Slow Convergence

Unanswered Question
Feb 4th, 2004

I have a hub and spoke network. My hub consists of 2 routers. The primary router connects to spokes via ISP MPLS VPN (CE is running BGP with PE) while the ISDN router served as backup, connects to spokes via 128k ISDN (floating static route method). We are using PRI at hub and BRI at spokes.

My IGP is EIGRP. BGP at primary router and static route at ISDN router are redistributed into EIGRP.

When the primary line is failed, the ISDN kick in successfully but the floating static route never appear in the hub's ISDN router routing table. External EIGRP route which indicates the best path to spokes is via primary router still appear in the ISDN router routing table, causing traffic cannot flow from hub to spokes via ISDN line. The external EIGRP route finally replaced by the floating static route after 2 minutes and 15 second. In other words, my WAN network take 2 minutes and 15 second to converge. 2minutes++ seems too long for me. How to reduce the convergence time significantly?

PRIMARY ROUTER CONFIG

C1#sh ru

Building configuration...

Current configuration : 2655 bytes

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname C1

!

!

ip subnet-zero

!

!

interface FastEthernet0/0

ip address 192.168.1.2 255.255.255.0

duplex auto

speed auto

!

!

interface FastEthernet0/1

ip address 202.163.53.214 255.255.255.252

duplex auto

speed auto

!

router eigrp 1

redistribute bgp 65001 metric 10000 100 255 1 1500

redistribute connected

network 192.168.1.0

no auto-summary

!

router bgp 65001

bgp log-neighbor-changes

network 0.0.0.0

neighbor 202.163.53.213 remote-as 9255

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.1.1

no ip http server

!

!

line con 0

logging synchronous

line aux 0

line vty 0 4

login

!

end

ISDN ROUTER CONFIG

C2#sh ru

Building configuration...

Current configuration : 2655 bytes

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname C2

!

controller E1 1/1

pri-group timeslots 1-31

!

username S1 password 0 abc

!

!

ip subnet-zero

!

isdn switch-type primary-net5

!

!

interface FastEthernet0/0

ip address 192.168.1.3 255.255.255.0

duplex auto

speed auto

!

!

!

interface Serial1/1:15

no ip address

encapsulation ppp

isdn switch-type primary-net5

ppp authentication chap

ppp multilink

dialer pool-member 1

!

interface dialer0

ip address 172.16.1.1 255.255.255.252

encapsulation ppp

dialer idle-timeout 300

dialer remote-name S1

dialer string 12345678

dialer load-threshold 125 either

dialer-group 1

dialer pool 1

ppp authentication chap

ppp multilink

!

router eigrp 1

redistribute static metric 128 2000 255 1 1500

redistribute connected

distribute-list 1 out static

network 192.168.1.0

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.1.1

ip route 192.168.2.0 255.255.255.0 172.16.1.2 250

!

no ip http server

!

access-list 1 deny 0.0.0.0

access-list 1 permit any

!

dialer-list 1 protocol ip permit

!

line con 0

logging synchronous

line aux 0

line vty 0 4

login

!

end

SPOKE ROUTER CONFIG

S1#sh ru

Building configuration...

Current configuration : 2655 bytes

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname S1

!

!

username C2 password 0 abc

!

!

ip subnet-zero

!

isdn switch-type basic-net3

!

!

interface FastEthernet0/0

ip address 192.168.2.1 255.255.255.0

duplex auto

speed auto

!

!

interface BRI0/0

ip address 172.16.1.2 255.255.255.252

encapsulation ppp

no ip route-cache

no ip mroute-cache

dialer idle-timeout 300

dialer map ip 172.16.1.1 name C2 87654321

dialer load-threshold 125 either

dialer-group 1

isdn switch-type basic-net3

ppp authentication chap

ppp multilink

!

interface FastEthernet0/1

ip address 172.22.31.165 255.255.255.252

duplex auto

speed auto

!

!

router bgp 65002

bgp log-neighbor-changes

network 192.168.2.0 mask 255.255.255.0

neighbor 202.163.53.217 remote-as 9255

neighbor 202.163.53.217 ebgp-multihop 2

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.16.1.1 250

ip route 202.163.53.217 255.255.255.255 172.22.31.166

!

no ip http server

!

dialer-list 1 protocol ip permit

!

line con 0

logging synchronous

line aux 0

line vty 0 4

login

!

end

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (1 ratings)
aretana Wed, 02/04/2004 - 13:15

Hi!

You are describing the case in which the physical link between the spoke and the provider fails...correct?? That's why the ISDN link comes up: the spoke detects it, eliminates the BGP-learned route and the floating static kicks in.

On the other hand, the Hub ISDN router has to wait for the routing to be updated through a longer path:

- the provider has to detect the failure in the local link (only this step is the same as the spoke)

- BGP in the provider's network has to propagate the routing change internally

- BGP has to propagate the change to the Hub CE

- BGP takes the route off the routing table

- EIGRP notices the change and removes the route from the network

- the floating static route kicks in the Hub ISDN router...

There are several steps that can contribute to the time you're seeing, but not everything is lost. IMHO, you may be able to reduce the 2+ minutes with some tunning. However, you really only have control over the part of the proces that happens in your network:

- BGP takes the route off the routing table

- EIGRP notices the change and removes the route from the network

- the floating static route kicks in the Hub ISDN router...

Once BGP receives the route withdraw, it take the route off the routing table right away... Likewise, EIGRP takes that information and pruges it immediatelly...and the static route kicks in right away. In other words, the process inside your network is negligible. The only thing that could be slowing you down internally is EIGRP's query process...but, assuming that there's no other route to the remote subnet, then this too should be pretty much nothing.

I ran a quick debug in the lab to make sure I'm telling the truth. :-) This is the equivalent of your Hub BGP router when the route is withdrawn:

Feb 4 19:51:02.320: BGP(0): 140.1.100.2 rcv UPDATE about 10.1.0.0/16 -- withdrawn

Feb 4 19:51:02.320: BGP(0): no valid path for 10.1.0.0/16

Feb 4 19:51:02.320: BGP(0): nettable_walker 10.1.0.0/16 no best path

Feb 4 19:51:02.320: RT: del 10.1.0.0/16 via 140.1.100.2, bgp metric [20/0]

Feb 4 19:51:02.320: RT: delete subnet route to 10.1.0.0/16

Feb 4 19:51:02.336: IP-EIGRP(Default-IP-Routing-Table:5): 10.1.0.0/16 - not in IP routing table

Feb 4 19:51:02.336: IP-EIGRP(Default-IP-Routing-Table:5): Ext 10.1.0.0/16 metric 4294967295 - 0 4294967295

Feb 4 19:51:02.352: IP-EIGRP(Default-IP-Routing-Table:5): Processing incoming REPLY packet

Feb 4 19:51:02.352: IP-EIGRP(Default-IP-Routing-Table:5): ExtS 10.1.0.0/16 M 4294967295 - 1249792 4294967295 SM 4294967295 - 1249792 4294967295

It takes it about 100ms...

Now this is the equivalent to your ISDN Hub:

Feb 4 19:51:02: IP-EIGRP(Default-IP-Routing-Table:5): Processing incoming QUERY packet

Feb 4 19:51:02: IP-EIGRP(Default-IP-Routing-Table:5): Ext 10.1.0.0/16 M 4294967295 - 0 4294967295 SM 4294967295 - 0 4294967295

Feb 4 19:51:02: RT: delete route to 10.1.0.0 via 140.1.10.49, eigrp metric [170/1787392]

Feb 4 19:51:02: RT: no routes to 10.1.0.0

By now you should know that the bulk of the time is being spent at the provider's network. Back to your original question: "How to reduce the convergence time significantly?". Go talk to your service provider. Show them the time difference between a link going down at a spoke and the BGP update being received at the Hub. There are some things they can change in the configs to help you out...

Good luck!

Alvaro.

lehpoh Thu, 02/05/2004 - 10:28

Thanks for your prompt reply, I will go and talk to my ISP.

Actions

Login or Register to take actions

This Discussion

Posted February 4, 2004 at 8:32 AM
Stats:
Replies:2 Avg. Rating:5
Views:222 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 2,069
2 1,736
3 1,675
4 1,624
5 1,529
Rank Username Points
5
5
5
5
5