Uploading IOS to switch

Unanswered Question
Feb 13th, 2004
User Badges:

We have a Catalyst 2900XL we need to configure, which has no IOS at all, the flash directory is completely empty.


XModem does not work, the switch does not respond to an Xmodem command, even when using hyperterminal.


We have followed all of the recommendations in "Recovery From Corrupt or Missing Software Image on Cisco Catalyst 2900XL and 3500XL Series Switches" to no avail. The documentation assumes that there is a boot file, whereas with our switch on bootup the message, "No boot File present" appears, which seems to be crucial for accepting any commands.


How can an IOS be uploaded to this switch?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
vkapoor5 Thu, 02/19/2004 - 06:42
User Badges:
  • Bronze, 100 points or more

It would have been helpful if you put exact error messages you got, but anyway if you are getting the prompt "Switch:" in ROMMON, I think the only option to upload an IOS image is through XMODEM command. If XMODEM is not working, then you could also try with different baud rates.

jwfinch Thu, 02/19/2004 - 07:31
User Badges:

The prompt we get is Switch:


When Xmodem fails, the exact error message received is "Remote system not responding" There was not other information, and it was simply displayed in a windows pop-up box.


Unfortunately trying with different baud rates, didn't get any response either, and the switch prompt didn't display in any baud rate apart from 9600.



Actions

This Discussion