DHCP Feature

Unanswered Question
Feb 25th, 2004
User Badges:

Hi,


i've got a problem with the DHCP feature on the Cisco Router:


When a PC with Windows 98 make a DHCP request, the subnet mask release by the router is 255.255.0.0

If the request is made by a PC with Windows XP or Windows 2000, I haven't got this problem (all ok).


If i do an IPCONFIG /RENEW (manually) on the PC with Windows 98, it takes the correct parametes.


You can understand that i can't say to all user with 98 to make IPCONFIG /RENEW..... ( i'll hope that when they power on the PC all is ok).


The configuration is correct.

NO DNS, NO WINS, NO PREFIX....

Only ip ,subnet and gateway.


I Repeat: The problem is only with Windows 98 PC.

I've the same problem with two different IOS.



This is the configuration


::::::::::::::::::::::::::::::::::::::::::::::::::

ip dhcp excluded-address 10.3.2.0 10.3.2.100

ip dhcp excluded-address 10.3.2.201 10.3.2.255

ip dhcp ping packets 3

!

ip dhcp pool 1

network 10.3.2.0 255.255.255.0

default-router 10.3.2.1

lease 3

!

:::::::::::::::::::::::::::::::::::::::::::::::::::


In this router (1721) the release software is 12.1(1)T.


Please, give me a feedback

Thanks for the support to all.



Diego

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
tbruce Fri, 02/27/2004 - 11:41
User Badges:

I use DHCP on Cisco2610 routers now and then. The only thing I don't see in your config is "no ip dhcp conflict logging" which I understand needs to be in the config. Do you have that statement in your configuration. I am using IOS 12.2(5) Have not had this issue with OS's 98,NT,2000 and XP.

Actions

This Discussion