×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

802.1q trunking 2611 to 3524

Unanswered Question
Mar 4th, 2004
User Badges:

Hi,


I'm trying to set up an 802.1q trunk between the buit-in 10meg ehternet port on a 2611 router and a cat 3524 switch. I am running release 12.2(11)T10 on the router. The subinterfaces will come up but I can not ping any devices on the vlans on the switches.


I know that 802.1q was not supported on the built-in interface till 12.2(2)T but should be with my version.


Are there any special caveats for configuring 802.1q trunking on these interfaces?


Thanks,


Joe

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
msdonahue Thu, 03/04/2004 - 10:08
User Badges:

Which feature set are you running? The are 14 feature sets available for 12.2(11)T10 but only 8 support 802.1q trunking.

Anonymous (not verified) Thu, 03/04/2004 - 12:06
User Badges:

What does your subinterface config look like? Do you mind posting it?

joe.pollere Thu, 03/04/2004 - 13:01
User Badges:

Here it is:


*********2600******************


interface Ethernet0/0

no ip address

no ip unreachables

no ip proxy-arp

duplex full

!

interface Ethernet0/0.1

encapsulation dot1Q 1 native

ip address 10.1.8.1 255.255.255.0

ip helper-address 10.10.10.56

no ip unreachables

!

interface Ethernet0/0.2

encapsulation dot1Q 2

ip address 192.168.8.1 255.255.255.0

ip helper-address 10.1.8.30

ip helper-address 10.10.10.56

no ip unreachables


*****3524***************************

interface FastEthernet0/24

description 2611 router E0/0

duplex full

speed 10

switchport trunk encapsulation dot1q

switchport mode trunk

switchport voice vlan 2

Anonymous (not verified) Mon, 03/08/2004 - 11:50
User Badges:

Your config looks good. That's exactly how I have mine configured and it works. I'm stumped. Sorry!

joe.pollere Mon, 03/08/2004 - 13:20
User Badges:

ok thanks...at least we know that the config is correct.


Appreciate your help.

milan.kulik Mon, 03/08/2004 - 23:46
User Badges:
  • Red, 2250 points or more

Hi,

I think this is the right moment to use a protocol analyzer.

Configure a SPAN (mirror) port on the switch mirroring the trunk traffic.

Connect a data analyzer (a PC running Ethereal freeware, e.g.) to it.

Try to Ping to/from the router and capture the ICMP frames.

You should see if your router sends/replies the correct frames.


Regards,

Milan

Actions

This Discussion