PIX 501 FTP config HELP

Unanswered Question
Mar 5th, 2004
User Badges:
  • Bronze, 100 points or more

Please excuse my noobness, but I need some help with FTP traffic to an internal server on my network. My configuration is pretty simple, i think.

Interfaces:

inside- 192.168.100.254 255.255.255.0

outside- 10.1.10.2 255.0.0.0

The outside IP comes from a Cisco broadband router that I don't have access to. All traffic is directed from our real external IP to the PIX through the router.


I have a FTP server with an internal IP of 192.168.100.13 and all I want to do is direct incoming FTP requests to my FTP server.


I have been using PDM, but also have a console connection.


Please help.....thank you


Dave

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mpalardy Fri, 03/05/2004 - 11:45
User Badges:
  • Bronze, 100 points or more

Hi Dave,

You'll have to do 3 statements to make this working


1)Map the IP address of your inside ftp-server to the outside interface:

static (inside, outside) 192.168.100.13 192.168.100.13 netmask 255.255.255.255 0 0


2)Add an access-list on your outside interface to permit ftp traffic:

access-list outside_access_in permit tcp 10.0.0.0 255.0.0.0 host 192.168.100.13 eq 21


3)Bind the access-list to the outside interface:

access-group outside_access_in in interface outside


You may refer to theses links:

http://www.cisco.com/univercd/cc/td/doc/product/iaabu/pix/pix_sw/v_63/cmdref/s.htm#wp1026694

http://www.cisco.com/univercd/cc/td/doc/product/iaabu/pix/pix_sw/v_63/cmdref/ab.htm#wp1067755


Also check for fixup protocol to permit pasv ftp.

Be sure to have this statement on the pix:

fixup protocol ftp 21

Connection will establish on port 21, and subsequent ftp commands on port 20. With this you wont need to manage port 20. PIX will open port 20 between hosts after port 21 was opened.

http://www.cisco.com/univercd/cc/td/doc/product/iaabu/pix/pix_sw/v_63/cmdref/df.htm#wp1067379


Hope this help,

Mike


Anonymous (not verified) Fri, 03/05/2004 - 12:28
User Badges:

Mike-


Wow....thanks for the quick response and great info. I just have one question.....


#1 you say to map the IP address of my ftp server to the outside interface:

static (inside, outside) 192.168.100.13 192.168.100.13 netmask 255.255.255.255 0 0


My outside interface IP is: 10.1.10.2 with netmask 255.0.0.0

Should the statement be:

static (inside, outside) 192.168.100.13 10.1.10.2 netmask 255.255.255.255 0 0 ???


I have fixup protocol ftp 21 entry already.

Thanks so much for your help.


Dave

mpalardy Fri, 03/05/2004 - 13:18
User Badges:
  • Bronze, 100 points or more

Dave,


Sorry, I should have wrote: "advertise the IP address of your ftp-server to the outside world".


When traffic is needed from lower to higher (eg outside to inside) security level interface, advertising the IP address of the inside ftp-server is required.


If you wish to use the real ip address of your server use the static command I've included in previous mailing.


Or you may advertise the server on a routable IP address on the outside network. eg

static (inside, outside) 172.16.32.64 192.168.100.13 netmask 255.255.255.255 0 0

In this case, users on the outside network will have to do this to access the inside ftp server

C:\>ftp 172.16.32.64


Do a "show xlate" and "show conn" commands on pix will help you to debug.


Mike

Anonymous (not verified) Mon, 03/08/2004 - 11:54
User Badges:

somebody please help!!

I just can't get this server going. Below is my current config. Whenever I set my FTP server's IP address to 192.168.100.13 I lose all connectivity, no internet connection or anything. If I change it to 192.168.100.14 I have access out, but of course the PIX will not let any FTP traffic in. Is the problem my router? My ISP has it configured to have an inside IP address of 10.1.10.2 and has assured me it will pass all data to the PIX.

Hmmm....I don't get it:(


Thanks for the help


Dave



: Saved

: Written by enable_15 at 06:20:15.110 UTC Mon Mar 8 2004

PIX Version 6.3(1)

interface ethernet0 auto

interface ethernet1 100full

nameif ethernet0 outside security0

nameif ethernet1 inside security100

enable password xxx

passwd xxx

hostname pixfirewall

domain-name ciscopix.com

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol ils 389

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

names

access-list ed_splitTunnelAcl permit ip any any

access-list inside_outbound_nat0_acl permit ip any 192.168.10.0 255.255.255.240

access-list outside_cryptomap_dyn_20 permit ip any 192.168.10.0 255.255.255.240

access-list outside_access_in permit tcp 10.0.0.0 255.0.0.0 host 192.168.100.13 eq ftp

pager lines 24

mtu outside 1500

mtu inside 1500

ip address outside 10.1.10.2 255.0.0.0

ip address inside 192.168.100.254 255.255.255.0

ip audit info action alarm

ip audit attack action alarm

ip local pool ippool 192.168.10.1-192.168.10.10

pdm location 192.168.1.0 255.255.255.0 inside

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list inside_outbound_nat0_acl

nat (inside) 1 0.0.0.0 0.0.0.0 0 0

static (inside,outside) 192.168.100.13 192.168.100.13 netmask 255.255.255.255 0 0

access-group outside_access_in in interface outside

route outside 0.0.0.0 0.0.0.0 10.1.10.1 1

timeout xlate 0:05:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server RADIUS protocol radius

aaa-server LOCAL protocol local

http server enable

http 0.0.0.0 0.0.0.0 outside

http 192.168.1.0 255.255.255.0 inside

http 0.0.0.0 0.0.0.0 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

sysopt connection permit-ipsec

crypto ipsec transform-set XXX

crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20

crypto dynamic-map outside_dyn_map 20 set transform-set XX

crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map

crypto map outside_map interface outside

isakmp enable outside

isakmp policy 20 authentication pre-share

isakmp policy 20 encryption 3des

isakmp policy 20 hash md5

isakmp policy 20 group 2

isakmp policy 20 lifetime 86400

vpngroup XXXX address-pool ippool

vpngroup XXXX dns-server 192.168.100.1

vpngroup XXXX split-tunnel XXXX_splitTunnelAcl

vpngroup XXXX idle-time 1800

vpngroup XXXX password x

telnet 0.0.0.0 0.0.0.0 inside

telnet 192.168.100.0 255.255.255.0 inside

telnet timeout 5

ssh 0.0.0.0 0.0.0.0 outside

ssh timeout 5

console timeout 0

dhcpd lease 3600

dhcpd ping_timeout 750

dhcpd auto_config outside

terminal width 80

Cryptochecksum:XXX

Anonymous (not verified) Mon, 03/08/2004 - 13:07
User Badges:

This server will only be used for FTP, and I would like to be able to have MX records point the domain name to the server if possible.


thx again

mpalardy Mon, 03/08/2004 - 13:11
User Badges:
  • Bronze, 100 points or more

Dave,


Can you setup a syslog server with debug information and post the result here.


Mike

Anonymous (not verified) Mon, 03/08/2004 - 13:32
User Badges:

I have not done that before. Can I just send the log to the console?

Anonymous (not verified) Mon, 03/08/2004 - 13:52
User Badges:

OK- I found the documentation for the syslog, but I will have to wait until tomorrow morning so I can test while there is no traffic on the network. It's almost 5pm here now, and I will run the syslog and capture output and post here around 8am tomorrow.


My email address is my name if you want to contact me off forum.


Thank you for your help.

Dave

sateeshk Mon, 03/08/2004 - 19:37
User Badges:

hi


try this


static(Inside,outside) 10.1.10.3 192.168.1.13 dont give mask...


Give the required access-list..


Regards

Sat

Anonymous (not verified) Wed, 03/10/2004 - 08:40
User Badges:

sorry for the delay in responding. work is pretty busy here, and I do much more than systems admin. anyway, thanks SO MUCH for the input. i may have another issue with the NIC in my linux box. i'm looking into it now, and will post the results here soon.


Dave

Actions

This Discussion