Troubleshooting "Gateway of last resort is not set"

Unanswered Question
Mar 9th, 2004

A router (R-1601) receives a default route via RIP from a L3 switch (C-6500).

R-1601 is also configured to generate a default route (default-information originate).

When everything is working fine (normal operation), the following can be seen from R-1601:

***********************************************************

Gateway of last resort is X.X.X.252 to network 0.0.0.0

<other info removed>

R* 0.0.0.0/0 [120/4] via X.X.X.252, 00:00:04, Ethernet0

[120/4] via X.X.X.253, 00:00:17, Ethernet0

[120/4] via Y.Y.Y.252, 00:00:04, Ethernet0

[120/4] via Y.Y.Y.253, 00:00:17, Ethernet0

***********************************************************

Both R-1601 and C-6500 are on the same building.

After a power failure, the following can be seen from R-1601:

***********************************************************

Gateway of last resort is not set

<other info removed>

R* 0.0.0.0/0 is possibly down, routing via Y.Y.Y.252, Ethernet0

***********************************************************

<R-1601 config>

!

interface Ethernet0

ip address Y.Y.Y.251 255.255.240.0 secondary

ip address X.X.X.251 255.255.255.0

!

router rip

version 2

redistribute static metric 4

passive-interface BRI0

network Y.Y.0.0

network X.X.0.0

default-information originate

!

no ip http server

ip classless

ip route Z.Z.0.0 255.255.0.0 BRI0 X.X.X.253 150

!

Is this normal? Because even after the C-6500 has finished booting up,

the route is still down. I was thinking that the routing table of R-1601

should be updated once it receives the default route from the C-6500.

I've used the following documents as my reference:

http://www.cisco.com/en/US/products/sw/iosswrel/ps1835/products_configuration_guide_chapter09186a00800ca765.html#1001036

http://www.cisco.com/en/US/tech/tk365/tk554/technologies_tech_note09186a0080094374.shtml

Any helpful input is greatly appreciated.

Ariel

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
gpauwen Tue, 03/09/2004 - 00:27

Hello,

after rebooting the 1601 issue the command:

debug ip rip

and

debug ip routing

Since RIP is usually slow converging, it might take a while. Or try to issue the command:

clear ip route *

on the 1601. Also, can you post the config of your 6500 as well ?

Regards,

GP

a.manosca Tue, 03/09/2004 - 01:05

First of all, thanks for your interest in this post, GP.

I'm afraid I can't reboot or debug the 1601 right now. Actually, the router was

already rebooted by our customer and I can say it's back to normal. I also thought

that clearing the routing table might resolve the issue. But we cannot do this

everytime a problem (power outage, link failure, etc.) occurs.

The 1601 router replaced another router. The previous router was a 7200.

I compared the old and new configs and I think one line was mistakenly erased.

ip route 0.0.0.0 0.0.0.0 X.X.X.254 200

The static route above was missing from the new config.

I'm thinking if this route has something to do with the problem.

I'd like to try adding it to the 1601 but still I won't be able to perform the test

on a live network.

Here's the 6500 config:

!

interface Vlan10

ip address Y.Y.Y.253 255.255.240.0 secondary

ip address X.X.X.253 255.255.255.0

no ip redirects

no ip unreachables

ip rip send version 2

ip rip receive version 2

standby 10 ip Y.Y.Y.254

standby 10 preempt

standby 20 ip X.X.X.254

standby 20 preempt

!

!

router rip

version 2

redistribute static metric 2

network A.A.0.0

network B.B.0.0

network C.C.0.0

network Y.Y.0.0

network X.X.0.0

distribute-list 10 out Vlan10

no auto-summary

!

No static default route is configured on this switch because the default

route/information is coming from another L3 switch.

Thanks again,

Ariel

Actions

Login or Register to take actions

This Discussion

Posted March 9, 2004 at 12:03 AM
Stats:
Replies:2 Overall Rating:
Views:738 Votes:0
Shares:0
Tags: No tags.
 

Discussions Leaderboard

Rank Username Points
1
thisisshanky
2,069
2
pkhatri
1,746
3
ankurbhasin
1,704
4
gpauwen
1,629
5
Richard Burts
1,583
Rank Username Points
xavierchang@hot...
5
Nandan Mathure
5
thiland
5
aacole
5
singhaam007
4