×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

ospf summary problem

Unanswered Question
Mar 9th, 2004
User Badges:

hi,

i have a 3 layered model:


corerouter (7206) distributionrouter (3640) any access-router (1760).


the 7206 and the 3640 are running ospf in a way that the 3640 gives a summary-route to the 7206 - e.g 10.20.0.0/16.


the 3640 then has static routes to the access-router

10.20.2.0 / 24

10.20.3.0 /24

and so on.


so the 7206 has no knowledge of the /24 networks behind the 3640.


is there any possibility, that the 7206 gets the summary routes (10.20.0.0 /16) AND the /24 networks??

(redistribute static or so)



reason:

we want to implement isdn-backup for some access-router to the core.

but the 7206 only knows the summary-route 10.20.0.0/16 and if we configa floating static over isdn to the network 10.20.2.0/24, the 7206 takes the path over isdn of course because of best match regardless which admin-distance we use for floating static route.


any idea ????


thanks for answer !

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Harold Ritter Tue, 03/09/2004 - 04:56
User Badges:
  • Cisco Employee,

Unlike BGP, OSPF doesn't allow you to advertise the summary and the more specific routes for that summary. One way to achieve what you want to do is to stop summarizing the /24s.


Hope this helps,

rabeder Tue, 03/09/2004 - 05:14
User Badges:

hi,

thanks for answer, but we have the solution:


it is possible to advertise both !!!


like this - with route-maps AND TAGs:

!

router ospf 65052

router-id 172.16.24.9

log-adjacency-changes

area 99 stub no-summary

area 99 range 10.22.216.0 255.255.248.0

redistribute connected

redistribute static subnets route-map isdn-backup

passive-interface default

no passive-interface Serial0/0.299

no passive-interface Serial0/0.699

network 10.22.216.0 0.0.7.255 area 99

network 172.16.24.9 0.0.0.0 area 0

network 172.16.25.28 0.0.0.3 area 0

network 172.16.25.128 0.0.0.3 area 0

network 172.16.26.9 0.0.0.0 area 0

!

route-map isdn-backup permit 10

match tag 99

set level backbone

!

ip route 10.22.216.1 255.255.255.255 Serial0/1 10.22.223.2 tag 99

ip route 10.22.217.0 255.255.255.0 Serial0/1 10.22.223.2 tag 99

ip route 10.23.122.0 255.255.255.192 Serial0/1 10.22.223.2 tag 99


so this 3 routes are advertised in the summary and

in these 3 routes too:

O IA 10.22.216.0/21 [110/1501] via 172.16.25.30, 01:49:59, Serial1/2.299

O E2 10.22.217.0/24 [110/20] via 172.16.25.30, 01:21:24, Serial1/2.299

O E2 10.22.216.1/32 [110/20] via 172.16.25.30, 01:21:24, Serial1/2.299

O E2 10.23.122.0/26 [110/20] via 172.16.25.30, 01:22:02, Serial1/2.299



If the link to this access-router fails, these 3 E2 routes are flushed from the table !!





Harold Ritter Tue, 03/09/2004 - 05:35
User Badges:
  • Cisco Employee,

My mistake, I thought you were summarizing using the summary-address command to filter the external routes.

Actions

This Discussion