ICM Webview Historical Data replication

Unanswered Question
Mar 22nd, 2004

I hve installed ICM 5.0 with Service Release 4 for a customer and I am not seeing any Historical data in Webview. Historical data repors only appear with 0 as entries or nulls. Real time reports apeear fine. Looking at some of the tables in SQL Enterprise Manager, I see data has replicated from the loggers for t_Termination_Call_Detail. Historical Data replication is enabled on the Loggers. Any suggestions?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 3.3 (3 ratings)
adignan Mon, 03/22/2004 - 16:53

When you say you are "Looking at some of the tables in SQL Enterprise Manager" I assume you are looking at the HDS database? Did you setup the HDS database with ICMDBA?

Thunderbird1 Tue, 03/23/2004 - 00:09

You may have lost the 'views' from the AWDB to the HDS. Check the AWDB Views for one of the historical tables and it will show if it is redirecting to the HDS.If not you will have to either change them all manually or write an SQL query to change all the views.(there may be a stored procedure for this or ask the TAC as they may have one already)

kazemik Tue, 03/23/2004 - 01:51

ICMDBA was used to create the HDS database. Also looking at the views on the HDS and they appear to be there.

Thunderbird1 Tue, 03/23/2004 - 02:19

To confirm that the views are working correctly run an SQL query ( e.g select * from Route_Call_Detail) against the AW database ( not the HDS and not the t_Route_Call_Detail table). Also check that you have data for the dates you speciied in the report. If you cannot see any data in the HDS for times specified you may need to check your retention settings. Also how full is the HDS database? Auto purge can cause the removal of some tables before others if the HDS isnt sized correctly.

kazemik Tue, 03/23/2004 - 05:19

I ran select * from Route_Call_Detail on the HDS, it is populated and there is data there for today. Retention is set to 60 days. The system is not live so there is enough data there to fill the 10 Gigs.

ICMDBA indicates that 0.21 is used.

Thunderbird1 Tue, 03/23/2004 - 05:40

Did you run the query from the HDS database or the AW database? It needs to be the AW database as this is where all the reports pick up the configuration and historical data ( via the AW database views)

kazemik Tue, 03/23/2004 - 07:02

I ran it against the _awdb. I have also ran the hdsgrant.sql against the same database. Still the same problem.

Thunderbird1 Tue, 03/23/2004 - 07:15

When you run the Webview Report are you logged into Webview as an Administrator? Set up a Webview user and try logging in as that user and re-running the report. Can you run the same report from Monitor ICM? does this work OK?

kazemik Tue, 03/23/2004 - 07:36

I am using a user created to access Webview through the ICM User List. Monitor ICM does not exist in ICM 5.0.

Thunderbird1 Tue, 03/23/2004 - 07:16

When you run the Webview Report are you logged into Webview as an Administrator? Set up a Webview user and try logging in as that user and re-running the report. Can you run the same report from Monitor ICM? does this work OK?

Thunderbird1 Tue, 03/23/2004 - 07:24

Did you also re-run through setup after creating the HDS? This is about all I can do to help from here, If you are still having problems You may have to put a call into the TAC

kazemik Tue, 03/23/2004 - 08:16

Sure did. I am going to run set up once more to see if it makes a difference.

Thanks for your help on this Brian.

Thunderbird1 Tue, 03/23/2004 - 08:25

You're welcome. If you do find the Answer to this can you post it back on here? I'm curious to find the answer as it may affect us in the future. Thanks

kazemik Wed, 03/24/2004 - 03:45

Response from TAC below:

I think what you are experiencing is a bug that was introduced in SR4 (CSCma25888). The issue is with WebView historical reports returning data with incorrect date span for European date formats. For Example - If the date selected on date picker page is August 12, then the data returned is for December 8.

Here is the work-around, however, it was fixed in ICM SR5 if you choose to install it:

Condition:

WebView server connected to database (MS SQL) with date

format as 'yyyy-dd-mm' (French, British-Eng...).

Workaround:

1) Locate 'pbodb80.ini' ('pbodb70.ini' for 4.6.x) file in '

Home>sharedPowerBuilder' directory.

2) Open the file in notepad

3) Locate following section

-------------------------------------

[MSSQLSERVER_DATETIME]

PBDateFmt=''yyyy-mm-dd''

PBTimeFmt=''hh:mm:ss''

PBDateTimeFmt=''yyyy-mm-dd hh:mm:ss.fff''

-------------------------------------

4) Modify the date format appropriately. For French system it would be

-------------------------------------

[MSSQLSERVER_DATETIME]

PBDateFmt=''yyyy-dd-mm''

PBTimeFmt=''hh:mm:ss''

PBDateTimeFmt=''yyyy-dd-mm hh:mm:ss.fff''

-------------------------------------

5) Restart 'Jaguar' and 'IIS ADmin' Services

Actions

Login or Register to take actions

This Discussion

Posted March 22, 2004 at 3:59 PM
Stats:
Replies:14 Avg. Rating:3.33333
Views:573 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard