Unity MMC Media Master issues

Unanswered Question
Mar 29th, 2004
User Badges:

Having problems with the MMC controls from Unity and from the client.


Background:


Cisco Unity 4.03 configured with failover.

Cisco Call Manager 3.3.3 SR 4A 2 node cluster.

All servers on the same VLAN

All servers are running gbit

All attached to same switch

All servers are HP Proliant DL380 G3

Secondary NICs are disabled.


Issue:


When playing a message (e.g. Opening Greeting) to an IP phone, I get intermittent failed attempts with occasional success. "Unknown problems are preventing playback" or something to that affect. This issue only occurs on the Primary server. The Secondary server works perfectly.


The only difference between the two installations (in terms of the actual install process) was that the primary had MSDE installed, then removed and SQL installed. I have found no DNS, name resolution, or other TCP/IP related issues on these servers.


I have opened a Cisco TAC case, but have had very little success bringing this to resolution. It would be nice if there were some troubleshooting steps I could look at, or some type of a trace file that would identify where the failure is occuring.


Any ideas?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
vharsha Mon, 03/29/2004 - 13:56
User Badges:

Do you see this problem with the SA and/or the Cisco PCA?


When you say the issue only occurs on the primary server, you mean you are launching the browser on the primary server, correct?


Micro traces for the TrapConnector might give some clues. Traces are logged in the AvCsMgr log files.

brent.morris Mon, 03/29/2004 - 16:25
User Badges:

Yes, with the SA, and also during playback through the VMO. Browser is launched from the primary server.


I just got a recommendation on a conference call to reinstall. I'd really like to avoid this, and I think the problem should be fixable.

brent.morris Mon, 03/29/2004 - 16:41
User Badges:

Also, can you give me more detail (or point in the direction) to turn on micro traces on the Trapconnector?

vharsha Mon, 03/29/2004 - 16:53
User Badges:

Unity Tools Depot > Diagnostic Tools > Unity Diagnostic Tool > Configure Micro Traces


Select all trace levels for the TrapConnector.


Reproduce the error.


Use the Unity Diagnostic Tool's Gather Log Files option to select the latest AvCsMgr log file.

brent.morris Mon, 03/29/2004 - 17:28
User Badges:

Here's the data, not very useful to me, but maybe you can see something I dont.


2004-03-30 00:49:10,-1,-1,data Data file opened 2004-03-30 00:49:10

2004-03-30 01:02:39,AvRepMgr_MC,30300,New Call,Port 1,1,31

2004-03-30 01:02:40,AvRepMgr_MC,30040,2004-03-29 17:02:40.187,BA9BDE299A254119BADBFDA96FF6B2EA,9

2004-03-30 01:02:41,AvRepMgr_MC,30040,2004-03-29 17:02:41.218,BA9BDE299A254119BADBFDA96FF6B2EA,1

2004-03-30 01:02:41,AvRepMgr_MC,30002,BA9BDE299A254119BADBFDA96FF6B2EA,1,2004-03-30 01:02:39,2004-03-30 01:02:41,CAPH-UNITY1

2004-03-30 01:02:41,AvRepMgr_MC,30040,2004-03-29 17:02:41.218,BA9BDE299A254119BADBFDA96FF6B2EA,4294967295

2004-03-30 01:02:41,AvRepMgr_MC,30300,Call Disconnect,Port 1,0,32

2004-03-30 01:02:42,AvRepMgr_MC,30300,New Call,Port 1,1,31

2004-03-30 01:02:42,AvRepMgr_MC,30040,2004-03-29 17:02:42.921,CC7E4D4129AD4DCE8357FF0C26EEC3C0,9

2004-03-30 01:02:47,AvRepMgr_MC,30040,2004-03-29 17:02:47.562,CC7E4D4129AD4DCE8357FF0C26EEC3C0,1

2004-03-30 01:02:47,AvRepMgr_MC,30020,2004-03-30 01:02:47,Patrick Brown,2005,12,1,N/A,N/A,2004-03-30 01:02:47,N/A,N/A,6009

2004-03-30 01:02:47,AvRepMgr_MC,30040,2004-03-29 17:02:47.906,CC7E4D4129AD4DCE8357FF0C26EEC3C0,2

2004-03-30 01:03:03,AvRepMgr_MC,30020,2004-03-30 01:03:03,Patrick Brown,2005,13,1,N/A,N/A,2004-03-30 01:03:03,N/A,N/A,6009

2004-03-30 01:03:03,AvRepMgr_MC,30002,CC7E4D4129AD4DCE8357FF0C26EEC3C0,1,2004-03-30 01:02:42,2004-03-30 01:03:03,CAPH-UNITY1

2004-03-30 01:03:03,AvRepMgr_MC,30040,2004-03-29 17:03:03.296,CC7E4D4129AD4DCE8357FF0C26EEC3C0,4294967295

2004-03-30 01:03:03,AvRepMgr_MC,30300,Call Disconnect,Port 1,0,32

2004-03-30 01:08:38,AvRepMgr_MC,30300,New Call,Port 1,1,31

2004-03-30 01:08:39,AvRepMgr_MC,30040,2004-03-29 17:08:39.125,EA7068C0AAE849ABB0E1D6A829BA1B18,9

2004-03-30 01:08:44,AvRepMgr_MC,30040,2004-03-29 17:08:44.375,EA7068C0AAE849ABB0E1D6A829BA1B18,1

2004-03-30 01:08:44,AvRepMgr_MC,30020,2004-03-30 01:08:44,Patrick Brown,2005,12,1,N/A,N/A,2004-03-30 01:08:44,N/A,N/A,6009

2004-03-30 01:08:44,AvRepMgr_MC,30040,2004-03-29 17:08:44.484,EA7068C0AAE849ABB0E1D6A829BA1B18,2

2004-03-30 01:09:03,AvRepMgr_MC,30020,2004-03-30 01:09:03,Patrick Brown,2005,13,1,N/A,N/A,2004-03-30 01:09:03,N/A,N/A,6009

2004-03-30 01:09:03,AvRepMgr_MC,30002,EA7068C0AAE849ABB0E1D6A829BA1B18,1,2004-03-30 01:08:38,2004-03-30 01:09:03,CAPH-UNITY1

2004-03-30 01:09:03,AvRepMgr_MC,30040,2004-03-29 17:09:03.281,EA7068C0AAE849ABB0E1D6A829BA1B18,4294967295

2004-03-30 01:09:03,AvRepMgr_MC,30300,Call Disconnect,Port 1,0,32

2004-03-30 01:11:43,AvRepMgr_MC,30300,New Call,Port 1,1,31

2004-03-30 01:11:44,AvRepMgr_MC,30040,2004-03-29 17:11:44.140,61D5D39258CF47769685E15F72B0AFA4,9

2004-03-30 01:11:49,AvRepMgr_MC,30040,2004-03-29 17:11:49.000,61D5D39258CF47769685E15F72B0AFA4,1

2004-03-30 01:11:50,AvRepMgr_MC,30020,2004-03-30 01:11:50,Patrick Brown,2005,12,1,N/A,N/A,2004-03-30 01:11:50,N/A,N/A,6009

2004-03-30 01:11:50,AvRepMgr_MC,30040,2004-03-29 17:11:50.125,61D5D39258CF47769685E15F72B0AFA4,2

2004-03-30 01:12:03,AvRepMgr_MC,30020,2004-03-30 01:12:03,Patrick Brown,2005,13,1,N/A,N/A,2004-03-30 01:12:03,N/A,N/A,6009

2004-03-30 01:12:03,AvRepMgr_MC,30002,61D5D39258CF47769685E15F72B0AFA4,1,2004-03-30 01:11:43,2004-03-30 01:12:03,CAPH-UNITY1

2004-03-30 01:12:03,AvRepMgr_MC,30040,2004-03-29 17:12:03.281,61D5D39258CF47769685E15F72B0AFA4,4294967295

2004-03-30 01:12:03,AvRepMgr_MC,30300,Call Disconnect,Port 1,0,32

brent.morris Tue, 03/30/2004 - 08:15
User Badges:

EVT_AVMIUMSG_CATASTROPHICFAILURE_FAIL_MAKECALL

ID: 564

Source: CiscoUnity_Miu

Message: Cisco Unity's telephony component has encountered a serious error.%n%nEXPLANATION:%nA serious failure has occurred on port %1 while placing an outgoing call. Most likely, parties involved in the call will be disconnected. In some cases, further calls on this port will not be handled correctly.%n%n%nTECHNICAL DETAILS:%nThread %2 had a Failure on Port %3 in Method %4%n%nDESCRIPTION: %5.%nDETAILS: %6.%nCALLINFO: %7.%nCALL SEQUENCE:%n%8.

Cisco Unity's telephony component has encountered a serious error.%n%nEXPLANATION:%nA serious failure has occurred on port %1 while placing an outgoing call. Most likely, parties involved in the call will be disconnected. In some cases, further calls on this port will not be handled correctly.%n%n%nTECHNICAL DETAILS:%nThread %2 had a Failure on Port %3 in Method %4%n%nDESCRIPTION: %5.%nDETAILS: %6.%nCALLINFO: %7.%nCALL SEQUENCE:%n%8.

brent.morris Wed, 03/31/2004 - 09:15
User Badges:

We followed the procedure in chapter four of the Unity failover guide to remove the primary server from the system. Basically, one must disable the AvsNodeMgr server on both servers and disable SQL replication.


Next, the server was deleted from Active Directory and totally rebuilt from scratch. We followed the Unity docs for installing a primary failover server. Once the server was up, we tested the voice mail against the new server and it worked great. There were no Temp Fail errors on the phone or error when playing messages via the MMC.


We then installed Unity 4.03 SR1 and tested again. It still worked great.


Then, the database was restored from the backup done earlier. More testing - still works great. All data was restored and the directory was intact as well as all of the old messages. Too cool!!!


We ran the failover configuration wizard on both servers. CAPH-UNITY1 is active (primary), CAPH-UNITY2 is inactive. Tested and failed. We get a Temp Fail on every phone every time. If I force a failover to the backup, it works fine.


I disabled the AvsNodeMgr on both servers. And stopped Unity on CAPH-UNITY2. This gets us back to a single server again. I tested it and it works.


The problem has something to do with the failover config. I don't know what but if I reenable failover the issue manifests itself.


Please help!

bmabee002 Wed, 05/04/2005 - 05:39
User Badges:

Brent,


I am having the same symptoms. Did you ever get a resolution to your problem?


Regards,

Bryan

brent.morris Wed, 05/04/2005 - 06:31
User Badges:

Yes, I believe the failover portion was misconfigured on the callmanager side.

Actions

This Discussion