How to disable spanning-tree on Catalyst 3750 switches ?

Answered Question

Hello,


I would like to fully-disable spanning-tree on a Catalyst 3750, but a stp process is still running:


swr-A#sh spanning-tree

MST00

Spanning tree enabled protocol mstp

Root ID Priority 32768

Address 0005.01af.870a

Cost 200000

Port 113 (FastEthernet3/0/7)

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32768 (priority 32768 sys-id-ext 0)

Address 000e.d71b.9c00

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Interface Role Sts Cost Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Fa3/0/1 Desg FWD 200000 128.107 P2p

Fa3/0/3 Desg FWD 200000 128.109 P2p

Fa3/0/4 Desg FWD 200000 128.110 P2p

Fa3/0/5 Desg FWD 200000 128.111 Edge P2p

Fa3/0/6 Desg FWD 200000 128.112 Edge P2p

Fa3/0/7 Root FWD 200000 128.113 Shr Bound(STP)

Po1 Desg FWD 100000 128.616 P2p Bound(PVST)

Po2 Desg FWD 100000 128.624 P2p Bound(PVST)

Po3 Desg FWD 100000 128.632 P2p Bound(PVST)

Po4 Desg FWD 100000 128.640 P2p Bound(PVST)

Po5 Desg FWD 100000 128.648 P2p Bound(PVST)


However, I disabled spanning-tree on each VLAN:

swr-A#sh run | inc spanning-tree

spanning-tree mode mst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

no spanning-tree vlan 1-2,100-116,900-901


I did the same way to disable spanning-tree on a Catalyst 3550:

swr-B#sh run | inc spanning-tree

spanning-tree mode pvst

spanning-tree extend system-id

no spanning-tree vlan 200

no spanning-tree vlan 201

no spanning-tree vlan 202

no spanning-tree vlan 203

no spanning-tree vlan 204

no spanning-tree vlan 205

no spanning-tree vlan 900

no spanning-tree vlan 901


And it worked:

swr-B#sh spanning-tree

No spanning tree instance exists.


Why can I not disable spanning-tree on a 3750 switch ?


Regards,


Philippe Muller

Correct Answer by michelpe about 13 years 4 months ago

Philippe,


On this box you are running MST (Multiple Spanning Tree) so disabling spanning tree per vlan doesn't work.


To be able to have the no spanning-tree vlan x

tob e effective you should configure

spantree mode pvst

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
michelpe Thu, 04/01/2004 - 19:34
User Badges:
  • Cisco Employee,

Philippe,


On this box you are running MST (Multiple Spanning Tree) so disabling spanning tree per vlan doesn't work.


To be able to have the no spanning-tree vlan x

tob e effective you should configure

spantree mode pvst

michelpe Thu, 04/01/2004 - 19:34
User Badges:
  • Cisco Employee,

that should read:

spanning-tree mode pvst

Actions

This Discussion