Unity 4.0(3) / Ex2k3 Cluster - Messages stuck in \unityMta

Unanswered Question
Apr 5th, 2004
User Badges:

Hello All,


Ran into a strange one. All messages from outside were AWOL. Found them all sitting in commserver\unitymta. Found another thread that talked about bouncing AcUMRSyncSvr. Bounced it and all 600+ messages were delivered in a few seconds.


Exchange environment is Exchange 2003 Enterprise in a 4 node Active/Active/Active/Passive cluster. Looks like the partner server (EX03) had been failed over to another node around the time the problem presented. Actually, it had been failed over a few times during the night as the exchange crew were working on the cluster. Each time, the UMR service went offline and then reconnected when it came back online. The last time, it had a new error message with Event ID 144:


"Could not retrieve Outside Caller Object. The UMR will not function correctly until this is addressed. Please call technical support. 0x00000F2C"



Outside callers could leave messages. Inside users would not receive them, nor would they get MWI.


I think, but need to verify, that they didn't get any indication when dialing in to check their messages that a message was waiting or the standard message that comes up when the partner server is down. I was working it remotely, so I'm not positive about this.


In researching, I determined that the partner server is not running MTA. I found an article that mentioned to use the cluster node that is running the MTA. Is this really the only issue? I can re-home it, but I just wanted to make sure we didn't have a bigger issue that could cause this problem to crop up again.


Thanks,

Vance

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
yshraybman Tue, 07/19/2005 - 09:16
User Badges:
  • Bronze, 100 points or more

hi, i'm having exactly the same issue with 4.0(3) EX2003. messages from pstn are being stuck in UnityMta folder. after restarting the service messages are delivered all at once. did you ever find the resolution? thanks.

kechambe Tue, 07/19/2005 - 17:37
User Badges:
  • Gold, 750 points or more

It's really hard to say without a better sample of the event log but there are some conditions in 4.0(3) which would cause this to occur.


We worked with Microsoft to correct some issues in their MAPI code. Exchange 2003 SP1 has some new functionality which will allow Unity to reconnect to a new GC for MAPI resolution if the current one goes down. To take advantage of this you will need to update to Unity 4.0(4) or later and apply Exchange 2003 SP1 on the Unity server.


Thanks,

Keith

Actions

This Discussion