PBR with 3550-12G problem

Unanswered Question
Apr 7th, 2004
User Badges:
  • Bronze, 100 points or more

I have 3 vlans (ID 101~103) enable ip routing

ip route 0.0.0.0 0.0.0.0 gateC

3 defferent gateway at vlan103

gateA,B,C which has static route vlan101,2 gw vlan103

and direct connect to internet

For some reasons I need put

vlan101(some-IP) route to internet from gateA

vlan101(other-IP) route to internet from gateB

vlan102,103 route to internet from gateC

I use access-list and PBR to perform this

It's my configure

access-list 101 permit ip any (vlan102~103)

access-list 102 permit ip some-IP any

access-list 103 permit ip vlan101 any

access-list 112 permit ip vlan102 any

access-list 113 permit ip vlan103 any

route-map test permit 10

match ip address 101

set ip nexthop gateC

route-map test permit 20

match ip address 102

set ip nexthop gateA

route-map test permit 30

match ip address 103

set ip nexthop gateB

route-map test1 permit 10

match ip address 112

set ip nexthop gateC

route-map test2 permit 10

match ip address 113

set ip nexthop gateC

interface vlan101 apply route-map test

interface vlan102 apply route-map test1

interface vlan103 apply route-map test2


Problem 1

I found host (pc) in vlan102,3 to internet is very slowly....

but traceroute is ok


Problem 2

pc host in vlan101 traceroute to pc in vlan102 will first go gateC then 3550(vlan102)

(it should skip gateC )

...BPR should low piro then director connect...


routing seems no fair...


any suggest ??

thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
carenas123 Wed, 04/14/2004 - 07:56
User Badges:
  • Silver, 250 points or more

Please check the following possible problems....


1. VLAN 102 and 103 pointed towards Gateway C. And may be this gateway link to Internet is congested enough, so that feeling slow response.


2. For the second problem, it's purely depends upon your configuration. I am not clear about your configuration, but please check with and without route-maps on VLAN 101 and 102 interfaces and removing route-map on only one interface at once. There should be some routing configuration to point to Gateway C first.

Actions

This Discussion