Upgrade CCM cluster to 3.3.3 version problem

Unanswered Question
Apr 8th, 2004
User Badges:

Hello


Today I was trying to upgrade our CCM Call Manager Cluster from 3.3.2 to 3.3.3 version. Unfortunately following problem has occured.


When I was trying upgrade subscriber (after I install CCM 3.3.3 on publisher) I got following error message:

---

Failure occurred trying to get DBNAME value from registry. Aborting Cisco CallManager installation.

---

I suppose that I have made mistake rebooting publisher before upgrading subscriber. I have noticed in SQL enterprise manager that on publisher there is two databases : CCM300 and CCM301.

Only CCM301 is published


On subscriber there is only subscription of CCM300. Now I see that IP telephony system works but I can't proceed instalation on subscriber.


Has anybody had any experience regarding that problem ?


If you need more information I will provide it to you as soon as possible



Thanks in advance

Michal Borgul

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
sarmentrout.bok77 Thu, 04/08/2004 - 16:15
User Badges:

I had the same exact problem when upgrading. I had to call TAC and they had to get into the registry of the subscriber to point it to the right database. I wish I could tell you more, but they seemed to know exactly what the problem was because it is a known problem when performing the upgrade to 3.3.3.

mborgul Fri, 04/09/2004 - 03:08
User Badges:

Hello,


I got information that I should create dbname.ini and backup.ini files on subscriber. I have done this but It doesn't solve problem. I made additionally changes to Dbname Key in registry from CCM300 to CCM301. But it doesn't help too....


Michal Borgul

mborgul Fri, 04/09/2004 - 07:33
User Badges:

Hello,


I have some additional information.


I have noticed that Cisco tool called

Database Helper shows wrong name assigned to subscriber.


But I have checked LMHOSTS file and there is correct entries for exmaple:


10.81.1.8 TORCCM01 -our publisher

10.81.1.9 TORCCM02 -our subscriber


Database Helper shows following information


TORCCM01 10.81.1.8

TORCCM01 10 81.1.9


There is a following comment


Duplicate server found. Don't process.


It seems that it could be due to name resolution problem. But I see that LMhosts file is configured properly. In our CCM configuration we use IP addreses instead of DNS names.


So I hope maybe that information is a key to solve that problem


Best regards,

Michal

6rdold Mon, 05/24/2004 - 06:29
User Badges:

Hi


I`m having the same problem with my Subscriber, My Publisher did it until the 5th installation.


Has anyone got this working yet?

I'm also having the same problem. I have run DBL Helper and I have 2 problems. I have the same as ref above, duplicate name but I cannot find where the duplicate name is, also I have deleted an old subscriber and re built it and in the DNS part it is showing up as the new IP but the old name. I have checked the lmhosts file and when I run the nbtstat -c I get the correct names.

Any ideas?

Actions

This Discussion