DNS not resolving

Unanswered Question
May 13th, 2004

I have the following configuration on a CISCO AP 1100

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname OLS

!

clock timezone EST -5

clock summer-time EDT recurring

ip subnet-zero

ip name-server 216.162.32.10

ip name-server 216.162.32.20

ip dhcp excluded-address 192.168.100.20 192.168.100.254

ip dhcp excluded-address 192.168.0.1 192.168.100.10

!

ip dhcp pool ols

network 192.168.100.0 255.255.255.0

lease 10

!

aaa new-model

!

!

aaa group server radius rad_eap

!

aaa group server radius rad_mac

!

aaa group server radius rad_acct

!

aaa group server radius rad_admin

!

aaa group server tacacs+ tac_admin

!

aaa group server radius rad_pmip

!

aaa group server radius dummy

!

aaa authentication login eap_methods group rad_eap

aaa authentication login mac_methods local

aaa authorization exec default local

aaa authorization ipmobile default group rad_pmip

aaa accounting network acct_methods start-stop group rad_acct

aaa session-id common

!

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

ssid OLSWireless

authentication open mac-address mac_methods

!

speed basic-1.0 basic-2.0 basic-5.5 basic-11.0

rts threshold 2312

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface BVI1

ip address 192.168.100.149 255.255.255.0

no ip route-cache

!

ip default-gateway 192.168.100.100

ip http server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag/ivory/1100

radius-server authorization permit missing Service-Type

bridge 1 route ip

!

!

banner login This is a private network... Please logoff if you are not a authorized user... Thank you...

!

line con 0

line vty 5 15

!

end

As you can see from the configuration, the AP has a user defined dhcp pool, my network does not have a DHCP server at this time.

DNS works from the AP itself. I'm able to ping ip addresses on the wired network and on the wireless side. I can ping domains (www.yahoo.com, www.cnet.com).

However, on the wireless side I can only ping internal ip addresses (192.168.100) either on the wired or wireless part of the network. When I try to surf the internet I get a DNS error. However, if I use the ip address of the website I can connect.

When I do an ipconfig on my laptop, it shows all the ip addresses except the DNS ip address.

Any ideas what I need to do? All assistance is appreciated and thanks in advance

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (1 ratings)
ebreniz Wed, 05/19/2004 - 11:06

Try using Ap(config)#ip dhcp pool

Include DNS sever name in this so that its propagated to the clients through bootP protocol.

Ap(dhcp-config)#?

DHCP pool configuration commands:

bootfile Boot file name

client-identifier Client identifier

client-name Client name

default-router Default routers

dns-server DNS servers

domain-name Domain name

exit Exit from DHCP pool configuration mode

hardware-address Client hardware address

host Client IP address and mask

import Programatically importing DHCP option parameters

lease Address lease time

netbios-name-server NetBIOS (WINS) name servers

netbios-node-type NetBIOS node type

network Network number and mask

next-server Next server in boot process

no Negate a command or set its defaults

option Raw DHCP options

scuba79 Thu, 05/20/2004 - 05:12

Thanks for the help. I found out about the dns entry after some searching, since the manual does not say anything about it..

Actions

Login or Register to take actions

This Discussion

Posted May 13, 2004 at 10:44 AM
Stats:
Replies:2 Avg. Rating:5
Views:314 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard