RIP and routing tables

Answered Question
Oct 11th, 2004

Router_A has the following table:

172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks

C 172.16.0.232/29 is directly connected, Ethernet0

R 172.16.0.4/30 [120/1] via 172.16.0.1, 00:00:22, Serial0

C 172.16.0.0/30 is directly connected, Serial0

C 192.168.1.0/24 is directly connected, Ethernet0

-----------------------------------

Router_B (directly connected to A) has:

172.16.0.0/30 is subnetted, 2 subnets

C 172.16.0.4 is directly connected, Serial3

C 172.16.0.0 is directly connected, Serial0

R 192.168.1.0/24 [120/1] via 172.16.0.2, 00:00:11, Serial0

--------------------------------------------

Why is 172.16.0.232/29 not advertised in Router_B? I've tried with auto-summary enabled and disabled. (Notice that the 192.168.1.0/24 subnet is advertised and it is a secondary ip address on the same interface.)

Thanks,

John

I have this problem too.
0 votes
Correct Answer by Harold Ritter about 9 years 6 months ago

You seem to be using RIP. I would definitely try using RIPv2, as RIP doesn't support VLSM.

Hope this helps,

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 4.5 (3 ratings)
tom.storey Mon, 10/11/2004 - 21:35

John,

I had a similar problem to this.

I have a SOHO 77 ADSL router, and 2 x 2514 routers. Ethernet0 from all 3 routers were plugged into a switch. The SOHO router had IP 172.25.84.1, and the 2514's were .2 and .3.

What I found is that the routes from the SOHO router werent comming up on one of my 2514's but they were on the other, both 2514's had each others routes, and the SOHO was getting both 2514's routes.

Just playing around I changed the SOHO's IP address to .6 and it all started to work fine.

Try changing router B's IP address and see what happens.

Cheers,

Tom

thomas.aure@egr... Tue, 10/12/2004 - 00:09

This is probably due to the classfull nature of RIP.

You should use "ip classless" or another routing protocol (i.e RIPv2).

tom.storey Tue, 10/12/2004 - 16:35

I was using RIPv2 and have ip classless on. Just wouldnt work when its IP address was 172.25.84.1

I am investing in a 2620 router. Once I have that I will be using EIGRP between all routers (with RIP redistribution to the SOHO 77 router).

Cheers,

Tom

Harold Ritter Tue, 10/12/2004 - 17:57

What was the IP address of the link between the two routers? Did you have "no auto-summary" configured?

Hope this helps,

Harold Ritter Tue, 10/12/2004 - 17:37

"ip classless" is just use at the forwarding plane level. It has nothing to do with how RPs behave.

Hope this helps,

Correct Answer
Harold Ritter Tue, 10/12/2004 - 17:42

You seem to be using RIP. I would definitely try using RIPv2, as RIP doesn't support VLSM.

Hope this helps,

jrgarrigues Thu, 10/14/2004 - 17:59

I thought that I verified I was using RIPv2, but I wasn't. Enabled v2 and updates produced the correct (desired) result. Thanks hritter.

majorward Mon, 10/18/2004 - 08:54

You must remember that is you are deploying RIP vsersion 1 on the two routers that RIP does not have the provisions to route via "subnet-mask" information.

The RIP version 1 datagram sets the subnet field to (unused). When the request command field is altered and forwarded in the RIP datagram to the router, the router repsonds with a response and the subnet mask field in the RIP datagram is unusable, the host will only forward the routing information pertaining to the entitiy and it will also forward the metric of the next hop as 16.

You can execute two methods to route between different subnets on the same data-link with RIP version 1.

1) Create secondary interfaces on the data-links and configure them with a different subnet. Enter the different subnets in the router with the command after router RIP.

2) Use the command to manipulate the metric to forward an unfavorable metric to the data-link you don't wan't the traffic forwarded to.

3) Or enable RIP version 2 on all RIP enabled interface so the subnet mask/next-hop filed in the RIP datagram will be processed by the hosts.

kevin.dorrell Sun, 11/07/2004 - 18:38

I tried out your topology in the lab because I was interested in finding out more about the behaviour of RIPv1 in the presence of subnetting.

What this illustrates is that RIPv1 can handle subnetting so long as two rules are obeyed:

1. all subnets of the network must be contiguous,

2. only one netmask is allowed.

Here we have a case where the second rule has been broken. The Ethernet of router A has the address 172.16.0.232/29. The link from router A to router B has the address 172.16.0.1/30. Router A believes that router B will only understand subnets with a /30 netmask, so it does not tell router B about 172.16.0.232, which has a netmask of /29.

If you changed the netmask of the link to /29, then the route for the 172.16.0.232 would turn up in router B. Of course, you should change the netmask at both ends of the link, and you will have to move the address of router B S3 as well to avoid a conflict, and the mask of router B S3 whould be changed as well.

Kevin Dorrell

Luxembourg

Actions

Login or Register to take actions

This Discussion

Posted October 11, 2004 at 8:41 PM
Stats:
Replies:9 Avg. Rating:4.5
Views:428 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 2,069
2 1,732
3 1,675
4 1,624
5 1,529