OSPF Stub Area

Unanswered Question
Oct 14th, 2004

I have try to set OSPF with Stub Area, after tested, I get ping Lan and Internet IP from PC but

I don't know is it success or not. I have something don't understand.

(1) From OSPF theorem, each router must at lease one interface belongs to area0, othterwise virtual-link is needed,

but from my lab, 1720A seems is not follow the rule, is stub area no need to from virtual-link?

(2) From OSPF theorem, external routes are not propagated inside stub area, stub area router (1720A),

that means when 1720B gerneted default route and propagate to 2620, then it will stop to propagate to 1720A.

But why 1720A now finally can access internet ?

A18 = Area 18, A0=Area0

Pc ->(A18) 1720A (A18) -> (A18) 2620 (A0) ->A(0) 1720B A(0) -> NAT Router(192.168.169.254)

1720A#sh ru

!

interface Loopback0

ip address 2.2.2.2 255.255.255.0

!

interface FastEthernet0

ip address 192.168.0.80 255.255.255.0 secondary

ip address 172.0.0.5 255.255.255.252 secondary

ip address 10.0.0.1 255.255.255.0 secondary

ip address 172.0.0.193 255.255.255.192

speed auto

!

interface Serial0

ip address 172.0.0.2 255.255.255.252

!

router ospf 20

log-adjacency-changes

area 18 stub

network 10.0.0.0 0.0.0.255 area 18

network 172.0.0.0 0.0.0.3 area 18

network 172.0.0.4 0.0.0.3 area 18

network 172.0.0.192 0.0.0.63 area 18

network 192.168.0.0 0.0.0.255 area 18

!

ip classless

no ip http server

!

2620#sh ru

!

ip subnet-zero

!

interface Loopback0

ip address 3.3.3.3 255.255.255.0

!

interface Ethernet0/0

no ip address

ip nat outside

!

interface Serial0/0

description connect to RouterB

ip address 172.0.0.1 255.255.255.252

ip nat inside

no fair-queue

clockrate 4000000

!

interface Ethernet0/1

no ip address

!

interface Serial0/1

description connect to RouterA

ip address 172.0.0.21 255.255.255.252

clockrate 4000000

!

router ospf 20

log-adjacency-changes

area 18 stub

network 172.0.0.0 0.0.0.3 area 18

network 172.0.0.20 0.0.0.3 area 0

!

end

1720B#sh ru

!

ip subnet-zero

!

interface Loopback0

ip address 1.1.1.1 255.255.255.255

!

interface FastEthernet0

ip address 192.168.169.252 255.255.255.0

ip nat outside

speed auto

!

interface Serial0

no ip address

shutdown

!

interface Serial1

ip address 172.0.0.22 255.255.255.252

ip nat inside

!

router ospf 20

log-adjacency-changes

network 172.0.0.20 0.0.0.3 area 0

network 192.168.169.0 0.0.0.255 area 0

default-information originate

!

ip nat inside source list 1 interface FastEthernet0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.169.254

no ip http server

!

access-list 1 permit 192.168.0.0 0.0.0.255

access-list 1 permit 10.0.0.0 0.0.0.255

!

end

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (1 ratings)
Richard Burts Thu, 10/14/2004 - 09:59

I am not sure where you got this:

(1) From OSPF theorem, each router must at lease one interface belongs to area0, othterwise virtual-link is needed,

but it is certainly not true that each router must have at least one interface in area 0. That is only true of ABR (Area Border Router).

2) It is true that in stub areas there is no advertisement of external routes generated from an ASBR. In your example the 1720B generates a default route and advertises it to the 2620 through area 0. The 2620 advertises the default route to 1720B through area 18. The default route is what allows 1720B to access the internet. But there are no external routes in the OSPF table of 1720B.

HTH

Rick

acbennyma Thu, 10/14/2004 - 18:57

Yes, you are right,

Pls ignore question 1, I think i know the concept clearly now.

for question 2, is it means that the default route originally is generated by 1720B(ASBR) and propagate to 2620, then 2620 (ABR) will generate another default route AUTOMATICALLY ?

Harold Ritter Thu, 10/14/2004 - 19:32

The ABR injects a default route as a lsa type 3 in the stub area by default no matter if it has a default route in the RIB or not.

Hope this helps,

acbennyma Thu, 10/14/2004 - 23:19

Thx !

Stub area only receive default route from ABR(2620) type3 LSA but I haven't enter any default route command in 2620 (default-information originate ). That 's why I want to ask is it means after 2620 receive Type5 default route , it will convert to Type3 default route automatically and propagate to Stub area ?

Harold Ritter Fri, 10/15/2004 - 04:01

The ABR doesn't convert the type 5 lsa into a type 3 lsa.

The ABR doesn't need any special configuration to generate the default route in the stub area. It doesn't need to receive a default route or have a default route installed in the RIB either. It generates the lsa type 3 default route in the stub area by default.

Hope this helps,

Actions

Login or Register to take actions

This Discussion

Posted October 14, 2004 at 9:02 AM
Stats:
Replies:5 Avg. Rating:5
Views:344 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 2,069
2 1,732
3 1,675
4 1,624
5 1,529