Received 802.1Q BPDU

Unanswered Question
Dec 10th, 2004

I very curious about i received 8021.Q BPDU, I think that very simple architecture and no any loop and trunk

I on Catalyst 6509 creat a vlan 15 then assign IP , An Catalyst 2950 24th port connecting the vlan 15 .

I am very sure no any loop cause and the catalyst 2950 just only one port connected right now

I configure between (6509 & 2950) below

interface GigabitEthernet1/24

no ip address

switchport

switchport access vlan 15

switchport mode access

interface FastEthernet0/24

no ip address

switchport

switchport access vlan 15

switchport mode access

During 10 ~ 15 second , I had received the message

"00:43:05: %SPANTREE-7-RECV_1Q_NON_TRUNK: Received 802.1Q BPDU on non trunk FastE

thernet0/24 VLAN15.

00:43:05: %SPANTREE-7-BLOCK_PORT_TYPE: Blocking FastEthernet0/24 on VLAN0015. Inc

onsistent port type."

But if i chang switchport mode access to Trunk , It's OK . any one can tell me why

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
a.kumaresan Fri, 12/10/2004 - 19:16

CDP, VTP, and PAgP packets are always sent on VLAN 1.So it necessary to have trunk port when the port is connected to other switch.

Regarding the error message:

Explanation This message means that the listed interface on which a Shared Spanning Tree Protocol (SSTP) BPDU was received was in trunk mode but was not using 802.1Q encapsulation. The first [chars] is the port, and the second [chars] is the VLAN.

Recommended Action Verify that the configuration and operational state of the listed interface and that of the interface to which it is connected are in the same mode (access or trunk). If the mode is trunk, verify that both interfaces have the same encapsulation (ISL or 802.1Q). If the encapsulation types are different, use the switchport trunk encapsulation interface configuration command to make them consistent. When the encapsulation is consistent, spanning tree automatically unblocks the interface.

emily@dragon99.... Sat, 12/11/2004 - 06:57

Thanks for your reponse

I am very sure that configure of the catlyst 6509 & 2950 was in access mode 。I would like to know if i have configure VTP domain between 6509 & 2950 , is need to trunk on between 6509 & 2950 ???

According to previous experience , I just change Catalyst 2950 to Trunk (6509 is still on access mode) , the interface automatically unblocks

kevin.dorrell Sat, 12/11/2004 - 11:11

I'm not sure I understand your question, but I'll have a go at it: VTP will only run over atrunk link. If you link two switches just via access ports, VLAN information will not pass from server to client.

Kevin Dorrell

Luxembourg

ankbhasi Mon, 12/13/2004 - 04:01

Even if you configure VTP domains on Cat6k and 2950 switch it is not necessary to configure trunk ports. You can still keep the switches connected via access ports. The only resule will be vlan information will not be passed from VTP server to VTP client.

The error message you are getting is due to inconsistent vlan config. Do you have any other port on cat6k connected to another switch as trunk where vlan 15 is working as a Native Vlan??

Ankur

Actions

Login or Register to take actions

This Discussion

Posted December 10, 2004 at 6:27 PM
Stats:
Replies:4 Avg. Rating:
Views:3631 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 2,069
2 1,732
3 1,675
4 1,624
5 1,529