rommon 1> and confreg 0x2102

Unanswered Question
Apr 26th, 2005

I have got cisco router 2600,If I start the router I see this prompt: "rommon1>"

I typed in: "confreg 0x2102" and then reset, still the same prompt.

Then I tried to type in: "confreg 0x2142" and resst, still the same prompt.

What should I do to solve this issue?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
mfreijser Wed, 04/27/2005 - 00:33

The commands you used sets the correct configuration register value for your router to start up like it is supposed to do. It goes back to ROMmon because the router's Cisco IOS software image and bootflash image are both corrupt.

Since you have already determined that the cause of the router booting up in ROMmon is not due to the configuration register value, the only option available for recovery is to re-install or upgrade the Cisco IOS software.

You can find information about installing Cisco IOS using Xmodem here :

http://www.cisco.com/en/US/products/hw/routers/ps259/products_tech_note09186a008015bfac.shtml

Regards,

Michaël

gpauwen Wed, 04/27/2005 - 00:41

Hello,

check if you have a valid IOS with the command:

rommon>dir flash:

If you see a valid image, try to boot manually with the command:

rommon>boot flash:c2600-i-mz.122-10b.bin (the image name is just an example, obviously you will have to use whatever image name you find with the 'dir flash:' command.

If there is no valid IOS, you will have to do a ROMmon recovery, check this link for the procedure:

ROMmon Recovery for the Cisco 2600 Series Router

http://www.cisco.com/en/US/products/hw/routers/ps259/products_tech_note09186a0080094a0b.shtml

Regards,

GP

zillah2004 Wed, 04/27/2005 - 03:14

Thanks Michaël and GP

The problem was with IOS, now it is working fine.

One more question, the documentation that Michaël

posted is advising to change baud rate for console from 9600 to 115200, by using confreg command.

Now after we downloaded image to our router, and it is working fine, how can we restore the default value for console (9600) ? Do we need to do it form confreg again?Or there is another option?

mfreijser Wed, 04/27/2005 - 03:30

To change the console speed, you have to enter the following commands:

Router# configure terminal

Router(config)# line console 0

Router(config-line)# speed 9600

Regards,

Michaël

zillah2004 Wed, 04/27/2005 - 04:51

I had experienced long time ago a problem with funny characters, the reason for the problem was; different baud rate speed between router and HyperTerminal.

I have been advised to increase the speed of the HyperTermianl (Try and error way) untill it matches the baud rate speed of our router,then I can get rid off the funny characters.

I did it and the speed that I used was 19200, it worked fine.

Fisrt:

Now my question is there another way to find the exact baud rate speed of the router without using way of try and error for matching the speed?

Second:(related to recovery image)

When I changed the buad rate speed from 9600 to 115200, I was able to see in show running, but when I restored to the original value, it was not shown in the running configuration!!!, Is it because asdefault value?

mfreijser Wed, 04/27/2005 - 05:13

First question:

There is a possibility to configure a router that it will automatically detect the Baud Rate on a line. I know that this works with Cisco IOS 12.2, I don’t know if other IOS releases support it though, but you can probably find this with the search on www.cisco.com.

Information about configuring automatic baud rate detection can be found here:

http://www.cisco.com/en/US/products/sw/iosswrel/ps1835/products_configuration_guide_chapter09186a00800ca732.html

Second question:

My first guess is that you can’t see it in the configuration because it's a default option and thus it’s not necessary to be shown in the configuration.

Regards,

Michaël

phillips.w Wed, 04/27/2005 - 04:40

I had the same issue with a cisco 2651 router. I had to TFTP a new image to the router to correct the problem.

Hope this helps

Actions

Login or Register to take actions

This Discussion

Posted April 26, 2005 at 10:49 PM
Stats:
Replies:7 Avg. Rating:
Views:3800 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 2,069
2 1,736
3 1,675
4 1,624
5 1,529