One way RTP stream with ATA186 and CCME

Unanswered Question
Jul 21st, 2005

Hi all

I have problems with one-way RTP stream using ATA186 although other IP phones work well. I have network as shown in attached picture -ATA e164 number is 226006675. ATA is loaded with H.323 software (v3.1.2atah323) and has IP adress 10.99.99.4. Default GW is 10.99.99.1 (C2651XM). When calling from ATA to PSTN signaling started, codec g711alaw is designated, channel is opened but audio is only one way (from ATA to PSTN is OK, from PSTN to ATA RTP doesnt goes through). I tried to troubleshhot this problem with ethereal and prserv (both files are attached). In prserv messages "OnReceivedAckPDU: sessionID missing" and "Unknown Q931: 110" are shown. BAsic configuration of ATA is also attached (connect mode, audio mode..).NAT is not problem - no NAT configured. Under voice service voip is fax protocol pass-through g711alaw configured. To avoid problems with firewall I moved ATA before Firewall. I tried almost everythink. Could anyone help me please?? Thank very much.

Regards Miroslav

ON 2951XM are these dial-peers for ATA.

IN: dial-peer voice 989 voip

incoming called-number .T

codec g711alaw

OUT: dial-peer voice 266 voip

huntstop

destination-pattern 226006675

session target ipv4:10.99.99.4

dtmf-relay cisco-rtp

codec g711alaw

fax rate disable

fax protocol pass-through

g711alaw

no vad

=== OUTPUT FROM PRSERV.EXE =============

logging started Thu Jul 21 08:49:14 2005

226006675 active @0xa636304 (GK @0x25642025)

[0]StartTone 0

[0]DTMF 7 , insum:523126

[0]StopTone

[0]DTMF 3 , insum:494590

[0]DTMF 6 , insum:514513

[0]DTMF 6 , insum:498982

[0]DTMF 9 , insum:512845

[0]DTMF 9 , insum:503774

[0]DTMF 0 , insum:514411

[0]DTMF 0 , insum:501916

[0]DTMF 7 , insum:521086

11:00;0,0,0,0,

Calling 736699007

SCC->(0 0) <cmd 16>

CLIP

SCC->(0 0) <cmd 2>

<0 0> dial<736699007>

block queue <- (18 1516504 0)

Connect to <0xa636301 1720>..

>>>>>>>> TX CALLER ID : 0x1 0x80 11

Q931<-0:Setup:CRV 32762

Q931->0:Proceeding

[0]Received pi=8 in q931

Q931->0:Alerting

Connect H245...

block queue <- (19 1516504 557050)

NuConnectDispatcher: 0x7ffa

H245 TCP conn a636301 57538

CESE/MSDSE start:<0 0 0 0>

capSize = 3

H245->0:Cese

[0]: OOB DTMF

RmtInputCap <15 5>

RmtInputCap <15 4>

RmtInputCap <15 1>

RmtAudioCap <4 1>

MD/FRM 1 20

Capability set accepted

H245->0:MSD: <rn tt> = <0xbeb 60>

[0]Slave Tx:1 TxRemote:1

H245->0:CeseAck

H245->0:MsdAck

h323.c 2118: cstate : 4

->H245<0> OLC

H245<-0:LcseOpen

TxAud = G711 (1) 20 fpp

G.711 Silence Suppression on

H245->0:LcseOpen

H245->0:OLC mode 1

remote OpenLogicalReq G711/G729(1) : 20 fpp

OpenRtpRxPort(0,0x0,16384):2

RTP Rx Init: 0, 0

RTP->0:<0xa636304 16384>

H245->0:LcseOpenAck

OnReceivedAckPDU: sessionID missing

RTP<-0:<0xa636301 16596>

[0]Enable encoder 8

[0]: EC 1

RTP TX[0]:SSRC_ID = d3d8f120

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
thisisshanky Thu, 07/21/2005 - 21:16

Miroslav,

Were you able to fix this problem ? I see you have a VOIP dial-peer to ATA (since its using H323) and another VOIP dial peer to your service provider. Normally all gateways are supposed to only connect a POTS to VOIP dial-peer by default. IOS is not enabled by default to connect two VOIP dial peers. So what you need to do is enable the following command in the router to connect two VOIP legs which is typically supposed to be done on a IPGWGW feature set IOS.

voice service voip

allow-connections h323 to h323

redirect ip2ip

HTH

miroslav_vodolan Tue, 10/25/2005 - 13:12

Hi,

I tried these commands but with no success. RTP still one way. Have you any other advise, please?

Many thanks for any reply.

miroslav_vodolan Sat, 11/05/2005 - 13:19

Here you are config of my voice GW where CCME is running (212.90.248.246). Unfortunately I am not able to post config of second side GW, where all my call are sended (213.235.87.71), because I have no access to this GW. But I think problem is on my side :o(

Thank very much for your ideas

jasyoung Sat, 11/05/2005 - 22:16

According to your configuration, and confirmed by your sniffer trace, the router is acting in an "IP-IP" gateway role. This means it plays a proxy role in the middle of the call, helping with H.323 call setup and fixing up the IP addressing in RTP packet headers as they pass through the gateway.

We can assume that your VoIP provider is probably sending RTP traffic properly. You say that calls from IP phones work, and we are seeing RTCP reports from your VoIP provider come in that indicate they're sending RTP. For reasons unknown, that RTP traffic isn't making it to your ATA.

I don't know if it'll help (and it might even hurt, so try it after business hours), but you can try adding the following to your config:

voice service voip

media flow-around

Since your ATA is using private addressing, you may have to move your ATA to back behind your firewall or reconfigure your router's NAT ACL. In a media flow-around config, some sort of NAT will be required since the ATA will now be trying to exchange media traffic directly with your provider's VoIP gateway.

If this doesn't work, we need to see new sniffer traces from inside near the ATA and also outside your gateway if possible (the Internet side). We also need the output of:

debug voip ipipgw

debug cch323 all

debug h225 asn1

debug h225 events

debug h225 q931

debug h245 asn1

debug h245 events

And while a call is up:

show call active voice brief

When you are posting configurations in the future, you may wish to remove passwords, crypto keys, SNMP community strings, etc. If you use 'show tech-support' on the router instead of 'show conf', most of this will be done for you.

miroslav_vodolan Thu, 11/10/2005 - 01:53

Hi JAson and all

I picked up some "shows" and all debugs you wished (h225 as1, h245as1...). All these debugs are attached. It is quite a lot of rows, but I hope you will find some time to anylize it.

Many Many thanks for you effort

Miroslav

maharris Thu, 11/10/2005 - 09:42

Quick observation here, your call is matching this peer coming in:

dial-peer voice 989 voip

translation-profile incoming Dovnitr

incoming called-number .T

codec g711alaw

And this peer going out to the ATA:

dial-peer voice 266 voip

huntstop

destination-pattern 226006675

session target ipv4:10.99.99.4

dtmf-relay cisco-rtp

codec g711alaw

fax rate disable

fax protocol pass-through g711alaw

no vad

You usually want the peers to be doing the same thing, and I have had one way voice issues with VAD on on one leg and not the other - not with ATA specifically, but it makes me suspicious. I seems to be more trouble than it is worth, so I would turn it off on all your peers and test again. It is also on in your ATA, I don't know if that will hurt of if it gets negotiated, to turn it off there set the audiomode to 0x00140014. Then test again. And, maybe someone else will notice something else..

Mary Beth

thisisshanky Sat, 11/05/2005 - 14:01

Mir,

I am not sure if this is a codec issue. You are using 2 h323 legs (one to ata and one to PSTN gateway- which is a voip gateway). Your ATA is using g711alaw while your PSTN dial-peer has not specified any codec (which means it defaults to g729).

Can you set the ATA side to g729 and see if that helps ?

Actions

Login or Register to take actions

This Discussion

Posted July 21, 2005 at 6:22 AM
Stats:
Replies:11 Avg. Rating:
Views:218 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard