Caller ID??

Unanswered Question
Sep 16th, 2005
User Badges:

I am trying to block or at least change the caller ID on outbound calls.

I have tried the following:

translation-rule 2

Rule 0 ^. xxx3984028

!

dial-peer voice 200 voip

preference 1

destination-pattern .T

translate-outgoing calling 2

session target ipv4:10.x.x.2

dtmf-relay cisco-rtp

fax rate 7200

translate-outgoing calling 2

ip qos dscp cs5 media

clid strip

no vad

!


Neither the clid strip or the translate rule seem to do anything.


My setup looks like this:

PSTN---Gateway---WAN connection--remote router--PBX

The above dial-peers are on the remote router.

Any ideas?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
ptredway Fri, 09/16/2005 - 16:12
User Badges:

Dave,


I want to make sure I understand this correctly. You're making calls from your PBX across some kind of TDM circuit to a local router and then across an IP backbone etc etc.


If that's the case, let's first make sure when you place a test call that you are in fact matching this dial-peer.


On the router local to the PBX, turn on 'debug voice ccapi inout' and paste it to this thread.


We'll be able to tell exactly what's going on based upon that output.


vanagon2tdi Mon, 09/19/2005 - 05:32
User Badges:

Changed my translate rule to the below and it worked.

Thanks anyways for your time!


translation-rule 2

Rule 0 any xxx3984028


Cheers!

Dave


Actions

This Discussion