×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Layer3 Switching and BVI questions 2948l3 to 3750

Unanswered Question
Oct 13th, 2005
User Badges:

We currently have a 2948L3 Core switch which does the routing of our two class C ip schemes. I did this using a BVI. We have purchased a 3750L3 gigabit to replace a core switch at another location however it appears some of the bridging that was capable in the 2948L3 is no longer supported in the 3750 or the methods for implementing it has changes.


On the 2948 I configured it like so and everything works great.


ip subnet-zero

bridge irb


interface BVI1

description Kludge for 192.1.11.0/24 and 192.1.12.0/24 to exist within the same broadcast domain

ip address 192.1.12.1 255.255.255.0 secondary

ip address 192.1.11.248 255.255.255.0

no ip directed-broadcast



bridge 1 protocol ieee

bridge 1 route ip


I then add any port into bridge-group 1 and it can route between the two subnets.



The 3750L3 does not support bridge protocol ieee only vlan-bridge. Here is the config of the 3750


version 12.2

!

switch 1 provision ws-c3750g-24ts

ip subnet-zero

!

!

!

!

!

!

no file verify auto

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

vlan internal allocation policy ascending

bridge irb

!

!

interface GigabitEthernet1/0/1

no mdix auto

!


!

interface Vlan1

no ip address

bridge-group 1

!

interface BVI1

description BVI to allow 192.1.30.0/24 and 10.0.32.0/20 to exist

ip address 10.0.32.2 255.255.240.0 secondary

ip address 192.1.30.1 255.255.255.0

!

ip classless

ip route 10.0.32.0 255.255.240.0 BVI1

ip route 192.1.30.0 255.255.255.0 BVI1

ip http server

ip http secure-server

!

!

!

control-plane

!

bridge 1 protocol vlan-bridge

bridge 1 route ip

!


When i try to add any port to bridge group 1 other than vlan1 it tells me that

% command accepted but obsolete, unreleased or unsupported.



So my question is how would I allow two different subnets to work in the same broadcast domain on a 3750 like i did on the 2948. I've looked all over the cisco site but have not found any info on what config proceeds the bridge ieee command that i used on the 2948.


TIA

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Richard Burts Thu, 10/13/2005 - 07:40
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Brian


I do not have experience with the 3750 so I can not know for sure. But it looks to me that if you assign ports to VLAN 1 that they will be associated with bridge-group 1 and would allow two logical subnets to operate in the same broadcast domain.


Give it a try and let us know if it works.


HTH


Rick

Actions

This Discussion