Looking for CSM config when CAT6500 running Hybrid S/W

Unanswered Question
Oct 14th, 2005
User Badges:

I have not come across any documentation showing any example or configuration guide on configuring a CSM in single or fault tolerant mode in CAT6500 running CatOS and IOS on the MSFC. Any points will be much appreciated because I have to do one tommorow.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Gilles Dufour Sun, 10/16/2005 - 07:36
User Badges:
  • Cisco Employee,

the CSM would be configured exactly the same way whatever CatOS or IOS you are running.

The only difference is that with CatOS you need to manually configure the trunk between Supervisor and CSM.

Make sure to allow the vlans that you need on the CSM.


Regards,


Gilles.

astanislaus Mon, 10/17/2005 - 03:33
User Badges:

Gilles,


I wish I had your answer one day earlier. I figured this out the hard way. Thank you.


I now have a different problem, which you may be able to help me with. From the router config when I type - module ContentSwitch csm 3 - it takes more than a minute to get the CSM config prompt.


Then every command I type - eg, vlan 46 client - takes about a minute to respond. This happens only on one CAT 6509. On the other CAT 6500 which has the CSM in slot 8 - when I say - at router config prompt - module ContentSwitch csm 8 - I get an immediate response with the csm config prompt and every command I type I get immediate response.


One CAT 6500 number 1, I did a reset 3 at the CatOS prompt and tried again. Same problem, Could it be a H/W problem on this CSM in this CAT6509. The CSM versions of the two CSMs in the two CAT6509 are

4.1(3) and the MSFCs in the two CAT6509 are 12.1(2)E.


It can't be version problem because the two CSMs and the two MSFCs in the two CAT 6509 have the same versions. Tomorrow I will replace the CSM in the problem CAT6509 abd try again. If you have any other suggestion, it will be good.


I have configured one CSM and I need to configure this other CSM whick takes more than a minute to respond to commands and so I gave up after I typed 3 or 4 commands.


Gilles Dufour Mon, 10/17/2005 - 04:07
User Badges:
  • Cisco Employee,

Are you really using version 12.1(2)E ???

This is not a supported software version, so I'm quite surprised.


See the following link for recommended version.


http://www.cisco.com/en/US/products/hw/switches/ps708/prod_installation_guide09186a008022ffe2.html#wp36546


If each CSM command takes a while it could be different things.

Actually you type commands on the MSFC and this one will communicate with the CSM to get the requested info.

So, if there is a delay for the response to come back, it could be because the CSM is too busy [do a -sho mod csm tech util - to see the cpu utilisation].


Could be hardware or a communication issue if you do not run the minimum supported version.


Gilles.

astanislaus Mon, 10/17/2005 - 05:02
User Badges:

Gilles,


I meant to type 12.1(22)E2. Please see below for the version and it is the same on the MSFC of both CAt6509 switches.


IOS (tm) MSFC2 Software (C6MSFC2-JK2SV-M), Version 12.1(22)E2, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

Gilles Dufour Mon, 10/17/2005 - 07:43
User Badges:
  • Cisco Employee,

ok - this version is ok [makes more sense like this].

What about the 'sho mod csm tech util' ?

Did you capture one ?

Could you attach it to this forum ?


We may also need 2 sho tech captured with 2 minutes interval.


Thanks,


Gilles.

astanislaus Mon, 10/17/2005 - 15:49
User Badges:

Gilles,


I shall do this when I go to site today. I am waiting for a spare CSM module just in case. When I receive the spare I will attend site and get the information as requested by you. I will also replace the CSm and try. Since one CSM in one CAT6509 works and the other CSM in the other CAT6500 doesn't work and the two CAT 6509 are equally loaded in terms of CPU utilization and memory usage, I suspect this is a H/W issue.

Actions

This Discussion