×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

OSPF & MPLS

Unanswered Question
Oct 26th, 2005
User Badges:

I've 2 routers conncted via MPLS IP VPN.

I try to up OSPF between it.

--------------------

1-st R-

--------------------

!

router ospf 9

log-adjacency-changes

network 10.20.18.0 0.0.0.255 area 1

network 172.30.0.0 0.0.0.255 area 1

!


#sh ip ospf interface

Serial0/0 is up, line protocol is up

Internet Address 172.30.0.9/30, Area 1

Process ID 9, Router ID 172.30.0.9, Network Type POINT_TO_POINT, Cost: 64

Transmit Delay is 1 sec, State POINT_TO_POINT,

Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

oob-resync timeout 40

Hello due in 00:00:09

Supports Link-local Signaling (LLS)

Index 2/2, flood queue length 0

Next 0x0(0)/0x0(0)

Last flood scan length is 0, maximum is 0

Last flood scan time is 0 msec, maximum is 0 msec

Neighbor Count is 0, Adjacent neighbor count is 0

Suppress hello for 0 neighbor(s)

FastEthernet0/0 is up, line protocol is up

Internet Address 10.20.18.2/24, Area 1

Process ID 9, Router ID 172.30.0.9, Network Type BROADCAST, Cost: 1

Transmit Delay is 1 sec, State DR, Priority 1

Designated Router (ID) 172.30.0.9, Interface address 10.20.18.2

No backup designated router on this network

Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

oob-resync timeout 40

Hello due in 00:00:07

Supports Link-local Signaling (LLS)

Index 1/1, flood queue length 0

Next 0x0(0)/0x0(0)

Last flood scan length is 0, maximum is 0

Last flood scan time is 0 msec, maximum is 0 msec

Neighbor Count is 0, Adjacent neighbor count is 0

Suppress hello for 0 neighbor(s)


---------------

2nd R-

---------------

!

router ospf 21

log-adjacency-changes

network 10.20.24.0 0.0.0.255 area 1

network 172.30.0.0 0.0.0.255 area 1

!

------

GW#sh ip ospf int

Serial0/0 is up, line protocol is up

Internet Address 172.30.0.21/30, Area 1

Process ID 21, Router ID 172.30.0.21, Network Type NON_BROADCAST, Cost: 64

Transmit Delay is 1 sec, State DR, Priority 1

Designated Router (ID) 172.30.0.21, Interface address 172.30.0.21

No backup designated router on this network

Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5

oob-resync timeout 120

Hello due in 00:00:08

Supports Link-local Signaling (LLS)

Index 2/2, flood queue length 0

Next 0x0(0)/0x0(0)

Last flood scan length is 0, maximum is 0

Last flood scan time is 0 msec, maximum is 0 msec

Neighbor Count is 0, Adjacent neighbor count is 0

Suppress hello for 0 neighbor(s)

FastEthernet0/0 is up, line protocol is up

Internet Address 10.20.24.2/24, Area 1

Process ID 21, Router ID 172.30.0.21, Network Type BROADCAST, Cost: 1

Transmit Delay is 1 sec, State DR, Priority 1

Designated Router (ID) 172.30.0.21, Interface address 10.20.24.2

No backup designated router on this network

Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

oob-resync timeout 40

Hello due in 00:00:09

Supports Link-local Signaling (LLS)

Index 1/1, flood queue length 0

Next 0x0(0)/0x0(0)

Last flood scan length is 0, maximum is 0

Last flood scan time is 0 msec, maximum is 0 msec

Neighbor Count is 0, Adjacent neighbor count is 0

Suppress hello for 0 neighbor(s)

===========================

I don't have ospf neighboors. I tryed to select for interfsaces -

ip ospf network point-to-multipoint

or ip ospf network broadcat

but it didn't help.


I tryed to write neighboors address but get message-

GW(config)#router ospf 21

GW(config-router)#nei

GW(config-router)#neighbor 172.30.0.9

OSPF: Neighbor address does not map to an interface


---------

Why i get that message?


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
christopher_for... Wed, 10/26/2005 - 05:44
User Badges:

Just looking at this quickly I'm seeing that the serial interfaces are not on the same subnet(assuming that these routers are connected through the serial 0/0 interfaces), which is why you would get "OSPF: Neighbor address does not map to an interface"


R1

#sh ip ospf interface

Serial0/0 is up, line protocol is up

Internet Address 172.30.0.9/30, Area 1

(This /30 has two usuable IP addresses in the subnet - 172.30.0.9 and 172.30.0.10)



R2

GW#sh ip ospf int

Serial0/0 is up, line protocol is up

Internet Address 172.30.0.21/30, Area 1

(This /30 has two usuable IP addresses in the subnet - 172.30.0.21 and 172.30.0.22)

Actions

This Discussion