PDM Access Denied

Answered Question
Oct 28th, 2005
User Badges:

When I attempt to access the PIX via PDM I am able to log into the first prompt by leaving the username blank and then typing in the enable password. Then I get a second prompt and I am unable to log on? I was able to log on before (many months ago), but, now I can't?


Should I create a new user and password? Or is there something else that I have to do?


I appreciate any help.


Thanks.


Mark

Correct Answer by fzamora about 11 years 9 months ago

You better check the PDM version you are running, I think is not compatible with the java version you are running.


Check the information below:


exception: java.security.AccessControlException: access denied

(java.util.PropertyPermission java.version read).


PIX Device Manager (PDM) versions 3.0(1), 3.0(2), 4.0(1), and 4.1(1) are incompatible with Java Plug-in versions 1.4.2_08 and 1.5.0_02 or later. If these Java Plug-ins are used in conjunction with the impacted PDM releases, the application will not load. Changes made in the Java Plug-in 1.4.2_08 and 1.5.0_02 break the existing code loading functionality in PDM and IDM.



As a workaround, the latest maintenance releases PDM 3.0(3), PDM 4.1(2), and IDM 5.0(2) resolve this issue. Another option is to uninstall the Java version your machine is running and install the one you will find by clicking on the link below:


<http://java.sun.com/j2se/1.3/download.html>


For more information check the link:


http://www.cisco.com/en/US/products/hw/vpndevc/ps4077/products_field_notice09186a008046c805.shtml


Regards,


Franco Zamora


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Correct Answer
fzamora Fri, 10/28/2005 - 09:17
User Badges:
  • Cisco Employee,

You better check the PDM version you are running, I think is not compatible with the java version you are running.


Check the information below:


exception: java.security.AccessControlException: access denied

(java.util.PropertyPermission java.version read).


PIX Device Manager (PDM) versions 3.0(1), 3.0(2), 4.0(1), and 4.1(1) are incompatible with Java Plug-in versions 1.4.2_08 and 1.5.0_02 or later. If these Java Plug-ins are used in conjunction with the impacted PDM releases, the application will not load. Changes made in the Java Plug-in 1.4.2_08 and 1.5.0_02 break the existing code loading functionality in PDM and IDM.



As a workaround, the latest maintenance releases PDM 3.0(3), PDM 4.1(2), and IDM 5.0(2) resolve this issue. Another option is to uninstall the Java version your machine is running and install the one you will find by clicking on the link below:


<http://java.sun.com/j2se/1.3/download.html>


For more information check the link:


http://www.cisco.com/en/US/products/hw/vpndevc/ps4077/products_field_notice09186a008046c805.shtml


Regards,


Franco Zamora


belenkym89 Fri, 10/28/2005 - 10:11
User Badges:

Wow, that was the problem!!

Thanks for responding so fast!


I guess what I should probably do now is to update the PDM software.


Thanks for you help.

fzamora Fri, 10/28/2005 - 10:15
User Badges:
  • Cisco Employee,

Not a problem, have a great day!


Franco

fzamora Fri, 10/28/2005 - 10:19
User Badges:
  • Cisco Employee,

Don't forget to rate the post as it will help another users as well


Franco

Actions

This Discussion