×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

VLAN Problem

Unanswered Question
Nov 3rd, 2005
User Badges:

I’m having a problem getting VLANs set up between my 3640 and my DLINK DES-3226L .


We have 5 ISPs and a /30 between them then a /24 or /27 of additional IP space which our NAT box (FreeBSD server) takes and NATs out to our internal servers.


The only sub interface that works is F1/0.1 and that is because I have native set on it. If I remove it and put it on another interface it works fine. Is my router configuration OK and it’s a dlink problem or is my router config not correct?


interface FastEthernet0/0

description Yipes 10Mbps Connection

ip address 66.xx.xxx.2 255.255.255.252

no ip proxy-arp

ip nat outside

ip virtual-reassembly

ip route-cache flow

speed 100

full-duplex

no cdp enable

!

interface FastEthernet0/1

description 10Mbps Connection

ip address 64.xxx.xxx.166 255.255.255.252

no ip proxy-arp

ip nat outside

ip virtual-reassembly

ip route-cache flow

speed 10

full-duplex

no cdp enable

!

interface FastEthernet1/0

no ip address

no ip proxy-arp

ip nat inside

ip virtual-reassembly

speed 100

full-duplex

dot1q tunneling ethertype 0x9100

no cdp enable

!

interface FastEthernet1/0.1

encapsulation dot1Q 2 native

ip address 192.168.101.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface FastEthernet1/0.2

encapsulation dot1Q 3

ip address 64.xxx.xxx.1 255.255.255.224

no ip proxy-arp

no cdp enable

!

interface FastEthernet1/0.3

encapsulation dot1Q 4

ip address 64.xxx.xxx.1 255.255.255.224

no ip proxy-arp

no cdp enable

!

interface FastEthernet1/0.4

encapsulation dot1Q 5

ip address 64.xxx.xxx.161 255.255.255.224

no ip proxy-arp

no cdp enable

!

interface FastEthernet1/0.5

description XO

encapsulation dot1Q 6

ip address 66.xxx.xx.1 255.255.255.0

no ip proxy-arp

no cdp enable

!

interface FastEthernet1/0.6

description Sprint

encapsulation dot1Q 7

ip address 63.xxx.xxx.1 255.255.255.0

no ip proxy-arp

no cdp enable

!

interface FastEthernet1/0.7

description TWTC

encapsulation dot1Q 8

ip address 209.xxx.xxx.1 255.255.255.0

no ip proxy-arp

no cdp enable

!

interface FastEthernet1/1

no ip address

no ip proxy-arp

ip nat inside

ip virtual-reassembly

speed 100

full-duplex

no cdp enable

!

interface FastEthernet2/0

description Sprint 10Mbps Connection

ip address 208.xx.xxx.74 255.255.255.252

no ip proxy-arp

ip accounting output-packets

ip nat outside

ip virtual-reassembly

ip route-cache flow

speed 10

full-duplex

no cdp enable

!

interface FastEthernet2/1

description TWTC 10Mbps Connection

ip address 66.xxx.xx.98 255.255.255.252

ip route-cache flow

speed 10

full-duplex

!

no ip http server

no ip http secure-server

!

ip classless

ip route 0.0.0.0 0.0.0.0 208.xx.xxx.73

!


Any help would be great.


Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
paul.werner Sat, 11/05/2005 - 03:00
User Badges:

A couple of thoughts here. First, this entry:


interface FastEthernet0/0

description Yipes 10Mbps Connection

ip address 66.xx.xxx.2 255.255.255.252

no ip proxy-arp

ip nat outside

ip virtual-reassembly

ip route-cache flow

speed 100

full-duplex

no cdp enable


Your description says 10Mbps, but your config says 100Mbps, which is right?


Further, do you have proper link negotiation set up between switches. Specifically how is link speed and duplex set on the DLINK? Generally, on Cisco switches, it is better to hard code the values if they can be properly set for a non-changing link, such as a switch to switch connection. On the other hand, non-Cisco switches may not always play well with Cisco and sometimes are more/better optimized for plug and play. You could possibly have speed and duplex mismatches on the DLINK switch. You have not posted the config, so it is hard to say.


Also, it might be useful to throw both switches into 100Mbps half duplex mode and pop a sniffer (via a 100mbps hub) in the middle of the mix and see what is happening. Capture the frames and see if the two are playing nicely with each other. Good luck,


pw

Richard Burts Sat, 11/05/2005 - 09:16
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Ryan


First I would like to verify my understanding of part of what you said. I think that if you configure FastEthernet1/0.1 as native that it communicates ok with the DLINK. And if you change and configure FastEthernet1/0.2 as native then it works ok. And I am guessing that if you configure FastEthernet1/0.3 as native that it works ok.


If my understanding is correct than I suspect that the issue is a difference between the way your 3640 works and the way the DLINK works. I took a quick look at the manual for the DLINK. I believe that it does not have the same concept that Cisco does of a trunk in which the native VLAN is untagged and all others are tagged. If I understand the manual correctly the DLINK either tags all frames being forwarded out an port or it untags all frames being forwarded out the port.


Can you veify how the DLINK is configured?


In my quick look through the manual I did not see anything obvious about how to configure the DLINK so that it would interoperate with the 3640. My guess is that you should configure the DLINK to tag all frames and should then configure one subinterface on the 3640 for a non-existant VLAN and mark it as native. That way both devices will process VLAN tags on all frames.


If I have misunderstood anything, please clarify.


HTH


Rick

flippedmedia1 Sat, 11/05/2005 - 09:21
User Badges:

Thanks for the reply.


I'm waiting on Saturday Delivery for a 2924-XL-EN.


I figured the DLINK is no good so I just got a new switch.


Hopefully it works out.

Actions

This Discussion