×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

destination host unreachable

Unanswered Question
Nov 9th, 2005
User Badges:

I have a linksys WRT54G with an ip 192.168.1.1 with a subnet as 255.255.255.0 I have a 2950 switch with this config:


TRUNK:

interface FastEthernet0/48

description 1841-TRUNK

switchport trunk allowed vlan 1


VLAN Interface:

ip address 10.1.2.2 255.255.255.0

no ip route-cache


ROUTER:

interface FastEthernet0/1

description Workstation IP

ip address 10.1.2.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1.1

description Voice IP

encapsulation dot1Q 3

ip address 10.1.3.1 255.255.255.0

no snmp trap link-status

!

interface FastEthernet0/1.2

description Server IP

encapsulation dot1Q 4

ip address 10.1.4.1 255.255.255.0

no snmp trap link-status

!

ip classless


I can ping any vlan interface if I assign myself a manual 10.1.x.x address. I can also ping any interface from the switch or router. If I go off of my linksys dhcp assigned 192.168.1.113 address, I get a time out when pinging 10.1.2.1, 10.1.3.1, and 10.1.4.1.


Now, if I get into the Linksys and manually add routes (I think this is a route problem somewhere - just not sure where), I get a Destination Host Unreachable INSTEAD of time out. Below are the three routes I added to the linksys to get from the 192.168.1.0 network to the 10.1.2.0 the 10.1.3.0, and the 10.1.4.0:


Destination LAN IP Subnet Mask Gateway Interface

192.168.1.0 255.255.255.0 0.0.0.0 LAN & Wireless

192.168.0.0 255.255.255.0 0.0.0.0 WAN (Internet)

10.1.4.0 255.255.255.0 192.168.1.1 LAN & Wireless

10.1.3.0 255.255.255.0 192.168.1.1 LAN & Wireless

10.1.2.0 255.255.255.0 192.168.1.1 LAN & Wireless

0.0.0.0 0.0.0.0 192.168.0.1 WAN (Internet)


Any ideas on where my routes are missing or incorrect? It seems like the pings/traceroutes are making it to the linksys router, but not through the switch to the cisco router.


Thanks!




  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
amit-singh Wed, 11/09/2005 - 21:34
User Badges:
  • Blue, 1500 points or more

Hi,


Let me know your Linksys router is connected in which vlan of the switch.What is the IP that you are giving on its WAN interface whihc is connected to switch. If you are giving it an IP of 10.1.x.x range on WAN that as its in the same directly connected interface for the router you will be able to ping its WAN IP.As linksys router does NAT on its LAN interface so i guess when you enable the DHCP, hosts get the IP in the range 192.168.1.x. Now when any client pings the router interface, it will do the NAT on the WAN Ip which should be in the range 10.1.x.x and that will become the source Ip and should be able to work in that.


I see that you have a WAN Ip of 192.168.0.1, whihc is a segment that doensot exisst on the router 1841. Change the WAN IP the the 10.1.x.x range and it should work fine.


regards,

-amit singh

networksavvy Thu, 11/10/2005 - 06:24
User Badges:

Thanks for the response. Well, the WAN interface on the linksys is not plugged into my switch - it is plugged into a Satellite modem and has a modem assigned DHCP of 192.168.0.1.


The LAN interface is giving NAT/DHCP in the 192.168.1.100-150 range and is plugged to a normal port on the layer 2 2950 switch so it is not doing any routing - just a management IP/VLAN of 10.1.2.2 which I understand there can only be one active at a time. All clients are working fine, getting a 192.168.1.x address and hitting the web.


The 10.1.4.0, 10.1.2.0, and 10.1.2.0 VLANS are configured on the 1841 router which is also connected to the switch on port e0/48 and is configured and working as a trunk. Eventually we will eliminate the SAT and Linksys altogether by installing a T1, but I would still like the 192.168.1 talking back and forth with the 10.1.2, 10.1.3, and 10.1.4 of both routers in the meantime. I understand what you are saying about the WAN ip of the Linksys, but my thoughts were that wan IPs of both routers would not even come into play in this situation as it is all LAN side. Am I assuming wrong? Thanks again!

Actions

This Discussion