Configure Cisco-Switch 3560-urgent

Unanswered Question
Nov 10th, 2005

Dear All,

I am still New to the World of Cisco.

I received today 15 Cisco switches 3560 - 48 Ports & 1 Core switch 4506.

i know the basic configuration of 3560.

i want to create 3 VLANS of core Switch and each VALN will be for specific reaons.

So VLAN with this Name ( NETWORK-DEVICE) will be for Cisco Switches .

and it should have DHCP for this VLAN only.

Can any one tell me , how i deploy DHCP for that on the Core Switch . or it needs to deploy on the 3560 Switch.

Please Help.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
amit-singh Thu, 11/10/2005 - 01:07

Hi,

You want to configure 3 vlans on core switch and also 0n 3560 too. You should have a trunk link between the switches to carryt 3 vlans.

For vlan creation on CORE:

conf t

vlan 2 name XXX

vlan 3 name YYY

* Note vlan 1 is by defualt

Create a Virtual interface for all vlans if you want to route between the vlans :

int vlan 1

ip address x.x.x.x y.y.y.y <-- Where X is the ip range and Y is the subnet.

Int vlan 2

ip address x.x.x.x y.y.y.y <-- Where X is the ip range and Y is the subnet.

Int vlan 3

ip address x.x.x.x y.y.y.y <-- Where X is the ip range and Y is the subnet.

If you dont want to route between the vlans then do not create SVI on the CORE.Just create one vlan interface with an IP to manage it remotely.

For trunk config on 4500

conf t

int gig x/y

switch trunk encapsulation dot1q

switchport mode trunk

On 3560:

trunk config

conf t

int gig x/y

switch trunk encapsulation dot1q

switchport mode trunk

There is not need to create SVI on 3560 as you have already created on 4500. You can assign an IP to one of its vlan interface to remotely manage teh switch.

Do you want to have DHCP enabled on 4500 or 3560 or you will use another DHCP server.I am assuming you want 4500 as DHCP server.

Do the following

conf t

service DHCP

ip dhcp pool TEST

network X.X.X.X y.y.y.y <-- Where x & y are network and subnet

default-router x.x.x.1 <-- this is degault gateway for clients.

domian-server <- you can also include the DNS servers.

You migh want to exclude some addresses from the DHCP pool like the gateway address.

ip dhcp excluded-address x.x.x.x

HTH,

-amit singh

rania20052006 Thu, 11/10/2005 - 04:11

Thanks for your reply.

I want to do the following :-

====================================

1- on the core switch i want to create 3 VLANS to be as the following :-

VLAN 2 for All the Cisco Switches which i have in the Head office & Branch Office , This Vlan will be for all the Switches & Router & Should have the DHCP Enable only on this VALAN and should only give this range of IP for all the Switches & Router ( 10.1.8.X / 24 ) .

How can i make the commands which is allowing me to do that on the core switch & on the 3560 switch ?

Should i need to enable routing between vlans or not ? and why ?

==============

2- the second vlan will be for All the servers which i have here in my company , how can i made ?

Please Provide me with the command for doing it on the 3560 & Core switch ?

Can i do the same on the 3560 ? i mean can i create the vlans on the 3560 as well & enable also the DHCP on the 3560 , and it will braodcast the configuration to all the switches, instead of the core switch ? if so , can you please provide me with the command which i need to do it on the 3560 as well .

the IOS version for the one which i have is 12.2(25) SEB4

thanks .

michael.l.choo@... Sun, 11/13/2005 - 21:03

Whether or not you need IP routing enabled on the 3560 depends on where you want the Inter-VLAN routing to take place. Even the most basic image for 3560 should support basic IP routing (static, RIP). But, you DEFINITELY need to turn IP routing on the Core 4506. Why? Otherwise it won't route traffic between VLANs.

What I'm describing here presume that only 4506 will perform IP routing, while the 3560s will only perform Layer-2 forwarding only.

The following are the basic configs that you'd need. (I'm presuming that your 4506 has either Sup IV or Sup V, running native IOS). Please note the prompt to determine which configuration mode you need to enter the commands in.

CORE:

! To enable IP Routing (so that Core can perform Inter-VLAN routing)

switch(config)# ip routing

! Create VLAN 2 (switches and routers VLAN)

switch(config)# vlan 2

switch(config-vlan)# name All_Switches_VLAN

! Create VLAN 3 (servers VLAN)

switch(config)# vlan 3

switch(config-vlan)# name All_Servers_VLAN

! Create the SVI (Switched VLAN Interface) for the VLANs

switch(config)# interface VLAN2

! the following line presumes the CORE switch to use .1 (and acting as default gateway for VLAN2)

switch(config-if)# ip address 10.1.8.1 255.255.255.0

switch(config)# interface VLAN3

switch(config-if)# ip address

! Creating DHCP Pool

switch(config)# ip dhcp pool VLAN2Pool

switch(dhcp-config)# network 10.1.8.0 255.255.255.0

switch(dhcp-config)# default-router 10.1.8.1 !Presuming .1 is your default gateway

switch(dhcp-config)# lease 30 !Presuming you want 30-day lease

switch(dhcp-config)# domain-name !Optional

switch(dhcp-config)# dns-server !Optional. You can enter up to 4 DNS server entries here

switch(dhcp-config)# netbios-name-server !Optional. Can't remember how many you can enter here. But, considering how WINS work, 2 is more than enough

switch(dhcp-config)# netbios-node-type h-node !Optional. But, if you want to enable WINS, highly recommend h-node.

! If you want to reserve a block of IP addresses from the DHCP pool for static allocation, enter the following line(s)

!

switch(config)# ip dhcp excluded-addresses

! Configure all trunk interfaces to use VLAN2 as native VLAN

! example below

switch(config)# interface GigabitEthernet1/1

switch(config-if)# switchport mode trunk

switch(config-if)# switchport trunk encapsulation dot1q

switch(config-if)# switchport trunk native vlan 2

!

You only need to create the DHCP scope on the CORE switch. You don't need (nor want!) to create one on the 3560s. Also, the switch is smart enough to know which DHCP scope is for which VLAN, simply by looking at the network address.

Then on the 3560, you only need to create the VLANs. The commands are exactly the same as the ones for 4506. Note that the only SVI that the 3560s need is the one for VLAN2. Make sure the VLANs you create on the 3560 match the ones on the CORE. Otherwise, they won't talk to each other.

When you configure the interfaces, make sure that you configure VLAN2 as the native VLAN for all TRUNK links!

That's as far as I can tell you free of charge. :)

Please don't take this the wrong way, but I think you desperately need to study Cisco LAN switching. PRONTO!

Actions

Login or Register to take actions

This Discussion

Posted November 10, 2005 at 12:47 AM
Stats:
Replies:3 Avg. Rating:
Views:350 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 2,069
2 1,736
3 1,675
4 1,624
5 1,529
Rank Username Points
5
5
5
5
5