×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

layer 3 EtherChannel explaination

Unanswered Question
Nov 23rd, 2005
User Badges:

I have these two switches with thier configuratios


Switch1:

interface FastEthernet0/10

switchport trunk encapsulation isl

no ip address

channel-group 1 mode desirable

!

interface FastEthernet0/11

switchport trunk encapsulation isl

no ip address

channel-group 1 mode desirable

!

interface FastEthernet0/12

switchport trunk encapsulation isl

no ip address

channel-group 1 mode desirable

!

interface Port-channel1

switchport trunk encapsulation isl



Switch2:

interface FastEthernet0/10

switchport trunk encapsulation isl

no ip address

channel-group 1 mode auto

!

interface FastEthernet0/11

switchport trunk encapsulation isl

no ip address

channel-group 1 mode auto

!

interface FastEthernet0/12

switchport trunk encapsulation isl

no ip address

channel-group 1 mode auto

!

interface Port-channel1

switchport trunk encapsulation isl


Pitfall:


((To ensure that all member interfaces maintain the exact same configuration put them in the channel with the channel-group interface command, then apply all subsequent configuration to the port-channel interface.


Note that for layer 3 EtherChannel configurations, member

interfaces must first be designated as routed interfaces before being

put them in the channel-group)).




I am looking for explaination for this phrase in pitfall :(Note that for layer 3 EtherChannel configurations, member

interfaces must first be designated as routed interfaces before being

put them in the channel-group)?


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Aaron Harrison Wed, 11/23/2005 - 11:05
User Badges:
  • Super Bronze, 10000 points or more
  • Community Spotlight Award,

    Member's Choice, May 2015

Hi


Basically you have two types of real ports on a switch - routed and switched. Switched ports are for PCs/trunk links and so on, whereas a routed port is like a real router interface with an IP address etc.


You switch a port to a switchport using the 'switchport' command, or to a routed one by entering 'no switchport'.


What the pitfall note is saying is that if you want to have an L3 (or routed) Etherchannel, each port must get the 'no switchport' command before the 'channel-group' commmand.


Your config has ports with 'switchport' enabled, so it is a layer 2 etherchannel.


Aaron

Actions

This Discussion