×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

mutual redistribution between rip and eigrp

Unanswered Question
Nov 30th, 2005
User Badges:

I have been working with this example from the link http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a008009487e.shtml on example 2 but every time I configure it the rip router learns of all the eigrp routes but the routers just running eigrp don't learn of the rip routes. Am I doing something wrong? This is the configuration I am using. Also, there is a diagram of the setup attached at the bottom. Thanks


R2:


router eigrp 7

network 181.16.0.0

redistribute rip route-map rip_to_eigrp metric 1 1 1 1 1


!--- Redistributes RIP routes that are


!--- permitted by the route-map rip_to_eigrp





router rip

version 2

network 178.1.0.0

redistribute eigrp 7 route-map eigrp_to_rip metric 2


!--- Redistributes EIGRP routes and set the tags


!--- according to the eigrp_to_rip route-map




route-map rip_to_eigrp deny 10

match tag 88


!--- Route-map statement to deny any routes that have a tag of "88"



!--- from being redistributed into EIGRP


!--- Notice the routes tagged with "88" should be the EIGRP


!--- routes that are redistributed into RIPv2



route-map rip_to_eigrp permit 20

set tag 77


!--- Route-map statement to set the tag



!--- on RIPv2 routes redistributed into EIGRP to "77"



route-map eigrp_to_rip deny 10

match tag 77


!--- Route-map statement to deny any routes that have a


!--- tag of "77" from being redistributed into RIPv2



!--- Notice the routes tagged with "77" should be the RIPv2


!--- routes that are redistributed into EIGRP




route-map eigrp_to_rip permit 20

set tag 88


!--- Route-map statement to set the tag on EIGRP


!--- routes redistributed into RIPv2 to "88"


R5:


router eigrp 7

network 181.16.0.0

redistribute rip route-map rip_to_eigrp metric 1 1 1 1 1


!--- Redistributes RIPv2 routes that are permitted



!--- by the route-map rip_to_eigrp





router rip

version 2

network 178.1.0.0

redistribute eigrp 7 route-map eigrp_to_rip metric 2


!--- Redistributes EIGRP routes and sets the tags



!--- according to the eigrp_to_rip route-map





route-map rip_to_eigrp deny 10

match tag 88


!--- Route-map statement to deny any routes that have a tag


!--- of "88" from being redistributed into EIGRP



!--- Notice the routes tagged with "88" should be the EIGRP routes


!--- that are redistributed into RIPv2



route-map rip_to_eigrp permit 20

set tag 77


!--- Route-map statement to set the tag on rip routes



!--- redistributed into EIGRP to "77"



route-map eigrp_to_rip deny 10

match tag 77


!--- Route-map statement to deny any routes that have a tag



!--- of "77" from being redistributed into RIPv2



!--- Notice the routes tagged with "77" should be the RIPv2 routes


!--- that are redistributed into EIGRP



route-map eigrp_to_rip permit 20

set tag 88


!--- Route-map statement to set the tag on EIGRP routes



!--- redistributed into RIPv2 to "88"






  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Harold Ritter Wed, 11/30/2005 - 16:22
User Badges:
  • Cisco Employee,

Try adding the default-metric command as follow rather than on the redistribute rip statement:


default-metric 10000 10 255 1 1500.


Hope this helps,

jason.suplita Wed, 11/30/2005 - 18:12
User Badges:

The default-metric 10000 10 255 1 1500 didn't change anything. Once I took away the command route-map rip_to_eigrp deny 10 then the eigrp routers saw the route to the rip routers. Of course though, when I took that statement off of both routers that were doing the redistribution they saw they saw the path through eigrp instead of rip. Can I use the distribute-list 3 in s1 then deny the routes that I am redistributing from rip? Or can I increase the distance on the routes that I redistributing into eigrp, so that the redistributing routers prefer the rip route? It seems that it works, but I want to make sure that is a recommended option or if there is one better. Thanks again for all your help.

ruwhite Thu, 12/01/2005 - 07:05
User Badges:
  • Gold, 750 points or more

RIP doesn't carry tags, so you can't filter on tags from RIP into EIGRP. The best you can do is to set the tags from RIP into EIGRP, and then filter on them from EIGRP into RIP.


I'm confused about the route being preferred through EIGRP--the redistributing router should have two routes, a RIP route, and an external EIGRP route. The RIP route should be preferred. Unless you're saying you have the route learned both from the EIGRP and the RIP side, and want to prefer the RIP route over the EIGRP internal (?).


:-)


Russ.W

jason.suplita Thu, 12/01/2005 - 12:05
User Badges:

I thought RIP carries tags as long as it is RIP version 2? The problem is when I use the configuration up above R1 and R6 see the routes that R3 and R4 have behind them; however, R3 and R4 don't see the routes behind R1 and R6. When I take the statement route-map rip_to_eigrp deny 10 then R3 and R4 see the routes from R1 and R6, but the routes start to flap with being able to ping them at first then eventually not pingable. I am assuming this happens because when I take that statement off of both R2 and R5 both R2 and R5 show the routes behind R1 and R6 going through the EIGRP domain from R2 to R3 to R4 to R5 and from R5 it shows the path take from R5 to R4 to R3 to R2. When I am either testing it with RIP to EIGRP or RIP to OSPF with this model the same result. The only thing that stops R2 and R5 going through the EIGRP or the OSPF domain is if first I take off the route-map rip_to_eigrp deny 10 and keep the rest of the configuration, but add in both R2 and R5 the command distribute-list 1 in s1 then deny the routes behind R1 and R6 will R2 and R5 prefer the routes through the links connected by RIP instead of EIGRP or OSPF and the routes from R1 and R6 are seen at R3 and R4. The problem with the configuration above is that R3 and R4 don't see the networks behind R1 and R6 with that configuration. I hope this all makes sense instead of being confusing. Thanks


Jason

ruwhite Fri, 12/02/2005 - 09:27
User Badges:
  • Gold, 750 points or more

Okay, I checked this in the lab (which is why it took me so long to answer). Yes, ripv2 does support tags, I don't work a lot with rip, so.... I have a simple network, with just three routers, in a triangle. I didn't change the ip addresses so they are "privates," so just take the them with a grain of salt. :-)


These are my three configs, and it works.


Router 1:


interface Ethernet1/3

ip address 208.0.233.20 255.255.255.0

!

interface Ethernet1/1

ip address 208.0.237.20 255.255.255.0

!

interface Loopback0

ip address 208.1.1.1 255.255.255.0

router eigrp 100

redistribute rip route-map rip2eigrp

network 208.0.233.0

network 208.1.0.0 0.0.255.255

default-metric 1000 1 255 1 1500

auto-summary

!

router rip

version 2

redistribute eigrp 100 route-map eigrp2rip

network 208.0.237.0

default-metric 2

!

route-map eigrp2rip deny 10

match tag 100

!

route-map eigrp2rip permit 20

set tag 200

!

route-map rip2eigrp deny 10

match tag 200

!

route-map rip2eigrp permit 20

set tag 100


Router 2:


!

interface Ethernet3/2

ip address 208.0.233.21 255.255.255.0

!

interface Ethernet3/3

ip address 208.0.232.21 255.255.255.0

router eigrp 100

!

address-family ipv4

redistribute rip route-map rip2eigrp

network 208.0.233.0

default-metric 1000 1 255 1 1500

exit-address-family

!

router rip

version 2

redistribute eigrp 100 route-map eigrp2rip

network 208.0.232.0

default-metric 2

!

route-map eigrp2rip deny 10

match tag 100

!

route-map eigrp2rip permit 20

set tag 200

!

route-map rip2eigrp deny 10

match tag 200

!

route-map rip2eigrp permit 20

set tag 100


Router 3:


interface Ethernet1/1

ip address 208.0.237.19 255.255.255.0

!

interface Ethernet1/3

ip address 208.0.232.19 255.255.255.0

!

router rip

version 2

network 208.0.232.0

network 208.0.237.0


And, also on router 3, which is only running RIP:


72K#sho ip route 208.1.1.0

Routing entry for 208.1.1.0/24

Known via "rip", distance 120, metric 2

Tag 200

Redistributing via rip

Last update from 208.0.237.20 on Ethernet1/1, 00:00:03 ago

Routing Descriptor Blocks:

* 208.0.232.21, from 208.0.232.21, 00:00:27 ago, via Ethernet1/3

Route metric is 2, traffic share count is 1

Route tag 200

208.0.237.20, from 208.0.237.20, 00:00:03 ago, via Ethernet1/1

Route metric is 2, traffic share count is 1

Route tag 200


So, it's learning the route from both redistribution points, and it has the tags correctly. Are you certain you have all the default metrics configured, etc?


:-)


Russ.W



jason.suplita Fri, 12/02/2005 - 12:30
User Badges:

Russ, I want to say thank you very much for all the time you have spent helping me. I appreciate it very much. I'm pasting my network setup. I have simplified it to four routers connected in diamond shape. The part I don't understand is the R1 which is only running RIP can see the route from EIGRP from both redistribution points, yet the router only running EIGRP can not see the route from RIP from the redistribution point. Here is my configuration on all four routers. I apologize for all the time I am taking from everyone with this question. Thanks for all your help.


R1

interface Loopback1

ip address 2.2.2.2 255.0.0.0

!


interface Serial0

ip address 192.168.1.1 255.255.255.0

no fair-queue

clockrate 64000

!

interface Serial1

ip address 192.168.2.1 255.255.255.0

clockrate 64000


!

router rip

version 2

network 2.0.0.0

network 192.168.1.0

network 192.168.2.0


R2


interface Ethernet0

ip address 10.0.0.1 255.255.255.252

!

interface Serial1

ip address 192.168.2.2 255.255.255.0

no ip directed-broadcast

!

router eigrp 1

redistribute rip route-map rip2eigrp

network 10.0.0.0

default-metric 1000 1 255 1 1500

no auto-summary

!

router rip

version 2

redistribute eigrp 1 route-map eigrp2rip

network 192.168.2.0

default-metric 2

!

route-map eigrp2rip deny 10

match tag 100

!

route-map eigrp2rip permit 20

set tag 200

!

route-map rip2eigrp deny 10

match tag 200

!

route-map rip2eigrp permit 20

set tag 100


R3


interface Loopback1

ip address 4.4.4.4 255.0.0.0

!

interface Ethernet0

ip address 10.0.0.2 255.255.255.252

media-type 10BaseT

!

interface Ethernet1

ip address 10.0.1.2 255.255.255.252

media-type 10BaseT


!

router eigrp 1

network 4.0.0.0

network 10.0.0.0

no auto-summary

no eigrp log-neighbor-changes



R4


interface Ethernet0

ip address 10.0.1.1 255.255.255.252

!

interface Serial0

ip address 192.168.1.2 255.255.255.0

no fair-queue

!

router eigrp 1

redistribute rip route-map rip2eigrp

network 10.0.0.0

default-metric 1000 1 255 1 1500

no auto-summary

!

router rip

version 2

redistribute eigrp 1 route-map eigrp2rip

network 192.168.1.0

default-metric 2


!

route-map eigrp2rip deny 10

match tag 100

!

route-map eigrp2rip permit 20

set tag 200

!

route-map rip2eigrp deny 10

match tag 200

!

route-map rip2eigrp permit 20

set tag 100


Here is the show ip route from all four routers



R1


C 2.0.0.0/8 is directly connected, Loopback1

R 4.0.0.0/8 [120/2] via 192.168.1.2, 00:00:07, Serial0

[120/2] via 192.168.2.2, 00:00:22, Serial1

R 10.0.0.0/8 [120/2] via 192.168.2.2, 00:00:22, Serial1

[120/2] via 192.168.1.2, 00:00:07, Serial0

C 192.168.1.0/24 is directly connected, Serial0

C 192.168.2.0/24 is directly connected, Serial1



R2


R 2.0.0.0/8 [120/1] via 192.168.2.1, 00:00:12, Serial1

D 4.0.0.0/8 [90/409600] via 10.0.0.2, 00:19:04, Ethernet0

10.0.0.0/30 is subnetted, 2 subnets

C 10.0.0.0 is directly connected, Ethernet0

D 10.0.1.0 [90/307200] via 10.0.0.2, 00:19:04, Ethernet0

R 192.168.1.0/24 [120/1] via 192.168.2.1, 00:00:13, Serial1

C 192.168.2.0/24 is directly connected, Serial1



R3


C 4.0.0.0/8 is directly connected, Loopback1

10.0.0.0/30 is subnetted, 2 subnets

C 10.0.0.0 is directly connected, Ethernet0

C 10.0.1.0 is directly connected, Ethernet1



R4


R 2.0.0.0/8 [120/1] via 192.168.1.1, 00:00:00, Serial0

D 4.0.0.0/8 [90/409600] via 10.0.1.2, 00:23:34, Ethernet0

10.0.0.0/30 is subnetted, 2 subnets

D 10.0.0.0 [90/307200] via 10.0.1.2, 00:23:34, Ethernet0

C 10.0.1.0 is directly connected, Ethernet0

C 192.168.1.0/24 is directly connected, Serial0

R 192.168.2.0/24 [120/1] via 192.168.1.1, 00:00:01, Serial0


ruwhite Fri, 12/02/2005 - 18:50
User Badges:
  • Gold, 750 points or more

It's no problem for me to work on this. Instead of setting this up in the lab again, let's try something different--I'd rather tell you how to find the problem and fix it in my lab. :-) There are a few places you can look to try and figure out what's going wrong here.


Start on R2 and R4, which appear to be doing the redistribution with your current configurations. On each router (one at a time), do a debug ip eigrp notifications. This will show you the interaction between EIGRP and routing table.... Now, clear the redistributed route from the routing table, using clear ip route 2.2.2.0 255.0.0.0, and look at the notifications EIGRP is getting from the routing table. You should see a callback telling EIGRP about RIP inserting the route into the table.


1w2d: IP-EIGRP: Callback: redist frm rip AS 0 208.1.2.0/24

1w2d: into: eigrp AS 100 event: 2

1w2d: IP-EIGRP(Default-IP-Routing-Table:100): Callback: callbackup_routes 208.1.2.0/24


Is what it should look like. Now, if you're not getting this, it's because the redistributing router simply isn't getting the route from RIP into EIGRP, and you need to double check your route maps, filters, and such. If you see this on one or both of R2 and R4, then turn off the debugs, and move to R3, which is the router that's only running EIGRP.


Now, just look at the local eigrp event log on R3, using show ip eigrp events. In fact, do a clear ip eigrp events, and then go back to the redistributing routers, and clear the route again. Now, go back to R3 and look at the event log. You should see some information about the route there. If it's there, and there's no route in the local routing table, or the EIGRP topology table, then post the lines from the event log around the route here, and I'll see what I can make of them. You have to have a moderate strength decoder ring to read the event log, but it's not too hard....


HTH.


:-)


Russ.W


P.S. I'm on the road next week, so I might reply a little slower than normal.

jason.suplita Sat, 12/03/2005 - 12:49
User Badges:

Ok, this is what I am getting. It seems that when I have the route-maps configured like I posted in my last post they don't get redistributed at all into eigrp. Here is the clear ip route 2.2.2.2 info.


Router#clear ip route 2.2.2.2

Router#

00:05:01: IP-EIGRP: Callback: redist frm rip AS 0 2.2.2.2/32

00:05:01: into: eigrp AS 1 event: 2

00:05:01: IP-EIGRP: Callback: redist frm rip AS 0 2.0.0.0/8

00:05:01: into: eigrp AS 1 event: 2

Router#

00:05:12: IP-EIGRP: Callback: redist frm rip AS 0 2.2.2.2/32

00:05:12: into: eigrp AS 1 event: 1



when I do a show ip eigrp events it shows nothing of the route 2.2.2.2


Router#show ip eigrp events

Event information for AS 1:

1 00:08:17.907 Metric set: 10.0.1.0/30 307200

2 00:08:17.907 Route install: 10.0.1.0/30 10.0.0.2

3 00:08:17.907 FC sat rdbmet/succmet: 307200 281600

4 00:08:17.907 FC sat nh/ndbmet: 10.0.0.2 307200

5 00:08:17.903 Find FS: 10.0.1.0/30 307200

6 00:08:17.903 Metric set: 10.0.0.0/30 281600

7 00:08:17.903 FC sat rdbmet/succmet: 281600 0

8 00:08:17.903 FC sat nh/ndbmet: 0.0.0.0 281600

9 00:08:17.903 Find FS: 10.0.0.0/30 281600

10 00:08:17.903 Metric set: 4.4.4.4/32 409600

11 00:08:17.903 Route install: 4.4.4.4/32 10.0.0.2

12 00:08:17.903 FC sat rdbmet/succmet: 409600 128256

13 00:08:17.903 FC sat nh/ndbmet: 10.0.0.2 409600

14 00:08:17.903 Find FS: 4.4.4.4/32 409600



jason.suplita Sat, 12/03/2005 - 12:50
User Badges:

When I do take off the command route-map rip2eigrp deny 10 then the routes get redistributed. Here is the show ip eigrp events when I do that.


Router#show ip eigrp events

Event information for AS 1:

1 00:19:08.831 Ignored route, metric: 2.2.2.2 4294967295

2 00:19:08.831 Ignored route, neighbor info: 10.0.0.2 Serial0

3 00:19:08.831 Ignored route, dup router: 192.168.2.2

4 00:19:08.795 Change queue emptied, entries: 1

5 00:19:08.795 Metric set: 2.2.2.2/32 2560256

6 00:19:08.795 Update reason, delay: new if 4294967295

7 00:19:08.795 Update sent, RD: 2.2.2.2/32 4294967295

8 00:19:08.795 Update reason, delay: metric chg 4294967295

9 00:19:08.795 Update sent, RD: 2.2.2.2/32 4294967295

10 00:19:08.791 Route install: 2.2.2.2/32 0.0.0.0

11 00:19:08.791 Find FS: 2.2.2.2/32 4294967295

12 00:19:08.791 Rcv update met/succmet: 2560256 0

13 00:19:08.791 Rcv update dest/orig: 2.2.2.2/32 Redistributed

14 00:19:08.791 Metric set: 2.2.2.2/32 4294967295

15 00:19:08.791 Redist rt event: Route Up

16 00:19:08.791 Redist rt change: 2.2.2.2/32 Redistributed

17 00:18:46.551 NDB delete: 2.2.2.2/32 1

18 00:18:46.551 Poison squashed: 2.2.2.2/32 rt gone

19 00:18:46.551 RDB delete: 2.2.2.2/32 10.0.0.2

20 00:18:46.551 RDB delete: 2.2.2.2/32 0.0.0.0

21 00:18:46.551 Find FS: 2.2.2.2/32 4294967295

22 00:18:46.551 Free reply status: 2.2.2.2/32

23 00:18:46.551 Clr handle num/bits: 0 0x0

24 00:18:46.551 Clr handle dest/cnt: 2.2.2.2/32 0

25 00:18:46.551 Rcv reply met/succ met: 4294967295 4294967295

26 00:18:46.551 Rcv reply dest/nh: 2.2.2.2/32 10.0.0.2

27 00:18:46.551 Ignored route, neighbor info: 10.0.0.2 Serial0

28 00:18:46.551 Ignored route, dup router: 192.168.2.2

29 00:18:46.511 Metric set: 2.2.2.2/32 4294967295

30 00:18:46.511 Active net/peers: 2.2.2.2/32 1

31 00:18:46.507 FC not sat Dmin/met: 4294967295 2560256

32 00:18:46.507 Find FS: 2.2.2.2/32 2560256

33 00:18:46.507 Rcv update met/succmet: 4294967295 4294967295

34 00:18:46.507 Rcv update dest/orig: 2.2.2.2/32 Redistributed

35 00:18:46.507 Redist rt event: Route Down

36 00:18:46.507 Redist rt change: 2.2.2.2/32 Redistributed



and also the clear ip route 2.2.2.2


Router#clear ip route 2.2.2.2

00:18:46: IP-EIGRP: Callback: redist frm rip AS 0 2.2.2.2/32

00:18:46: into: eigrp AS 1 event: 2

00:18:46: IP-EIGRP: Callback: callbackup_routes 2.2.2.2/32

00:18:46: IP-EIGRP: Callback: redist frm rip AS 0 2.0.0.0/8

00:18:46: into: eigrp AS 1 event: 2

00:19:08: IP-EIGRP: Callback: redist frm rip AS 0 2.2.2.2/32

00:19:08: into: eigrp AS 1 event: 1


I know I can get the whole redistribution to work out with distribute-lists and distance commands, but the thing that is killing me is I don't understand why it doesn't work with the route-maps I have already configured. The logic behind the route-maps seems to be right. At least from my point of view. Once again, I really appreciate all of your help.


Jason Suplita

jason.suplita Wed, 12/07/2005 - 17:13
User Badges:

Could it be an ios bug? If so, how do I find out? I can't get access to the bug toolkit from my account. Thanks


Jason Suplita

ruwhite Tue, 12/13/2005 - 08:09
User Badges:
  • Gold, 750 points or more

It could be, but that seems odd.... Could youpost a show version for the three routers?


Thanks!


:-)


Russ.W

jason.suplita Tue, 12/13/2005 - 20:17
User Badges:

Here is the show version for all four routers. Also, I noticed that R4 is having a software crash when I delete the route-map eigrp2rip deny 10. Also, R3 is crashing occassionally, but I am pretty sure that it is happening only when I am debugging. So, the debugging is probably crashing it somehow, I'm assuming.


R1


Cisco Internetwork Operating System Software

IOS (tm) 4500 Software (C4500-D-M), Version 12.1(3)T, RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2000 by cisco Systems, Inc.

Compiled Wed 19-Jul-00 03:35 by ccai

Image text-base: 0x60008968, data-base: 0x60A92000


ROM: System Bootstrap, Version 5.3(16) [richardd 16], RELEASE SOFTWARE (fc1)

BOOTFLASH: 4500 Bootstrap Software (C4500-BOOT-M), Version 10.3(7), RELEASE SOFT

WARE (fc1)


Router uptime is 2 minutes

System returned to ROM by power-on

System image file is "flash:c4500-d-mz.121-3.t.bin"


cisco 4500 (R4K) processor (revision E) with 32768K/16384K bytes of memory.

Processor board ID 07185625

R4700 CPU at 100Mhz, Implementation 33, Rev 1.0

G.703/E1 software, Version 1.0.

Bridging software.

X.25 software, Version 3.0.0.

6 Ethernet/IEEE 802.3 interface(s)

4 Serial network interface(s)

128K bytes of non-volatile configuration memory.

128K bytes of non-volatile configuration memory.

16384K bytes of processor board System flash (Read/Write)

4096K bytes of processor board Boot flash (Read/Write)


Configuration register is 0x2102



R2



Cisco Internetwork Operating System Software

IOS (tm) 2500 Software (C2500-IS-L), Version 12.0(7), RELEASE SOFTWARE (fc1)

Copyright (c) 1986-1999 by cisco Systems, Inc.

Compiled Wed 13-Oct-99 21:43 by phanguye

Image text-base: 0x0303DC40, data-base: 0x00001000


ROM: System Bootstrap, Version 11.0(10c), SOFTWARE

BOOTFLASH: 3000 Bootstrap Software (IGS-BOOT-R), Version 11.0(10c), RELEASE SOFT

WARE (fc1)


Router uptime is 6 minutes

System restarted by power-on

System image file is "flash:c2500-is-l_120-7.bin"


cisco 2500 (68030) processor (revision N) with 2048K/2048K bytes of memory.

Processor board ID 19493959, with hardware revision 00000000

Bridging software.

X.25 software, Version 3.0.0.

1 Ethernet/IEEE 802.3 interface(s)

2 Serial network interface(s)

32K bytes of non-volatile configuration memory.

8192K bytes of processor board System flash (Read ONLY)

Configuration register is 0x2102




jason.suplita Tue, 12/13/2005 - 20:18
User Badges:

R3


Cisco Internetwork Operating System Software

IOS (tm) 4500 Software (C4500-IS-M), Version 12.2(2)T, RELEASE SOFTWARE (fc1)

TAC Support: http://www.cisco.com/cgi-bin/ibld/view.pl?i=support

Copyright (c) 1986-2001 by cisco Systems, Inc.

Compiled Sat 02-Jun-01 13:17 by ccai

Image text-base: 0x600089C8, data-base: 0x60D3C000


ROM: System Bootstrap, Version 5.3(16) [richardd 16], RELEASE SOFTWARE (fc1)

BOOTFLASH: 4500 Bootstrap Software (C4500-BOOT-M), Version 10.3(7), RELEASE SOFT

WARE (fc1)


Router uptime is 0 minutes

System returned to ROM by processor memory parity error at PC 0x603F25A0, addres

s 0x0 at 02:39:09 UTC Wed Dec 14 2005

System image file is "flash:c4500-is-mz.122-2.T.bin"


cisco 4700 (R4K) processor (revision F) with 32768K/4096K bytes of memory.

Processor board ID 20220957

R4700 CPU at 133Mhz, Implementation 33, Rev 1.0, 512KB L2 Cache

G.703/E1 software, Version 1.0.

Bridging software.

X.25 software, Version 3.0.0.

6 Ethernet/IEEE 802.3 interface(s)

1 FastEthernet/IEEE 802.3 interface(s)

128K bytes of non-volatile configuration memory.

16384K bytes of processor board System flash (Read/Write)

4096K bytes of processor board Boot flash (Read/Write)


Configuration register is 0x2102




R4

Cisco Internetwork Operating System Software

IOS (tm) 2500 Software (C2500-I-L), Version 12.1(2), RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2000 by cisco Systems, Inc.

Compiled Tue 09-May-00 19:57 by linda

Image text-base: 0x0303E424, data-base: 0x00001000


ROM: System Bootstrap, Version 5.2(8a), RELEASE SOFTWARE

BOOTFLASH: 3000 Bootstrap Software (IGS-RXBOOT), Version 10.2(8a), RELEASE SOFTW

ARE (fc1)


Router uptime is 4 minutes

System returned to ROM by power-on

System image file is "flash:c2500-i-l.121-2.bin"


cisco 2500 (68030) processor (revision N) with 6144K/2048K bytes of memory.

Processor board ID 05538646, with hardware revision 00000000

Bridging software.

X.25 software, Version 3.0.0.

1 Ethernet/IEEE 802.3 interface(s)

2 Serial network interface(s)

32K bytes of non-volatile configuration memory.

8192K bytes of processor board System flash (Read ONLY)

Configuration register is 0x2102



R4 software crash


Router(config)#no route-map eigrp2rip deny 10



%Software-forced reload


Preparing to dump core...

00:01:52: %SYS-2-INTSCHED: 'suspend' at level 4

-Process= "Exec", ipl= 4, pid= 2

-Traceback= 3270D82 32641E0 32642AC 3332982 3332CB8 3489C72 3489F82 33432AA 335B

CEC 31EE1A4 32038D8

Queued messages:

Exception: Software forced crash at 0x326CCBA (PC)


ruwhite Fri, 12/16/2005 - 05:30
User Badges:
  • Gold, 750 points or more

Which router is this on?


:-)


Russ.W

jason.suplita Fri, 12/16/2005 - 14:46
User Badges:

The software crash happened on the 2501 router, which is router R4 and it is redistributing rip and eigrp. It has an ios image file of c2500-i-l.121-2.bin (this was the router that is crashing when I delete the route-map eigrp2rip deny 10)


The other router that was crashing was the 4700 router with an image file of c4500-is-mz.122-2.T.bin

Once again, from my knowledge it only crashes when I have had debugging ip eigrp notifications on.


Thanks.


Jason suplita


Actions

This Discussion