×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

New Phones stuck at configuring IP

Unanswered Question
Dec 19th, 2005
User Badges:

I have checked physical connectivity, tried replacing the phones and still the phones are stuck at configuring IP? Any ideas? phone is a 7960. tried using a 7940 and it comes up fine. thanks...

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Tommer Catlin Mon, 12/19/2005 - 15:18
User Badges:
  • Green, 3000 points or more

Check the licensing on the CallManger for the 7960 phones. 7940 phone license will not activate a 7960 phone.


Check your tFTP.. we had a problem where all the phones at once tried to download the confige and crapped out the tftp server. So we had to limit the connections (for remote phones mostly)


hope this helps.

lafortuna Mon, 12/19/2005 - 15:49
User Badges:

how do I verify how many licenses are left? Also, tftp has been bounced to no avail.

mshavrov Mon, 12/19/2005 - 19:23
User Badges:

The "Configuring IP" message shows that the IP phone has send DHCP request and is waiting for DHCP response. Your phones do not receive IP addresses. If your phones are on the different subnet than your CallManager/DHCP server, then you have to make sure that your have the "ip helper " command on the phone subnet's interface.


Check your DHCP server, if it is running, if your have scopes defined and activated, and if scope has any IP addresses leased. Check if you have IP addresses available, and if not, try to reconsile the scope or release some IP addresses. Also, if it's possible, you can increase your scope.


Good luck,


Michael Shavrov

www.ciscoheadsetadapter.com


phones4u_jcregeen Tue, 12/20/2005 - 03:21
User Badges:

If you are using auto registration then I would also check your auto registration settings within Callmanager, make sure that you have enough free numbers.


Via - System/Cisco Callmanager/

Checking your - Starting range and Ending Range is large enough to encorperate all your phones.


Or if you have dead phones (phones that have been replaced, but the original phone MAC address is still appearing) in your callmanager phone list then removing these would also help

dekulp Tue, 12/20/2005 - 07:39
User Badges:

I am experiencing the same thing. The fix is to hard code an IP in the phone then go back to DHCP, however, this is a workaround. I was hoping to find an answer to this question on the forum myself. What we see with packet captures is that the DHCP server is offering an IP but the phone is not taking it.

Tommer Catlin Tue, 12/20/2005 - 08:11
User Badges:
  • Green, 3000 points or more

Everyone is suggesting great things here. To sum up:


- check your DHCP scope. Have enough addresses?

- Licensing. CCM license for the correct model phone?

- dead hardware.. remove those dead MACs that are taking up license.

- have the phones been regestered before or is this new? I have seen DOA phones out of the box. The way to check for sure is put a static IP on the phone. Can it connect to CallManager.

- On the same cable drop, try another phone.. will a 7940 connect on the same cable? if not, then you probably have a VLAN issue to your DHCP server, or TFTP server.

- you can also try a quick test with a PC... can the PC get an IP address off the voice vlan? at least you know if it can, the DHCP is working correctly.

- in your DHCP scope, find the MAC address of the phone and delete the IP and MAC address. Bounce the DHCP server (if it's Windows, you can just stop and start the service in Service Manager).


hope any of this helps!

mshavrov Mon, 12/26/2005 - 19:46
User Badges:

Just a thought... Don't you have 802.1x implemented?


Another thing - try to reset these phones to the factory default configuration:


1. **# to unlock the phone

2. (Settings) -> "3" -> "33"

3. "Yes" -> "Save"

4. Reboot.


Good luck,


Michael Shavrov

www.ciscoheadsetadapter.com


bhattacharya.s Wed, 12/28/2005 - 03:43
User Badges:

Hi,


I see that everyone has come up with good probable causes.


Check the phoneload on the new 7960 that you are trying to plug in and the phoneload in the Device Defaults page. I remember from my days in TAC, we used to have such issues being reported. The phoneload has to be upgraded to an interim one and then from there to the latest load (or whatever you have in the Device defaults)


So, let me know the phoneloads you have on the phone and the device defaults page.

MARTIN STREULE Wed, 12/28/2005 - 06:47
User Badges:
  • Silver, 250 points or more

I have seen this in cases where in DHCP the option 150 was done as ASCII instead IP address (wrong field type).


If you think you've done everything, check this option.

dhingst Wed, 12/28/2005 - 12:26
User Badges:

I've had this problem several times. It's due to a combindation of things. Try this...


Make sure your Windows dhcp server is connected to a switchport set for access mode rather than trunking like you would hook a normal users phone/pc to. There is an issue with dhcp and Windows where the dhcp server replies with an address on the native vlan rather than the data/voice vlan as it should. The easy way to check for this is look at your dhcp scopes and see if you see an entry for the phone in the wrong scope. Also if you have a sniffer you can look at the offered address and make sure it's appropriate for the network the phone is on. It should be for the voice vlan, not the data or native vlans of course.


There is an issue with firmware loads with new phones where they won't respond correctly to dhcp on a trunked switch port. The work-around is to plug the phone into a switch port set to access mode rather than as a trunk port. Let the phone boot and update its load and then it should be fine. The default load with a lot of new phones has a bug with dhcp. I highly recommend updating to the latest phone load.


For brand-new phones I usually have my techs plug them into an access port in the shop before deployment. It's an extra step but it makes sure the phone works when it hits the users desk. For phones that have been previously deployed we can just configure in CM and send them out saving a little time since they already have a good working load.


The other workaround was already discussed which is to set a static address on the phone, let it register and update it's load then switch back to dhcp.


bhattacharya.s Thu, 12/29/2005 - 02:11
User Badges:

Let us know the phoneload you have on the 7960 you are trying to connect and the phoneload you have in the Device Defaults page.


I don't think this issue is with the DHCP settings or anything, or else the 7940 phones wouldn't have worked.

Actions

This Discussion