Disabling DTP for 3550 switcport access

Unanswered Question
Jan 7th, 2006
User Badges:

As you all know, the ports in the 3550s comes with DTP enabled. I have gone through the messages posted in this group in last Nov. 23rd. The recommended solution to configure the port to "switchport nonegotiate" didn't work. I do get the message "Command rejected: Conflict between 'nonegotiate' and 'dynamic' status"


Please see the initial config. and the response to the command"-


!

interface GigabitEthernet0/2

switchport access vlan 20

switchport mode dynamic desirable

shutdown

end


sw2#conf t

Enter configuration commands, one per line. End with CNTL/Z.

sw2(config)#int gi0/2

sw2(config-if)#switchport nonegotiate

Command rejected: Conflict between 'nonegotiate' and 'dynamic' status.

sw2(config-if)#

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
konigl Sat, 01/07/2006 - 09:08
User Badges:
  • Gold, 750 points or more

If you want to disable DTP, you have to first specify the trunking status on a port manually: either "switchport mode access" or "switchport mode trunk". Then you can issue the "switchport nonegotiate" command.


The "switchport nonegotiate" command is valid only when the interface switchport mode is access or trunk. This command returns an error message if you attempt to execute it in dynamic (auto or desirable) mode.


When you use the "switchport mode dynamic desirable" or "switchport mode dynamic auto" commands on an interface, you are telling the switch to autonegotiate the trunk status on that interface. Trunk negotiation is managed by the Dynamic Trunking Protocol (DTP).


When you try to run "switchport nonegotiate" on a dynamic trunking port, you're telling the switch to NOT use DTP, the protocol that it needs to use to determine trunking status. That's why you get the error.

samisalim Sat, 01/07/2006 - 14:50
User Badges:

Thank you very much. Your input is proven working.

Actions

This Discussion