×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Multilink PPP on FR and ATM

Unanswered Question
Jan 10th, 2006
User Badges:

Hi ,


I am having this scenario:

Main site: Router 3745 (ATM)

Remote site: Router 1721 (FR)


I want to have a PVC of 256 between the 2 points.

On the remote site, hey cannot install a 256 access-point and pvc so they are going to install 2 x 128 PVCs.


I lknow i have to use mutlilink PPP and i have a sample configuration for it so i shouold be ok with that on the FR for the remote site.


However, i thought they would give me a 256kbps for my ATM site, and the ISP would take care of the multilink situation on their ATM-FR switch.


What is the correct scenario for this ??

Do i have to do multilink ppp on both routers main and remote, or

2. 2x128 kbps only on remote, and have a 'normal' 256 kpbs on main router and the ISP should take care of it????



Also, if i need to use multilink on ATM can someone give me a sample configuration example ???


Thanks,



George

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.5 (2 ratings)
Loading.
mheusinger Tue, 01/10/2006 - 01:27
User Badges:
  • Green, 3000 points or more

Hello,


first I would assume that you also get two PVCs on the ATM interface. as far as I know there is no way of "merging" two FR-ATM PVCs into one. So the ISP can not solve your problem there.

When you have two PVCs on each end it is your own "pleasure" to get multilink PPP up and running.


Sidenote: you could also setup load balancing through dynamic or static IP routing in this case.


For the ATM PVC it would be advisable to read

"Using Multilink PPP over ATM Links"

http://www.cisco.com/en/US/products/ps6350/products_configuration_guide_chapter09186a00804a4095.html


You wrote that you are aware on how to set up MLPPP on the FR side. In case you need help there as well just ask for it.


Hope this helps


Martin

Hope this helps

dukenukem Thu, 01/12/2006 - 01:54
User Badges:

Hi and thank you for your reply.


I am more interested now in the load balancing.

I have read that the router will automatically load balance if one or more paths are known to the same destination.


In my case, i have a central router 3745 and 6 remote disctrict offices, all which are stub networks.

So i only use static routing.


In one new district i want a 256 kbps PVC but the ISP can only provide 128. So he can give me 2 FR 128 kbps PVCs on the remote site and two ATM 128 PVCs on the 3745 router.


So if i used load balancing, it should be straight forward...


Can you please comment on my thoughts for my configuration.

I will have the correct FR and ATM configuration for each router.


IP ADDRESSING


cisco 1841 (remote) FR:

-----------------------

LAN IP : 10.51.122.X SM : 255.255.255.0


PVC 1 128 kbps IP: 10.51.10.30 SM: 255.255.255.252

PVC 2 128 kbps IP: 10.51.10.34 SM: 255.255.255.252



cisco 3745 (Central) ATM:

-------------------------

LAN IP: 10.51.22.X SM: 255.255.255.0


PVC 1 128 kbps IP: 10.51.10.29 SM: 255.255.255.252

PVC 2 128 kbps IP: 10.51.10.33 SM: 255.255.255.252



would these static routes work for load balancing:


Cisco 1841 (Remote)

static routing table:

----------------------

ip route 10.51.22.0 255.255.255.0 10.51.10.29

ip route 10.51.22.0 255.255.255.0 10.51.10.33


Cisco 3745 (Central)

static routing table

----------------------

ip route 10.51.122.0 255.255.255.0 10.51.10.30

ip route 10.51.122.0 255.255.255.0 10.51.10.34




Would these entries just be enough for load balancing to work ???


I have also posted a thread for a comparison between load balancing and Multilink PPP and why should i chose each one ????


Can you shed some more light on this please ??


Thanks,


George Serghiou

pkhatri Thu, 01/12/2006 - 02:01
User Badges:
  • Purple, 4500 points or more

Hi George,


Your config is fine. Your static routes will load balance over the 2 links as per your requirements. Just be sure that your provider supports FR-ATM OAM interworking so that your FR/ATM PVCs are brought down if there is a problem with the PVCs. Otherwise, you might end up black-holing half your traffic.


However, you will have the limitations that I have outlined in my response to your last post.


Paresh.

arvenugopal Tue, 01/10/2006 - 01:30
User Badges:

Hi George,

I hope you are looking for the Multilink over ATM please find the sample config for the requirement.


Note: This section shows the parts of a core Cisco 3660 router

!--- configuration that is relevant to MLPoATM.


class-map match-all Voice_Stream

match access-group 100

class-map match-all Voice_Control

match access-group 101


policy-map toortr01

class Voice_Stream

priority 175

class Voice_Control

bandwidth 18

random-detect


interface loopback0

ip address 10.16.0.105 255.255.255.252


interface ATM2/0

description To Carrier E3 ATM Service

no ip address


interface ATM2/0.15 point-to-point

pvc toortr01 0/58

vbr-nrt 406 406

tx-ring-limit 8

protocol ppp Virtual-Template15


interface Virtual-Template15

bandwidth 320

ip unnumbered loopback0

ip tcp header-compression iphc-format

service-policy output toortr01

ppp multilink

ppp multilink fragment-delay 14

ppp multilink interleave

ip rtp header-compression iphc-format



!--- Note: Do not configure

!--- IP addresses directly on any configuration source,

!--- such as a virtual template, whenever the possibility

!--- exists that this information is cloned to multiple

!--- active interfaces. The exception to this rule is the

!--- rare case where the intent is to define multiple parallel

!--- IP routes and have IP do load balancing between them.

!--- If an IP address is present on the configuration source,

!--- this IP address is copied to all the cloned interfaces.

!--- IP installs a route to each of these interfaces.


Branch Frame Relay Router


!--- Note: This section shows the parts of a branch Cisco 2600 router

!--- configurations that is relevant to MLPoFR.



class-map match-all Voice_Stream

match access-group 100

class-map match-all Voice_Control

match access-group 101


policy-map dhartr21

class Voice_Stream

priority 240

class Voice_Control

bandwidth 18

random-detect


interface loopback0

ip address 10.16.0.106 255.255.255.252


interface Serial0/0

description To Carrier Frame Relay Service

encapsulation frame-relay IETF

frame-relay traffic-shaping


interface Serial0/0.1 point-to-point

frame-relay interface-dlci 38 ppp Virtual-Template1

class dhartr21


interface Virtual-Template1

bandwidth 320

ip unnumbered loopback0

max-reserved-bandwidth 85

service-policy output dhartr21

ppp multilink

ppp multilink fragment-delay 10

ppp multilink interleave


map-class frame-relay dhartr21

frame-relay adaptive-shaping becn

frame-relay cir 320000

frame-relay bc 3200

frame-relay mincir 320000


ps: rate it if you find the docs useful.

Actions

This Discussion