×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

ADSL setup. DNS not able to resolve.

Unanswered Question
Jan 10th, 2006
User Badges:

Hi,

I setup the ADSL connection. The router is able to get the dynamic address from ISP and from router the ping with name and ip address is ok. But from client pc, ping with IP address is only possible and with name is bad. Internet access with name is also not going. Only with IP possible.

I have attached my config, please look and let me know if i have missed any line.

My router is 1841-ADVSECURITYK9-M, Version 12.4(3a)

Thank you.




Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
pkhatri Tue, 01/10/2006 - 03:21
User Badges:
  • Purple, 4500 points or more

Hi,


One problem I can see is that your PC is configured to have the following DNS server: 172.29.162.1


This happens to also be the IP address of interface FastEthernet0/0. That is not going to work. Set the DNS servers on your Win2k machine to be the same as those on your router i.e.

A.B.C.250 ----> DNS

L.M.N.6 ------> DNS


That should fix it.


Hope that helps... pls rate the post if it does.


Paresh.

examples20001 Tue, 01/10/2006 - 03:45
User Badges:

Thank you very much.

Can you please tell why the spoofing is shown for Dialer0.


Dialer0 is up, line protocol is up (spoofing)

spremkumar Tue, 01/10/2006 - 06:11
User Badges:
  • Red, 2250 points or more

hi


AFAIK spoofing does tells that the conection can be established as on when its required.


Its the information being sent to the IOS that the connectivity is operational though physical connectivity might not need to be there(live) at that point of time.


regds


spremkumar Tue, 01/10/2006 - 03:26
User Badges:
  • Red, 2250 points or more

Hi


Change the DNS entries in ur wkstation to L.M.N.6


A.B.C.250 and check for pinging/browsing the outside domains..


regds


examples20001 Tue, 01/10/2006 - 03:56
User Badges:

Is it possible to use the DNS address as router address 172.29.162.1 in client pc, with out using DHCP. It is because, if we change the ISP, we need to change all the clinets DNS address also.

Is there any way to setup in router for DNS reolve for clinet connections?

pkhatri Tue, 01/10/2006 - 04:08
User Badges:
  • Purple, 4500 points or more

Why don't you use a dummy IP address as the DNS server address in all your client PCs and setup a static outside NAT translation on your router that maps this dummy address to the real DNS server. That way, when you change ISPs, all you change is the NAT statement.


Note that you cannot use a dummy IP that is in the same subnet as your ethernet addresses ... this will not work with NAT since the PCs will try to arp for this address. Pick some other address that is unlikely to overlap with anything else.


Paresh.

examples20001 Tue, 01/10/2006 - 19:01
User Badges:

Hi All

Thank you very much for the inputs,

In first test, I setup the DNS address in client pc and ping/browsing to outside domain worked.

In second test, I NATed the DNS address with dummay IP in the router and used the dummay ip client pc. ping/browsing wotked fine.


ip nat outside source static udp L.M.N.6 53 172.29.161.2 53 extendable

ip nat outside source static udp A.B.C.250 53 172.29.161.1 53 extendable


C:\>ipconfig /all

Windows 2000 IP Configuration

Host Name . . . . . . . . . . . . : examples20001

Primary DNS Suffix . . . . . . . :

Node Type . . . . . . . . . . . . : Broadcast

IP Routing Enabled. . . . . . . . : No

WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :

Description . . . . . . . . . . . : Intel 8255x-based PCI Ethernet Adapter (10/100)

Physical Address. . . . . . . . . : 00-00-E2-60-4C-CC

DHCP Enabled. . . . . . . . . . . : No

IP Address. . . . . . . . . . . . : 172.29.162.10

Subnet Mask . . . . . . . . . . . : 255.255.255.0

Default Gateway . . . . . . . . . : 172.29.162.1

DNS Servers . . . . . . . . . . . : 172.29.161.1

172.29.161.2

C:\>

C:\>ping yahoo.com

Pinging yahoo.com [216.109.112.135] with 32 bytes of data:

Reply from 216.109.112.135: bytes=32 time=200ms TTL=47

Reply from 216.109.112.135: bytes=32 time=199ms TTL=47

Reply from 216.109.112.135: bytes=32 time=200ms TTL=47

Reply from 216.109.112.135: bytes=32 time=200ms TTL=47

Ping statistics for 216.109.112.135:

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

Minimum = 199ms, Maximum = 200ms, Average = 199ms

C:\>

TestC#show ip nat translations

Pro Inside global Inside local Outside local Outside global

udp --- --- 172.29.161.1:53 A.B.C.250:53

udp --- --- 172.29.161.2:53 L.M.N.6:53

icmp X.Y.Z.28:512 172.29.162.10:512 216.109.112.135:512 216.109.112.135:512

udp X.Y.Z.28:1607 172.29.162.10:1607 172.29.161.1:53 A.B.C.250:53

TestC#

pkhatri Tue, 01/10/2006 - 19:20
User Badges:
  • Purple, 4500 points or more

No problems.


Pls do rate posts that help.


Paresh.

examples20001 Tue, 01/10/2006 - 20:24
User Badges:

Hello NetPro designers,

Why I am not able to rate the posts other than the first two. I want to rate all the posts, as all the posts helped me lot and solved the problem. Post of Paresh is not able to rate at all.

Please look the problem...

Actions

This Discussion