×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

NO-NAT / Cisco 837 ADSL Router

Unanswered Question
Jan 10th, 2006
User Badges:

I am currently try to configure a 837 with a block of 16 public ip address i do not need private ip's dhcp dns or anything else from the router just for the usable ip to be routed back and fourth can any one point me in the right direct for some config's


Many Thanks

Aaron Bolton

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
pkhatri Tue, 01/10/2006 - 16:34
User Badges:
  • Purple, 4500 points or more

Hi Aaron,


Since you are saying NO-NAT, I presume you do not want to use NAT. I also presume that this block of public IPs is to be used on your LAN segment behind the router.


Essentially, all you need to do is:

1. configure the LAN interface on your router with an IP address in this public range.

2. Assign IP addresses from this range to your PCs on this LAN segment

3, Configure a default route on your 837 that points to the WAN interface

4. Instruct your ISP to route this public range to your WAN link.


Hope that helps,

Paresh.

abolton291078 Tue, 01/10/2006 - 21:47
User Badges:

Hi there,


thanks for the quick reply, what im trying to do is pretty much what you have described although i need the router interfaces ATM0 and ETH0 to have the same ip so i am not wasting 2 ip's on the router and the ISP is already doing the routing, basicly the connection is already there i have upgraded the router from an old effecient network 5861 to the Cisco 837 and im looking for some example config which i can modify to fit my exsisting network

pkhatri Tue, 01/10/2006 - 21:57
User Badges:
  • Purple, 4500 points or more

Hi Aaron,


You cannot assign the same IP address to more than one interface.


Since you stated that you have 16 public IPs, I presume you have a /28 block, giving you 14 useable addresses. One possibility is to divide the block into two /29 blocks, giving you 6 useable addresses per block. You would then use one block on your ATM interface and the other on your Ethernet interface. However, I have a feeling that you are not going to like that.


An alternative is to setup your 837 to be a bridge. In that case, you would not have to assign any IPs to the 837 at all. However, in that case you would have to get your ISP to use RBE (routed bridge encapsulation) to terminate the ATM link. That would give you a lot more addresses to use on your LAN segment. I have a config that does precisely this if you choose to go down this path...


Hope that helps.. pls rate helpful posts.


Regards

Paresh.

pkhatri Tue, 01/10/2006 - 22:05
User Badges:
  • Purple, 4500 points or more

Hi again,


Usually the ISP would assign you a /30 or /31 subnet for your WAN link.. are you sure your ISP has not done that ?


Paresh



arvenugopal Tue, 01/10/2006 - 22:37
User Badges:

Hi

to summarise the things,

1) you can use the block of 16 IPS with with CRB. the url is given below

http://www.cisco.com/en/US/products/hw/routers/ps380/products_configuration_guide_chapter09186a0080118d24.html#19696


2) if your ISP Gives gives you the /30 or 31 it makes the life simple and easier.all that you have to do is use the 16 block ip in ur lan

hope it helps

abolton291078 Wed, 01/11/2006 - 01:14
User Badges:

Hello again,


I do have a block of 16 /28 public ip's and as mentioned only 14 are usable the config i am looking for is below, I have done this on 2 other routers generally with out a problem even on this same connection. unfortunatly i cannot get the isp to make any changes to how they provided these to me


81.xxx.xxx.96 - Networks Address (un-usable)

81.xxx.xxx.97 - Router - Hopefully Cisco 837 :)

81.xxx.xxx.98 - Server, workstation or other device

81.xxx.xxx.99 - Server, workstation or other device

81.xxx.xxx.100 - Server, workstation or other device

81.xxx.xxx.101 - Server, workstation or other device

81.xxx.xxx.102 - Server, workstation or other device

81.xxx.xxx.103 - Server, workstation or other device

81.xxx.xxx.104 - Server, workstation or other device

81.xxx.xxx.105 - Server, workstation or other device

81.xxx.xxx.106 - Server, workstation or other device

81.xxx.xxx.107 - Server, workstation or other device

81.xxx.xxx.108 - Server, workstation or other device

81.xxx.xxx.109 - Server, workstation or other device

81.xxx.xxx.110 - Server, workstation or other device

81.xxx.xxx.111 - Broadcast Address (un-usable)


I hope this explains my scenario a little better

abolton291078 Wed, 01/11/2006 - 01:44
User Badges:

I have fond this configure after a bit of googling should this fit my needs


Your ADSL login: [email protected]

Your ADSL Password: lxxxxxxx

Virtual Path Identifier: 0

Virtual Channel Identifier: 38

Data Link Encapsulation: PPPoA (PPP over ATM)

PPP Properties: VC Multiplexed or VC Based or VCMUX

Below are details of the static IP addresses allocated to you:

Network: x.x.40.32

Gateway*: x.x.40.33

Netmask: 255.255.255.240

* The gateway address will be automatically assigned to your router when

you connect via DHCP.


This is the configuration I have created :-

hostname voiprouter

enable secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxxxx

no aaa new-model

ip subnet-zero

ip routing

ip ips po max-events 100

no ftp-server write-enable

interface Ethernet0

ip address x.x.40.34 255.255.255.240

no ip route-cache

hold-queue 100 out

!

interface ATM0

no ip address

no ip route-cache

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

no ip route-cache

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

!

interface FastEthernet1

no ip address

duplex auto

speed auto

!

interface FastEthernet2

no ip address

duplex auto

speed auto

!

interface FastEthernet3

no ip address

duplex auto

speed auto

!

interface FastEthernet4

no ip address

duplex auto

speed auto

!

interface Dialer0

description $FW_OUTSIDE$

ip address dhcp

ip mtu 1452

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname USERNAME

ppp chap password 0 PASSWORD

ppp pap sent-username USERNAME password PASSWORD

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer0

no ip http server

no ip http secure-server

!

control-plane

!

scheduler max-task-time 5000

end


beckerola Wed, 01/11/2006 - 01:21
User Badges:

And wouldn't it be more simple just doing an "ip unnumbered ethernet0" on the ATM interface?

This will save one IP address on the router, although you will have to use another one in the same range on the other side. In any case you are saving one IP.

Maybe I lost something but I think this should work.


Hope it helps.


Regards

abolton291078 Wed, 01/11/2006 - 01:25
User Badges:

this is very close to what i am looking for do you know any example configs as i am very new to cisco and need a base to start from.

beckerola Wed, 01/11/2006 - 02:00
User Badges:

This link may help. The first example refers to serial ports but they are valid for ATM interfaces as well. Teh seconf one uses ATM and as you can see, if you want to use ATM sub-interfaces, ip unnumbered works for it too.


Hope it helps.



http://www.cisco.com/warp/public/701/20.html


http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a0080094344.shtml

abolton291078 Wed, 01/11/2006 - 03:38
User Badges:

this looks like the solution


1. assign the WAN ip to the eth0

2. then use ip unumbered for the atm0

3. create the dialer profiles

Actions

This Discussion