×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

EIGRP Routing Question

Answered Question
Jan 17th, 2006
User Badges:

interface Vlan110

ip address 136.160.196.1 255.255.255.0

!

interface Vlan310

ip address 136.160.197.1 255.255.255.192

!

interface Vlan610

ip address 192.168.180.1 255.255.255.0

!

interface Vlan710

ip address 192.168.150.1 255.255.255.0

!

interface Vlan910

ip address 192.168.254.84 255.255.255.248

!

router eigrp 411

network 136.160.0.0

network 192.168.0.0

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.254.81

=======================================

Core-SC1#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route


Gateway of last resort is 192.168.254.81 to network 0.0.0.0


136.160.0.0/16 is variably subnetted, 2 subnets, 2 masks

C 136.160.196.0/24 is directly connected, Vlan110

C 136.160.197.0/26 is directly connected, Vlan310

C 192.168.150.0/24 is directly connected, Vlan710

C 192.168.180.0/24 is directly connected, Vlan610

192.168.254.0/29 is subnetted, 1 subnets

C 192.168.254.80 is directly connected, Vlan910

S* 0.0.0.0/0 [1/0] via 192.168.254.81

Core-SC1#sh ip eigrp top

IP-EIGRP Topology Table for AS(411)/ID(192.168.254.84)


Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

r - reply Status, s - sia Status


P 136.160.196.0/24, 1 successors, FD is 2816

via Connected, Vlan110

P 136.160.197.0/26, 1 successors, FD is 2816

via Connected, Vlan310

=======================================

Why wouldn't subnets in 192.168.0.0 network show up in the "sh ip eigrp top"?

Correct Answer by pkhatri about 11 years 7 months ago

Hi,


Try replacing your 'network 192.168.0.0' statement under router eigrp with 'network 192.168.0.0 0.0.255.255'.


By default, if a mask is not specified, the network statement is treated as a classful network and in your case, the mask would default to 0.0.0.255


Hope that helps - pls rate the post if it does.


Regards,

Paresh

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
pkhatri Tue, 01/17/2006 - 16:40
User Badges:
  • Purple, 4500 points or more

Hi,


Try replacing your 'network 192.168.0.0' statement under router eigrp with 'network 192.168.0.0 0.0.255.255'.


By default, if a mask is not specified, the network statement is treated as a classful network and in your case, the mask would default to 0.0.0.255


Hope that helps - pls rate the post if it does.


Regards,

Paresh

Richard Burts Tue, 01/17/2006 - 18:14
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

I think that the answer given by Paresh is one correct alternative. Another alternative is to replace the one network statement for 192.168.0.0 with two network statements, one for each of the class C 192.168 networks on the interfaces.


Another way to understand the impact of the original configuration is to do the command show ip eigrp interface. If you do this you will see that neither of the 192.168 interfaces are currently included in EIGRP since they do not match the 192.168.0.0 network statement.


HTH


Rick

AmnardC04 Tue, 01/17/2006 - 20:20
User Badges:

That's it! Thank a lot!!!

I couldn't believe I missed something this simple...


Actions

This Discussion