cookie persistence for HTTP traffic

Unanswered Question
Jan 19th, 2006
User Badges:

hello,

i have the following situation: on an 11506, clients connects to VIP on port 80, this VIP maps to port 7777 on 2 services. The objective is to configure cookie persistence for http. The cookie persistence should be for URI /thestring/

I have used

advanced-balance cookies

string prefix "/thestring/"

in the content rule and it did not work.

Does this have anything to do with the port changing from 80 to 7777, or am i missing something for cookie persistence?


Regards

Bassam

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
pgolding Thu, 01/19/2006 - 20:14
User Badges:

p.s. - changing port from 80 to 7777 is not causing this problem.


bissrached Fri, 01/20/2006 - 00:37
User Badges:

thx for you reply; still it sometimes work and sometimes dont

my service config:

service ebizsso1

keepalive frequency 3

keepalive port 7777

ip address 10.10.230.82

port 7777

protocol tcp

string /oiddas/

active

my content rule

content ebizsso-servers

add service ebizsso1

vip address 10.10.231.9

protocol tcp

port 80

advanced-balance cookieurl

string prefix "/oiddas/"

active


is this is the required?

thank you

bassam

Gilles Dufour Fri, 01/20/2006 - 02:33
User Badges:
  • Cisco Employee,

Bassam,


remove the 'string prefix' command and replace it with the command 'url "/oiddas/*"'.

I assume what you want is match the every url starting with oiddas ? correct ?

If not, simply remove the string prefix and add 'url "/*"'.


Regards,


Gilles.

Thanks for rating this answer.

bissrached Fri, 01/20/2006 - 03:58
User Badges:

Thx Gilles,

But my requirement was to match a URI, so the url may start with something different. Is this the same? or should i use url '"*/oiddas/*"'

Do you think i should keep the "string in the service or also remove it?


Thank you

bissrached Fri, 01/20/2006 - 04:38
User Badges:

Thank you guys,


Now that i've testing many options, including the one you have adviced, i have the following:

Both solutions you did advice works for quite a time, and stops sudenly for 10 minutes and work again after few minutes. ever seen this with cookies on css?


My question now: is there any chance that the css works fine with a configuration (as the one i did sent) and then stop? or should i start to check for the problem somewhere else.

PS: services on the refered servers are up all the time.

patrickdonlon Fri, 01/20/2006 - 04:48
User Badges:

Bassam


I've had similar experiences to this with an oracle app'. I use the 11000 and 11500 CSSs and used the arrowpoint cookie because the cookie was unique per session and it was not possible to match a prefix.


Pat

Gilles Dufour Fri, 01/20/2006 - 05:51
User Badges:
  • Cisco Employee,

there is no way the css would stop working after 10 minutes.

What could happen is if you have idle connections, the css will stop looking for the cookie for those connections.

If you have a css 11500, use the 'flow-timeout-multiplier' with a value of 10 and see if this improves the situation.

You may have to adjust the value higher.


Regards,


Gilles.

bissrached Fri, 01/20/2006 - 07:26
User Badges:

Thx patric for your input. It has been working for half an hour fine with no disruption.

How did you configure the arrowpoint-cookie to expire when the client browser is closed?


Gilles, do you think that increasing the "flow timeout-multiplier" and configuring arrowpoint-cookie to expire with browser (i don't know if this is feasible) will work together?


Thank a mile

patrickdonlon Fri, 01/20/2006 - 07:49
User Badges:

The cookie is set when the client logs in, I don't think there's a timeout to configure it's a value that's hashed (could be wrong here!). If you look at the cookie generated, it's very basic and you can see the name of the service in the cookie and the cookie generated from the apache server.


Pat

Actions

This Discussion