IOS DHCP for Nortel i2004 VoIP phones

Unanswered Question
Feb 3rd, 2006

I need to setup a IOS dhcp server for nortel voip phones. I have info on what the phones does during dhcp handshake:

1. Requests options (via option 55) 43, 128,144,157,191

2. It gets an address and a option with the vlan it should be on (voice vlan)

3. It drops the address and re-requests its dhcp info form the voice vlan

I am using Version 12.2(18)SXE2 on 6509 720 supervisor. I am setting up a voice vlan for phones. Does anyone know how to configure DHCP raw options to allow nortel phone to attach to voice vlan and obtain voip ip address?

Option 191 should be used to tell what vlan to attach to for voice.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
thisisshanky Fri, 02/03/2006 - 13:06

Voice vlan info is communicated to phones via CDP. I am sure Nortel doesnt support CDP so I dont think Voice vlan config would work.

jkowalke Mon, 02/06/2006 - 10:35

Thankyou for your response but what I need is info on the IOS DHCP configuration. I have info on how to make the Nortel phone use the voice lan. I just need info on IOS DHCP server and how to use the raw options.

jkowalke Wed, 02/08/2006 - 13:16

For anyone interested, through trial and error I made a Nortel phone get reconnected to voice vlan and pc attached to internal switch on phone attach to data network

1. Setup Nortel VoIP phone for "full DHCP"

2.Create DHCP pools in IOS with options

ip dhcp pool TestDataVoIP (DATA VLAN temporarily vlan 1)

network 172.17.0.0 255.255.0.0

default-router 172.17.0.2

option 191 ascii "VLAN-A:10."

option 128 ascii "Nortel-i2004-A."

ip dhcp pool Test_VoIP (VOICE VLAN 10)

network 172.18.0.0 255.255.0.0

default-router 172.18.0.1

option 128 ascii "Nortel-i2004-A,172.18.0.10:4100,1,5;172.18.0.10:4100,1,7."

3. configure switchport for voice vlan

interface FastEthernet1/0/1

switchport mode access

switchport voice vlan 10

duplex full

speed 100

spanning-tree portfast

Attach Nortel phone to port and powerup

Debug messages on IOS DHCP server:

06:36:14: DHCPD: DHCPDISCOVER received from client 000a.e40c.118a on interface Vlan1.

06:36:21: DHCPD: Sending DHCPOFFER to client 000a.e40c.118a (172.17.0.9).

06:36:21: DHCPD: creating ARP entry (172.17.0.9, 000a.e40c.118a).

06:36:21: DHCPD: unicasting BOOTREPLY to client 000a.e40c.118a (172.17.0.9).

06:36:21: DHCPD: DHCPDISCOVER received from client 000a.e40c.118a on interface Vlan1.

06:36:21: DHCPD: Sending DHCPOFFER to client 000a.e40c.118a (172.17.0.9).

06:36:21: DHCPD: creating ARP entry (172.17.0.9, 000a.e40c.118a).

06:36:21: DHCPD: unicasting BOOTREPLY to client 000a.e40c.118a (172.17.0.9).

06:36:22: DHCPD: DHCPREQUEST received from client 000a.e40c.118a.

06:36:22: DHCPD: Sending DHCPACK to client 000a.e40c.118a (172.17.0.9).

06:36:22: DHCPD: creating ARP entry (172.17.0.9, 000a.e40c.118a).

06:36:22: DHCPD: unicasting BOOTREPLY to client 000a.e40c.118a (172.17.0.9).

06:36:22: DHCPD: DHCPRELEASE message received from client 000a.e40c.118a (172.17.0.9).

06:36:32: DHCPD: DHCPDISCOVER received from client 000a.e40c.118a on interface Vlan10.

06:36:39: DHCPD: Sending DHCPOFFER to client 000a.e40c.118a (172.18.0.6).

06:36:39: DHCPD: creating ARP entry (172.18.0.6, 000a.e40c.118a).

06:36:39: DHCPD: unicasting BOOTREPLY to client 000a.e40c.118a (172.18.0.6).

06:36:39: DHCPD: DHCPDISCOVER received from client 000a.e40c.118a on interface Vlan10.

06:36:39: DHCPD: Sending DHCPOFFER to client 000a.e40c.118a (172.18.0.6).

06:36:39: DHCPD: creating ARP entry (172.18.0.6, 000a.e40c.118a).

06:36:39: DHCPD: unicasting BOOTREPLY to client 000a.e40c.118a (172.18.0.6).

06:36:48: DHCPD: DHCPDISCOVER received from client 000a.e40c.118a on interface Vlan10.

06:36:48: DHCPD: Sending DHCPOFFER to client 000a.e40c.118a (172.18.0.6).

06:36:48: DHCPD: broadcasting BOOTREPLY to client 000a.e40c.118a.

06:36:49: DHCPD: DHCPREQUEST received from client 000a.e40c.118a.

06:36:49: DHCPD: Sending DHCPACK to client 000a.e40c.118a (172.18.0.6).

06:36:49: DHCPD: broadcasting BOOTREPLY to client 000a.e40c.118a.

Actions

Login or Register to take actions

This Discussion

Posted February 3, 2006 at 12:24 PM
Stats:
Replies:3 Overall Rating:
Views:826 Votes:0
Shares:0
Tags: No tags.