×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Layer 2 Problem with MAC address ?

Unanswered Question
Feb 5th, 2006
User Badges:

I am using a Cisco 1801. I have a /30 network with one static public IP on my end and the other useable IP being the gateway on the ISP's side.


The connection works fine for a few hours, after which it just drops comms and I get no data flow. I'll power cycle the Cisco 1801 and still no data flow, but the CD light is on solid.


The odd thing is that to establish data flow again, I have to remove the Cisco 1801 and plug in a netgear router. I then plug the Cisco 1801 back in and everything works fine for a few more hours. I'm continually having to do this to get the Cisco 1801 to work.


The ISP says it's a layer 2 problem because when my connection goes down they can't see any MAC address coming from my end. Even after power cycling the Cisco 1801, they still can not see any MAC address on my end. When I plug the netgear router in, they then can see a MAC address on my end.


Is it my Cisco 1801 that's the problem or something on the ISP's side?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Richard Burts Sun, 02/05/2006 - 17:01
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Is it possible that the few hours that it works is 4 hours? If it does run for 4 hours and then fail I would guess that it might be a problem in the ARP cache.


If you could give us some more information, what kind of interface, configuration of the router, pehaps show interface, and maybe show ARP, then we might be better able to see what is causing this problem.


HTH


Rick

andysaykao Tue, 02/07/2006 - 17:18
User Badges:

It doesn't run for four hours and then fail.


Below is the edited show run.


Please find attached the show interfaces, show arp and show version output.


Thanks for everyone's help so far.


-----


#show run

Building configuration...


Current configuration : 4918 bytes

!


version 12.3

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

service sequence-numbers

!

hostname xxxxxx

!

boot-start-marker

boot-end-marker

!

security authentication failure rate 3 log

security passwords min-length 6

logging buffered 51200 warnings

enable secret xxxx

!

username xxx privilege 15 secret xxxx

clock timezone PCTime 10

clock summer-time PCTime date Mar 30 2003 3:00 Oct 26 2003 2:00

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

no aaa new-model

ip subnet-zero

no ip source-route

!

!

ip cef

ip tcp synwait-time 10

!

!

no ip bootp server

ip domain name see.com.au

ip name-server aa.aa.aa.aa

ip name-server bb.bb.bb.bb

no ftp-server write-enable

!

!

!

interface Null0

no ip unreachables

!

interface ATM0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.2 point-to-point

mtu 1457

ip address yy.yy.yy.yy 255.255.255.252

ip nat outside

pvc 1/32

encapsulation aal5snap

!

!

interface BRI0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

shutdown

no cdp enable

!

interface FastEthernet0

description Wireless Link$FW_INSIDE$$ETH-LAN$

ip address 192.168.0.2 255.255.255.0

duplex auto

speed auto

no cdp enable

!

interface Vlan1

description 8 Port LAN Switch$ETH-SW-LAUNCH$$INTF-INFO-FE 1$$FW_INSIDE$

ip address 192.168.2.1 255.255.255.0

ip nat inside

ip route-cache flow

!

interface Dialer0

no ip address

no cdp enable

!

router rip

version 2

network 192.168.0.0

network 192.168.2.0

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 ATM0.2

ip route 192.168.1.0 255.255.255.0 192.168.0.1 permanent

!

ip http server

ip http access-class 2

ip http authentication local

ip http timeout-policy idle 600 life 86400 requests 10000

ip nat inside source list 1 interface ATM0.2 overload

ip nat inside source static tcp 192.168.2.210 8000 interface Dialer0 8000

ip nat inside source static tcp 192.168.2.210 80 interface ATM0.2 80

!

ip access-list extended sdm_fastethernet0_in

remark SDM_ACL Category=1

remark port-87

permit tcp any eq 87 any eq 87 log

!

access-list 1 remark INSIDE_IF=Vlan1

access-list 1 remark SDM_ACL Category=2

access-list 1 permit 192.168.2.0 0.0.0.255

access-list 2 remark HTTP Access-class list

access-list 2 remark SDM_ACL Category=1

access-list 2 permit 192.168.0.0 0.0.0.255

access-list 2 permit 192.168.2.0 0.0.0.255

access-list 2 permit 192.168.1.0 0.0.0.255

access-list 2 deny any

access-list 100 remark VTY Access-class list

access-list 100 remark SDM_ACL Category=1

access-list 100 permit ip 192.168.0.0 0.0.0.255 any

access-list 100 permit ip 192.168.2.0 0.0.0.255 any

access-list 100 deny ip any any

no cdp run

!

control-plane

!

line con 0

login local

transport output telnet

line aux 0

login local

transport output telnet

line vty 0 4

access-class 100 in

privilege level 15

login local

transport input telnet

line vty 5 15

access-class 100 in

privilege level 15

login local

transport input telnet

!

scheduler allocate 4000 1000

scheduler interval 500

end


-----





Attachment: 
nethelper Sun, 02/05/2006 - 17:04
User Badges:
  • Silver, 250 points or more

Hello,


you could try and configure the arp timeout to never timeout:


arp timeout 0


Which IOS version are you running, and what kind of connection do you have to your ISP (e.g. Leased Line PPP, Frame Relay)?


Regards,


Nethelper

andysaykao Tue, 02/07/2006 - 18:11
User Badges:

It's a ADSL connection with one public IP on our end and the gateway on the ISP's end.


#show version

Cisco IOS Software, C180X Software (C180X-BROADBAND-M), Version 12.3(8)YI1, RELEASE SOFTWARE (fc1)

Synched to technology version 12.3(10.3)T2

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2005 by Cisco Systems, Inc.

Compiled Fri 22-Apr-05 15:54 by ealyon


ROM: System Bootstrap, Version 12.3(8r)YH5, RELEASE SOFTWARE (fc1)

ROM: Cisco IOS Software, C180X Software (C180X-BROADBAND-M), Version 12.3(8)YI1, RELEASE SOFTWARE (fc1)


branch-router uptime is 2 days, 1 hour, 11 minutes

System returned to ROM by power-on

System image file is "flash:c180x-broadband-mz.123-8.YI1.bin"


Cisco 1801 (MPC8500) processor (revision 0x200) with 118784K/12288K bytes of memory.

Processor board ID FHK0940115G, with hardware revision 0000


9 FastEthernet interfaces

1 ISDN Basic Rate interface

1 ATM interface

31360K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2102

scottmac Sun, 02/05/2006 - 20:36
User Badges:
  • Green, 3000 points or more

You could try using a locally administered MAC address (replace the 1801's MAC with the MAC of the Netgear).


In the cable broadband environment, some providers enforce the use of a single MAC at the destination.


If you originally registered the Netgear as your router, something at the ISP may be trying to keep it as the only valid device.


It's pretty thin, as suggestions go, but if it comes down to the "beat your head against the wall" stage of troubleshooting, give it a shot.


It could also be a flakey 1801 (or interface). Substituting the Netgear gives the 1801 time to cool off so it's ready for another couple hours (then it heats up, flakes out, gets a break , cools off ......).


Make sure there's plenty of "breathing room" around the 1801.


FWIW


Scott




Actions

This Discussion