output drops on Multilink

Unanswered Question

Hi

A (2621 XM) - B (3640 ) - C (3725)

Between A to C total of 2 X E1 ckts are present. Multilink is configured on the links. Lot of output drops are seen in the multilink interfaces. This drops are really affecting the perforamance of the links.


No QOS implemented in the routers.

A - B Internaitonal Ckt

B- C Domestic Ckt

Static routing are configured.


Any thoughts to reduce the output drops ...


Thanks

regards

R.Sundara Rajan


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
spremkumar Thu, 02/09/2006 - 00:26
User Badges:
  • Red, 2250 points or more

Hi


Output drops are caused by a congested interface. For example, the traffic rate on the outgoing interface cannot accept all packets that should be sent out. The ultimate solution to resolve the problem is to increase the line speed. However, there are ways to prevent, decrease, or control output drops when you do not want to increase the line speed. You can prevent output drops only if output drops are a consequence of short bursts of data. If output drops are caused by a constant high-rate flow, you cannot prevent the drops. However, you can control them


do refer the link on troubleshooting Output drops..


http://www.cisco.com/en/US/products/hw/routers/ps133/products_tech_note09186a0080094791.shtml#drops


Also do revert how your multilink is built over Router B (3640),i feel you need to throw some lite over the multilink bundling which is there between the routers and where you are exactly seeing the errors.

whether you are seeing on one particular end or on both the ends ?


regds



lgijssel Thu, 02/09/2006 - 02:24
User Badges:
  • Red, 2250 points or more

Looking at your config, I noticed that you do not have the bandwidth defined on the serial links. This parameter is used by the router to scale the flow through an interface. It's presence and accuracy is not as unimportant as many may think.

Under the current circumstances you are using the default value of 1544kbps on the serials. Drops may result if this value does not match the actual situation. My advice would be to adjust it for the serials and probably for the multilinks as well.


Regards,

Leo

Hi


When I see the interfaces output it clearly specifies they are of 2 Mbps Ckt.


I had checked this on the Serial interfaces on all the routers and output is as follows.

MTU 1500 bytes, BW 1984 Kbit, DLY 20000 usec,


Multilink Interfaces output

MTU 1500 bytes, BW 3968 Kbit, DLY 100000 usec,


regards

Sundara

spremkumar Thu, 02/09/2006 - 03:00
User Badges:
  • Red, 2250 points or more

hi sundar


few quick checks ..


1.whats the normal loading conditions on these links ? do you have any backend mechnasim to record or keep track on the bandwidth usage conditions of the multilinks ?

2.Are you seeing any errorneous logs in any of these routers ?

3.whats the CPU utilisation as well as memory utilisation in the routers especially in 3640 ?


regds


Hi Prem.


1. Loading conditions starts after 13:00 hrs of IST.

A - Network is of UK . C - India.

Earlier the ckt was with only e1link. Since there utilization increased so much that a quick fix solution of adding one more linkand configuring E1 was made. Presently traffic is seen till 2.6 Mbps on the Multilink

2. Enormous amount of drops are making the drop in packets. ( 3640 not able to take 4 multilinkconfiguration since small packets are really affecting it )

3. CPU utilization of the 3640 goes very high and drop in rates is very very high. 32 Mb Flash & 128 MB of Memory is present.


regards

Sundara

spremkumar Thu, 02/09/2006 - 04:30
User Badges:
  • Red, 2250 points or more

hi


The second point which you have highlited in your post about the possible backlog of smaller packets you can check out on LFI which is designed to help the smaller packets the opportunity to get placed on the wire in regular intervals rather than getting backlogged...


http://www.cisco.com/en/US/products/sw/iosswrel/ps1835/products_configuration_guide_chapter09186a00800b75d2.html


Also you have mentioned the CPU utilisation is already peaking up so i wont go for LFI in first place here which may end up in crashing the box itself.


regds

lgijssel Thu, 02/09/2006 - 04:48
User Badges:
  • Red, 2250 points or more

Hi Sundara,


It is well known that using multilink is putting a heavy load on the CPU. A 3640 is not too well up to that. Is it correct that you have decided to put a 2nd link next to an existing one due to a growing demand for bandwidth?

In that case, it is no absolute requirement to utilize multilinks, you may just as well use ordinary load balancing over equal bandwidth links. This will reduce CPU loads and may hence increase your throughput. I do not think that multilink is required here to preserve voice quality. This is sometimes needed due to serialization delays but in my opinion you have sufficient bandwidth available.


Regards,

Leo

pkhatri Thu, 02/09/2006 - 14:30
User Badges:
  • Purple, 4500 points or more

Hi Sundara,


Just as a thought, could you try to disable fragmentation altogether, by configuring the following under your multilink interface:

ppp multilink fragment disable


It might help with reducing your CPU utilisation.


Paresh

Actions

This Discussion