×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

827H ATM no layer1 connection

Unanswered Question
Feb 10th, 2006
User Badges:

Hi gentlemen,

I'm configuring a 827H router to connect to 640Kbps ADSL SP Tele2 Italia.

Before I have had very IOS problems and now I have found a stable IOS.... maybe.

The SP router requirement are:

- Protocol = PPPoA (1577 RFC Routed)

- VPI/VCI = 8/35

- encapsulation = LLC

- Modulation = Multimode

- Authentication protocol = PAP or CHAP

.

Connecting the ADSL line to a ADSL Trust modem the line is OK. The ADSL modem requirements are PPPoA, 8/35, VCMUX/NULL, Multimode, PAP or CHAP.

Instead connecting the ADSL line to 827H, I receive in "debug atm events" these messages:

============================

00:13:22: DSL: 1: Modem state = 0x8

00:13:25: DSL: 2: Modem state = 0x8

00:13:27: DSL: 3: Modem state = 0x8

00:13:30: DSL: 4: Modem state = 0x8

00:13:32: DSL: 5: Modem state = 0x8

00:13:35: DSL: 6: Modem state = 0x8

00:13:37: DSL: 7: Modem state = 0x8

00:13:40: DSL: 8: Modem state = 0x8

00:13:42: DSL: 9: Modem state = 0x8

00:13:45: DSL: 10: Modem state = 0x8

00:13:47: DSL: 11: Modem state = 0x8

00:13:50: DSL: 12: Modem state = 0x8

00:13:52: DSL: 13: Modem state = 0x8

00:13:55: DSL: 14: Modem state = 0x8

00:13:57: DSL: 15: Modem state = 0x8

00:14:00: DSL: 16: Modem state = 0x10

00:14:02: DSL: 17: Modem state = 0x10

00:14:05: DSL: 18: Modem state = 0x10

00:14:06: DSL: Received response: 0x22

00:14:06: DSL: Open failed: Req. min. rate + noise margin + PSD not possible on the line -- retrying

00:14:09: DSL: Trying to bring up DSL line using Embedded firmware version : 3.9.19

00:14:09: DSL: Send ADSL_OPEN command.

00:14:09: DSL: Using subfunction 0x15

00:14:09: DSL: Using subfunction 0x15

00:14:09: LOCAL:Max noise margin for power cutoff 31

00:14:09: DSL: Sent command 0x3

00:14:12: DSL: 1: Modem state = 0x8

..... etc....

=========================

I don't understand message "DSL: Open failed: Req. min. rate + noise margin + PSD not possible on the line -- retrying".

Showing the router ATM interface it is always "ATM0 is down, line protocol is down".

Follow the router configuration:

=================

ip dhcp excluded-address 10.10.10.1

!

ip dhcp pool avvenk

network 10.10.10.0 255.255.255.240

default-router 10.10.10.1

dns-server 130.244.127.161 130.244.127.169

!

interface Ethernet0

ip address 10.10.10.1 255.255.255.240

ip nat inside

ip virtual-reassembly

no ip mroute-cache

no cdp enable

hold-queue 100 out

!

interface ATM0

no ip address

no ip mroute-cache

no atm ilmi-keepalive

dsl operating-mode auto

hold-queue 224 in

pvc 8/35

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

!

interface Dialer1

ip address negotiated

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

!

ip nat inside source list 105 interface Dialer1 overload

!

access-list 105 permit ip 10.10.10.0 0.0.0.15 any

!

======================

Also I have tried under pvc 8/35 this encapsulation:

pvc 8/35

encapsulation aal5snap

protocol ppp dialer

dialer pool-member 1

but the result doesn't change.

Note that the command "ip virtual-reassembly" has been implemented from last IOS automatically.

.

IOS version is 12.3(14)T6.

.

Have you any suggestions ?

Many Thanks in advance,

Luca


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
nethelper Fri, 02/10/2006 - 14:31
User Badges:
  • Silver, 250 points or more

Hello Luca,


a couple of things: is this the full configuration of your router ? What authentication are you using ?

Make sure your configuration looks like this:


ip dhcp excluded-address 10.10.10.1

!

ip dhcp pool avvenk

network 10.10.10.0 255.255.255.240

default-router 10.10.10.1

dns-server 130.x.x.x.x.x.169

!

interface Ethernet0

ip address 10.10.10.1 255.255.255.240

ip nat inside

ip virtual-reassembly

no ip mroute-cache

no cdp enable

hold-queue 100 out

!

interface ATM0

no ip address

no ip mroute-cache

no atm ilmi-keepalive

--> dsl operating-mode ansi-dmt

hold-queue 224 in

pvc 8/35

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

!

interface Dialer1

ip address negotiated

ip nat outside

-->ip mtu 1452

or

-->ip tcp adjust-mss 1452

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

-->ppp authentication pap chap callin

-->ppp chap hostname username

-->ppp chap password password

-->ppp pap sent-username [email protected] password password

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

!

ip nat inside source list 105 interface Dialer1 overload

!

access-list 105 permit ip 10.10.10.0 0.0.0.15 any

-->dialer-list 1 protocol ip permit


Can you try this and see if it makes a difference ?


Regards,


Nethelper

avvenk Sat, 02/11/2006 - 01:03
User Badges:

Hi Nethelper, nothing change....

Naturally the authentication was always present on router configuration.

But I think that encapsulation ppp should start only after interface atm0 will be up while interface atm0 remains down.

However I’ve modified the parameters from you suggested, but the result is the same.

On the contrary now is present in "debug atm event" also any "DSL: Open failed: Error in early non-CRC message or in first CRC-covered" message that was not present with the command "dsl operation-mode auto".

Send in attachment a little debug captured and full router configuration (password modified).

.

The problem seems to be to activate layer 1 atm interface.

Have you any other suggestion ?

Best Regards,

Luca




nethelper Sat, 02/11/2006 - 05:07
User Badges:
  • Silver, 250 points or more

Hello Luca,


can you take out:


--> dsl operating-mode ansi-dmt


and configure what you had in originally (dsl operating-mode auto) ?


I am not sure if the configuration is the problem, it looks more like a physical problem. Can you get your provider to test the line up to your modem ?


Regards,


Nethelper

avvenk Sat, 02/11/2006 - 09:06
User Badges:

Hi Nethelper,

in this moment I'm testing a US Robotics SureConnect ADSL4-P.... and It seems work fine.

Unfortunately on the same link with Cisco 827 not work.

I don't know if SP is playing with ADSL line (I hope no !!!) or if Cisco atm HW adapter is more noice touchy that US Rob atm adapter or if Cisco IOS cause the prb.

I'm investigating on problem and will inform you as soon as possible.

Have you a nice day,

Best RGDS, Luca

avvenk Sat, 02/11/2006 - 16:00
User Badges:

Hi Nethelper, good news...

Internet SP is Tele2 but telephony Company is Telecom.

On telephony line there were connected 3 phones (one line with 3 star connection) on which was installed a adsl-filter to each phone.

Unfortunately, another star connection finished under the building floor and here, to the end, was connected a broken/dusty phone (without ring...).

Disconnecting this phone the adsl link go up on 827H.

.

Then,for test, we have re-connected the phone after a adsl filter and the link remain up.

.

It's very strange, but only one phone connected (and not used) without adsl-filter doen't permit the link to go up on Cisco equipment.

And also on US-Robotics link was not stable (went up and after about two minutes down and then again up).

.

Sorry for trouble, but your suggestions have been important for me to solve this strange problem.

Best Regards, Luca

Actions

This Discussion