boot second image in Rommon

Unanswered Question
Feb 13th, 2006

Is there a way from the Rommon prompt to boot from the second image in Flash ?

I have a 2651XM and the first image is corrupted, but I believe the second image is ok.

Thanks, Gardner

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
rasoftware Mon, 02/13/2006 - 08:43

You can issue the to boot from an alternative IOS in flash.Where file name = the alternative IOS.

thisisshanky Mon, 02/13/2006 - 09:33

I think the command was "boot flash:. "

Revert back with which command is correct.

gcyeaw Mon, 02/13/2006 - 10:18

I tried the 'boot'commands, but the message is always 'reset the router first' which boots the router from the first code load. I don't see how to enter the 'boot' command on it's own?

Gardner

thisisshanky Mon, 02/13/2006 - 10:43

Gardner,

Can you paste the boot sequence, after you type the boot commands ? (Basically a log of what you are typing on the console)

Also paste output of,

dev (hit return)

dir flash: (hit return)

HTH

Sankar.

gcyeaw Mon, 02/13/2006 - 11:06

Sankar,

What I mean is that when I enter a boot command the router returns the message "Please reset before booting'. So you cannot use the boot command. Have you tried it on a router?

Gardner

thisisshanky Mon, 02/13/2006 - 12:28

Gardner,

I have used the boot command before. I just dont remember off top of my head..how this command behaved. I dont have router with me now, when I get back home, i will check on one of my home routers and get back to you tomorrow. I have a 2600 that I can test the same.

HTH

Sankar.

thisisshanky Mon, 02/13/2006 - 22:35

Gardner,

I verified the commands I suggested at my home 2600 router and it works with out mistake.

Please see attached text file for boot sequence.

a. dev (+ return key) - will show you list of available devices. What we are interested in is "flash:"

b. dir flash: will show list of files in flash. In your case you should see two files

c. boot flash: should boot from the image you specify.

HTH

Sankar

PS: please remember to rate posts!

Attachment: 
gcyeaw Tue, 02/14/2006 - 06:41

Sankar,

Attached is what I get when I follow your procedure. There seems to be no way to execute the boot comand. If I do a reset, i wind up with the same results.

Attachment: 
thisisshanky Tue, 02/14/2006 - 07:53

Gardner,

That is weird. My router is a non XM, yours is an XM. Its possible that different versions of rommon may behave differently.

Going an alternate route, If you have the same image (valid checksum) in a TFTP server, you can try booting the router using TFTPDNLD process.

http://www.cisco.com/en/US/products/hw/routers/ps259/products_tech_note09186a008015bf9e.shtml

HTH

Sankar.

gcyeaw Tue, 02/14/2006 - 08:37

Sankar,

I will open a TAC case. Most likley things have changed and I haven't found any documentation that explains it. Thanks for your help, now I know I am not crazy.

Gardner

thisisshanky Tue, 02/14/2006 - 09:26

Gardner,

I take that back when I said, you may have the option to use TFTPDNLD. Even after TFTPDNLD you may end up having the problem with booting using the boot command.

One alternative I may suggest is to try upgrading the image using RXBoot mode. Not sure if your router has an rxboot image, but you may as well give it a try.

confreg 0x2101

reset

If the router has an RXBOOT image, it will boot to Rxboot mode. then you may use copy tftp flash to load the image into flash.

Sankar.

gcyeaw Tue, 02/14/2006 - 12:06

Sankar

I have the answer>>>>

rommon 1 > dev

Devices in device table:

id name

flash: flash

rommon 2 > dir flash:

File size Checksum File name

5571972 bytes (0x550584) 0xd7b5 c2600-i-mz.122-29a.bin

5548272 bytes (0x54a8f0) 0x3aa9 c2600-i-mz.122-17.bin

rommon 3 > BOOT=flash:c2600-i-mz.122-17.bin

rommon 4 > sync

rommon 5 > reset

Gardner

thisisshanky Tue, 02/14/2006 - 12:13

Gardner,

Thats good news! Didnt think about the ENV variables. Good catch!

Sankar.

Actions

Login or Register to take actions

This Discussion

Posted February 13, 2006 at 8:20 AM
Stats:
Replies:13 Avg. Rating:
Views:1540 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard