×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Intermittent DTMF tones missing

Unanswered Question
Feb 14th, 2006
User Badges:

I have a few users that are reporting one of two problems :


1) They will make an external call to a voice menu application, when they press a key, sometimes their chioce will be ignored and they notice they do not hear a DTMF tone being generated. They then hangup the call, dial the same number and the call will continue correctly, their menu choice is accpeted and they do hear the DTMF tone on that ocassion.


2) A user accepts an external call, goes to transfer the call, presses transfer and then no number keypresses are acknowledged (they see no numbers appear on the screen or do not hear DTMF etc.). They then have to take the original caller off hold and give the number to dial direct themselves. Again, this is happening intermittently.


Using CM4 with H.323 gateway, it has "dtmf-relay h245-alphanumeric" config. Phones are 7940. We are using a 3rd party call centre app that does has control of the handsets.


Any ideas ? How is the DTMF tone generated ? Does the phone report to Call Manager "9 key has been pressed" and

Call Manager reply "generate DTMF for 9" (in the same way I understand dial-tone is initiated). Could this indicate a problem with signalling/comm to Call Manager ? or is this function contained within the phone itself. Could the 3rd party call centre be affecting this ?


The only thought on the intermittent cause I had was if there was network congestion and the CM signalling was being lost, is this feasible (if their was a problem with prioritising signalling traffic) ?


It is happening on enough phones to rule out a fault with the actual handset. I have not yet been able to identify whether the problem exists with non-call centre users on the same site (this users are on a seperate site to the CM and Call Centre App servers).

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
adignan Tue, 02/14/2006 - 06:07
User Badges:
  • Blue, 1500 points or more

Can you post your config?


If its intermittent like that, you could be having "echo" issues.


andy - berbee

anup.anand Wed, 02/22/2006 - 23:55
User Badges:
  • Silver, 250 points or more

Recently I read somewhere that Callmanager sends DTMF tones using h245-signal but will only accept DTMF using h245-alphanumeric. Please try changing to h245-signal at the gateway and see if that helps.


Regards,


Anup

Actions

This Discussion