×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Multiplexer hardware

Answered Question
Feb 16th, 2006
User Badges:

I currently am using a WIC, which has an ethernet cable T1 connected to it, and we're considering getting a MUX to tie in an additional T1 for more bandwidth. I can see how the MUX would connect from the MUX to the provider, but what about from the MUX to my router? Do I need a different module than the WIC to do this, or do I need to just change the config on my single WIC to include 48 channels, or would I need to use a 2nd WIC to utilize the second T1? Or, are none of my ideas correct?


thank you,


Bill

Correct Answer by pkhatri about 11 years 6 months ago

Yeah, I would be hesitant to use MPPP with a 1721 at one end...


The reason why you would use a physical layer mux is to get your link to appear as one single interface on your router.


The difference between doing that and using CEF is a subtle one. CEF will load-balance per-destination over each line. This means that the maximum rate acheived by a single flow can be no more than the size of a single link since a single flow will not be sent out over more than one link (since this could cause packet re-ordering issues). That means that if you do something like a FTP download, the max you will get is a single T1 rate. This limitation is not much of an issue if you have got lots of different flows flowing over the link.


The following link has a good discussion of nxE1/T1 links:

http://www.cisco.com/en/US/products/hw/modules/ps2033/products_white_paper09186a0080091d4b.shtml


http://www.cisco.com/en/US/products/hw/modules/ps2033/products_white_paper09186a0080091d4b.shtml

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.3 (4 ratings)
Loading.
pkhatri Thu, 02/16/2006 - 04:16
User Badges:
  • Purple, 4500 points or more

Hi Bill,


If you have two T1s, a good option is to use Multilink PPP to combine them. This results in a single multilink interface, which has the combined bandwidth of 2*T1. You then do all your configuration on the T1 instead of the individual serial interfaces.


Here's a sample config:


Router 1

========

interface Multilink1

ip address 10.1.1.1 255.255.255.0

no cdp enable

ppp multilink

ppp multilink group 1

!

interface Serial0

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 1

!

interface Serial1

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 1


Router 2

========

interface Multilink1

ip address 10.1.1.2 255.255.255.0

no cdp enable

ppp multilink

ppp multilink group 1

!

interface Serial0

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 1

!

interface Serial1

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 1



Hope that helps - pls rate the post if it does.


Paresh



WILLIAM STEGMAN Thu, 02/16/2006 - 04:29
User Badges:

Ok, that definately helps. From the hardware aspect though, so I do need to use 2 serial interfaces, 2 WICs, and tie them to a multiplexer, which then leads to my provider, and then I need 2 more serial interfaces, and 2 WICs, on my remote router as well? I'm really trying to get a clear idea on the hardware we need to purchase.

pkhatri Thu, 02/16/2006 - 15:54
User Badges:
  • Purple, 4500 points or more

Howdy,


There is really no need to get a multiplexer. You can use two separate T1 lines and plug them into 2 serial interfaces on your router. For all intents and purposes, the lines are physically separate. You just combine them at the logical layer.


So the equipment you need is: 2 serial interfaces at each end.


One word of caution, though.. Multilink PPP is CPU-intensive so you need a reasonable platform to make this work. What routers are you using ?


Even if you find that the CPU on your box is taking a bit of a hit, you should still be able to use two separate T1s without Multilink PPP and then use CEF to provide load-sharing over them.


Hope that helps - pls rate the post if it does.


Paresh

WILLIAM STEGMAN Fri, 02/17/2006 - 05:44
User Badges:

I have a 2811 on one end, and a 1720 on the other end. The 1720 is a little weak, 24MB of memory.


I see. So with 2 lines, why use a multiplexer? What sort of situtaion would warrant the use of a multiplexer?


thx,


Bill

Correct Answer
pkhatri Fri, 02/17/2006 - 13:23
User Badges:
  • Purple, 4500 points or more

Yeah, I would be hesitant to use MPPP with a 1721 at one end...


The reason why you would use a physical layer mux is to get your link to appear as one single interface on your router.


The difference between doing that and using CEF is a subtle one. CEF will load-balance per-destination over each line. This means that the maximum rate acheived by a single flow can be no more than the size of a single link since a single flow will not be sent out over more than one link (since this could cause packet re-ordering issues). That means that if you do something like a FTP download, the max you will get is a single T1 rate. This limitation is not much of an issue if you have got lots of different flows flowing over the link.


The following link has a good discussion of nxE1/T1 links:

http://www.cisco.com/en/US/products/hw/modules/ps2033/products_white_paper09186a0080091d4b.shtml


http://www.cisco.com/en/US/products/hw/modules/ps2033/products_white_paper09186a0080091d4b.shtml

pkhatri Sun, 02/19/2006 - 17:25
User Badges:
  • Purple, 4500 points or more

Hi,


I'm not exactly sure which bits of config you want but here's the config you need to get the E1 up and running ...


controller e1 x/y

clock source line

linecode hdb3 ! you can use 'ami' if that's what your provider is using

channel-group 1 unframed

no shutdown


Once you do that, you will be able to configure the associated serial interface.


Hope that helps - pls rate the post if it does.


Paresh

ajurkevich Tue, 05/23/2006 - 10:09
User Badges:

Hello Paresh,


This my first time here, so pls forgive me if I missed something . . .


With respect to the configuration that you posted, I do have some questions:


1) If we would be linking 3 T1 circuits, what is the best choice for a router and how much memory should it have, etc. (We're thinking about a 2811 series router, 2 dual WIC cards, etc.)?


2) We only have 1 location, and 3 T1 circuits coming to us from our ISP (Verizon) which will terminate at our single router. What is the best way to setup multilink ppp? Could you provide a configuration example?


3) In your opinion, would we have to work with our ISP (Verizon) to have them setup a certain configuration on their end (as opposed to just an ordinary setup (i.e., three T1 circuits coming in, each with its own ip address and subnet mask, etc.). We already have a routable block of ip addresses that we are currently using.


Any help that you can provide would be great.


Thanks,


Alex

ajurkevich Tue, 05/23/2006 - 10:12
User Badges:

Hello Paresh,


This my first time here, so pls forgive me if I missed something . . .


With respect to the configuration that you posted, I do have some questions:


1) If we would be linking 3 T1 circuits, what is the best choice for a router and how much memory should it have, etc. (We're thinking about a 2811 series router, 2 dual WIC cards, etc.)?


2) We only have 1 location, and 3 T1 circuits coming to us from our ISP (Verizon) which will terminate at our single router. What is the best way to setup multilink ppp? Could you provide a configuration example?


3) In your opinion, would we have to work with our ISP (Verizon) to have them setup a certain configuration on their end (as opposed to just an ordinary setup (i.e., three T1 circuits coming in, each with its own ip address and subnet mask, etc.). We already have a routable block of ip addresses that we are currently using.


Any help that you can provide would be great.


Thanks,


Alex

ajurkevich Fri, 05/26/2006 - 07:55
User Badges:

My belief is that multilink ppp utilizes separate circuits' bandwidth to take advantage of the maximum speed . . . if a single circuit fails, multilink ppp should continue to utilize the remaining working circuits . . .

Actions

This Discussion