×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

How to do client stability in wireless lans

Unanswered Question
Feb 20th, 2006
User Badges:

One of our client having Wireless LAN connectivity for their Education institute. WLAN established with cisco aironet 1230 G access points.


Problem is wireless clients are not stable to associated access points. Frquentley clients association changing from ap to ap. During this time client is disconnecting from the network till then associated to ap.


clients are using cisco and inbuilit wi-fi enabled laptops make (Acer,HP,IBM) please help how to make client stability in wireless networks and what could the possible reasons for avoiding of this type of situations.


The access points are located based on sitesurvey of only.


If anybody faced this type of problem please sugess me.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
pradeepde Fri, 02/24/2006 - 10:11
User Badges:
  • Bronze, 100 points or more

Intermittent connectivity issues can be due to RF interference. Try using different channel for the Access Points. Say for example if the AP is using channel 1 for communication try using channel 6 or channel 11. This should work.


scottmac Sat, 02/25/2006 - 07:12
User Badges:
  • Green, 3000 points or more

Many of the "built-in" nics are Intel. There are some long-standing issues between Intel wireless NICs and the Cisco APs.


Make sure your IOS on the APs is ~current (12.37JA2 is current, I believe), and get the clients updated as well.


I had a client with older Intel drivers that threw MIC errors .... if you receive two in one minute, it shuts down the radio on that AP for a while. Then he' switch to the next nearest AP and shut that one down ... then back to the original.


Updating to current drivers resolved the problem.


Interference can be an issue, as suggested by the first poster, try other channels.


If the NIC suports 'Bluetooth cooperation", enable that ... Bluetooth uses the entire 2.4 sepectrum and is seen by the 802.11b/g systems as noise.


Antenna placement can be an issue. Generally speaking, higher is better to maintain line-of-sight and coverage. Humans are built with a lot of water, and water absorbs these frequencies. If the antenna is blocked by passing people, that can be at least part of the issue.


You may need antennas with a different radiation pattern ... something that has higher gain or a pattern that more closely concentrates the signal to the coverage area.


It's hard to make a specific suggestion without specific information, but the above covers many of the usual problems.


Good Luck


Scott


lmslattery Wed, 03/08/2006 - 04:45
User Badges:

I have this same issue , Clients frequently jump between AP's I have however noticed that the WLC is briefly swapping the channel on my AP's and Swapping it back again , causing Associations to drop. This is kind of weird considering all of the Auto-RF options are disabled and I have set all AP channels to custom to hardcode channels. I have a TAC case open but haven;t got a satisfactory response yet



vramanaiah Tue, 05/02/2006 - 03:37
User Badges:

In our case, we have the exactly opposite situation.. :-)


Well, as i roam across the campus, i expect the client adapter to associate to its nearest AP (Obviously due to better signal strength). However, we observe the client continues to be associated to the original AP although the signal quality level are much much lower than the nearest AP.


Just want to know, if this is the normal behaviour as per standards? Also want to know, if there is any threshold setting that we can do on client adaptor where we can configure to choose a better AP when the SQ goes down with the associated AP.



There's no standard defined as to how/when a client will roam (I believe this is under IEEE development as 802.11r). The phenomena you describe is called the "bug-light" effect and is preferred over the connection breaking and re-scanning for another AP. The 350 cards used to have some of these knobs exposed but now it pretty much hamgs on for dear life until it reaches its receive sentitivity threshold.


That being said, one way to attempt to make faster cleaner roams this is to shrink the AP cell sizes by limiting data-rate shifting and decreasing AP transmit power. Another might be to increase the beacon rate to induce the device into roaming by more constant and better RSSI info from closer APs. This might also require a denser deployment of APs to provide RF continuity.

I don't think you can stop the dynamic RF updates, but you can limit the frequency of updated RF information so that it does not change the settings as often. There's a "config advanced <802.11a/802.11b> monitor" command set that I think lets you stretch out the timers to 3600 secs. Same as "Monitor Intervals" in the GUI under the Auto-RF Gloabl Parameters.


config advanced 802.11b monitor signal 3600

config advanced 802.11b monitor noise 3600

config advanced 802.11b monitor coverage 3600

config advanced 802.11b monitor load 3600


Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode