×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

I simply need to change Ip address but I can't

Answered Question
Feb 20th, 2006
User Badges:

I bought a Pix 501, in the configuration, I want to change the default inside interface ip address from 192.1.1.2 to 10.0.2.234, but each time I get an error, "Interface address is not on same subnet as DHCP pool"

So I decide to change the DHCP pool addresses and I get this error:"Address range subnet is not the same as inside interface"


So I can I force the change of those settings?

Correct Answer by lgijssel about 11 years 6 months ago

did this many times. perhaps u are not in config mode when trying to enter your changes?

To begin, your prompt should look like: pixfirewall#

Then enter the following:

conf t

no dhcpd address 192.168.1.2-192.168.1.33 inside

ip address inside 10.0.2.234 255.255.255.0

end

wr mem

This should do the job


Leo

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
lgijssel Mon, 02/20/2006 - 08:49
User Badges:
  • Red, 2250 points or more

You obviously have a defaulted pix at hand.

In the default config, a dhcp pool is created for the default inside-ip range.

To change it, remove the dhcp-pool first:

no dhcpd enable inside

no dhcpd address 192.168.1.2-192.168.1.254 inside


After that you can change the interface ip on the inside:

ip address inside 192.168.x.x 255.255.255.x


Regards,

Leo


openheart Mon, 02/20/2006 - 09:00
User Badges:

I tried your suggestion, but same problem.


Again, I need to change the default IP address to another subnet. But the Pix wont let me do it!


Some information about the config I have:

Show ip address:

show IP address

System IP Addresses:

ip address outside 199.243.183.XX 255.255.255.0

ip address inside 192.168.1.1 255.255.255.0

Current IP Addresses:

ip address outside 199.243.183.XX 255.255.255.0

ip address inside 192.168.1.1 255.255.255.0


show dhcpd

dhcpd address 192.168.1.2-192.168.1.33 inside

dhcpd lease 3600

dhcpd ping_timeout 750

dhcpd auto_config outside


I want to change the ip address(inside) with 10.0.2.234 and disable DHCPD

Correct Answer
lgijssel Mon, 02/20/2006 - 11:15
User Badges:
  • Red, 2250 points or more

did this many times. perhaps u are not in config mode when trying to enter your changes?

To begin, your prompt should look like: pixfirewall#

Then enter the following:

conf t

no dhcpd address 192.168.1.2-192.168.1.33 inside

ip address inside 10.0.2.234 255.255.255.0

end

wr mem

This should do the job


Leo

openheart Mon, 02/20/2006 - 11:27
User Badges:

Thanks it works! I probably did'nt enter the right command to disable dhcpd

Actions

This Discussion