STP Issues

Unanswered Question
Feb 27th, 2006

Hi there,

I have a network with 7 access layer switches connecting to 2 4507R switches. When i give a show standby brief on one of the core switches it gives the following output -

Interface Grp Prio P State Active addr Standby addr Group addr

Vl1 1 100 P Standby 10.128.0.201 local 10.128.0.200

Vl2 2 110 P Active local 10.128.8.201 10.128.8.200

Vl16 16 100 P Standby 10.128.16.2 local 10.128.16.1

Vl100 100 100 P Standby 10.128.100.2 local 10.128.100.1

Vl101 101 110 P Active local 10.128.101.2 10.128.101.1

Vl102 102 100 P Standby 10.128.102.2 local 10.128.102.1

Vl103 103 110 P Active local 10.128.103.2 10.128.103.1

Vl104 104 100 P Standby 10.128.104.2 local 10.128.104.1

Vl105 105 110 P Active local 10.128.105.2 10.128.105.1

Vl106 106 110 P Init unknown unknown 10.128.106.1

Vl200 200 100 P Standby 10.128.200.2 local 10.128.200.1

Vl201 201 110 P Active local 10.128.201.2 10.128.201.1

Vl202 202 110 P Active local 10.128.202.2 10.128.202.1

Vl203 203 100 P Standby 10.128.203.2 local 10.128.203.1

Vl204 204 110 P Active local 10.128.204.2 10.128.204.1

Vl205 205 100 P Standby 10.128.205.2 local 10.128.205.1

If you have a look, the switch doesnot know which is the active and the standby IP. Any clues.

Regards,

Rathish

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 4 (1 ratings)
ankurbhasin Tue, 02/28/2006 - 00:34

Hi Rathish,

The output is correct because you have just issued a command sh standby brief so the switcch is showing you the brief information with only the local state of that vlan on this particular switch.

If you issue a command "sh standby" it will give you a complete out including what is the ip address of the active or standby router and what is the current state of thhis interface on this switch etc etc.

Have a look at this output

router#show standby

FastEthernet0/0 - Group 1

State is Active

4 state changes, last state change 01:49:46

Virtual IP address is x.x.x.x

Active virtual MAC address is

Local virtual MAC address is (v1 default)

Hello time 3 sec, hold time 10 sec

Next hello sent in 0.244 secs

Preemption enabled

Active router is local

Standby router is x.x.x.x, priority 250 (expires in 8.108 sec)

Priority 154 (configured 254)

Track interface Serial0/0/0 state Down decrement 100

IP redundancy name is "hsrp-Fa0/0-1" (default

HTH, if yes please rate the post.

Ankur

rathish_ram Tue, 02/28/2006 - 01:28

Ankur,

Sorry about that. Please have a look at Vlan 106. I forgot to mention that. Thanks ih advance.

Regards,

Rathish

ankurbhasin Tue, 02/28/2006 - 01:59

Hi Ratish,

Your vlan 106 is in unknown state. Can you paste the "sh run int vlan 106" from both the peers.

Regards,

Ankur

rathish_ram Tue, 02/28/2006 - 02:42

Ankur,

Please find the config details below.

BAN-CORE-1#sh run int vlan 106

Building configuration...

Current configuration : 229 bytes

!

interface Vlan106

description : Data VLAN - MGIC 5th floor

ip address 10.128.106.2 255.255.255.0

ip helper-address 10.128.3.2

no ip redirects

standby 106 ip 10.128.106.1

standby 106 priority 100

standby 106 preempt

end

BAN-CORE-2#sh run int vlan 106

Building configuration...

Current configuration : 239 bytes

!

interface Vlan106

description : Data VLAN - MGIC 5th floor

ip address 10.128.106.3 255.255.255.0

ip helper-address 10.128.3.2

no ip redirects

shutdown

standby 106 ip 10.128.106.1

standby 106 priority 110

standby 106 preempt

end

Thanks in advance,

Regards,

Rathish

ankurbhasin Tue, 02/28/2006 - 02:48

Hi Ratish,

If you check on your BAN-CORE-2 router, interface vlan 106 is shutdown and that is the reason it is not processing the hello packet for HSRP and that is the reason your output in first post was showing unknown.

So go ahead and no shut the interface and things will work fine as expected.

HTH, if yes please rate the post.

Ankur

Actions

Login or Register to take actions

This Discussion

Posted February 27, 2006 at 11:40 PM
Stats:
Replies:5 Avg. Rating:4
Views:216 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard