Create 2 new VLANs and Trunk

Answered Question
Mar 1st, 2006
User Badges:

Hi


I am working with a service provider to segment inbound traffic for a client. Rather than creating a seperate fibre circuit, we have opted for two new VLANs and a trunk to the upstream router.


The equipment we are working on is a Cisco Catalyst 2900XL, IOS (tm) C2900XL Software (C2900XL-H-M), Version 11.2(8)SA2, RELEASE SOFTWARE (fc1)


Current configuration:

!

version 11.2

no service pad

no service udp-small-servers

no service tcp-small-servers

!

hostname

!

enable secret

!

ip subnet-zero

ip domain-name

ip name-server

!

interface VLAN1

ip address

no ip route-cache

!

interface FastEthernet0/1

speed 10

duplex full

spantree portfast

!

interface FastEthernet0/2

speed 100

duplex full

spantree portfast

!

interface FastEthernet0/3

spantree portfast

!

interface FastEthernet0/4

shutdown

spantree portfast

!

interface FastEthernet0/5

shutdown

spantree portfast

!

interface FastEthernet0/6

shutdown

spantree portfast

!

interface FastEthernet0/7

shutdown

spantree portfast

!

interface FastEthernet0/8

shutdown

spantree portfast

!

ip default-gateway

snmp-server community private

snmp-server community public

!

line con 0

exec-timeout 0 0

stopbits 1

line vty 0 4

password

login

!

end


I need to creat VLAN 2 and VLAN 3. Traffic currently running through VLAN 1 will be segmented between these two VLANs with a trunk to an upstream router.


vlan database commands don't appear to be working. At this stage I only want to create the VLANs. Can anyone recommend a command reference?

Correct Answer by pkhatri about 11 years 5 months ago

Ok, just did a quick search. With your release of software, you can only configure VLANs on the Enterprise edition of the software, which yours does not appear to be.


IOS 12.0(5)XU and later support both standard and enterprise edition features.


I suggest that you upgrade if you want to use VLANs.


Hope that helps - pls rate the post if it does.


Paresh

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (4 ratings)
Loading.
pkhatri Wed, 03/01/2006 - 14:12
User Badges:
  • Purple, 4500 points or more

Hi,


It's possible that your switch is running as a VTP client which will not allow you to create VLANs. Could you post the output of 'sh vtp status' ?


Hope that helps - pls rate the post if it does.


Paresh

stevenpaterson Wed, 03/01/2006 - 14:18
User Badges:

Hi Paresh!


Good to hear from you!


User Access Verification


Password:

>en

Password:

#sh vtp status

^

% Invalid input detected at '^' marker.


#


It doesn't accept the command.


Here are the results of a show ? from enable mode:


publicswitch#sh ?

access-lists

accounting

aliases

arp

boot

buffers

cdp

clock

configuration

controllers

debugging

file

forward

history

hosts

html

interfaces

ip

line

location

logging

mac-address-table

memory

port

privilege

processes

queue

queueing

registry

reload

rhosts

rmon

running-config

sessions

snmp

spantree

stacks

startup-config

subsys

tcp

tech-support

terminal

users

version


Thanks

glen.grant Wed, 03/01/2006 - 14:19
User Badges:
  • Purple, 4500 points or more

That is really old code , maybe that is causing your problems . I would try to upgrade if possible . What happens when you try commands within the vlan database ?

stevenpaterson Wed, 03/01/2006 - 14:21
User Badges:

Hi Glen


That was my initial thinking. I can't access the VLAN database.


publicswitch#vlan database

^

% Invalid input detected at '^' marker.




pkhatri Wed, 03/01/2006 - 14:28
User Badges:
  • Purple, 4500 points or more

It does seem like ancient code... can you post the output of 'sh ver'


Paresh

stevenpaterson Wed, 03/01/2006 - 14:31
User Badges:

IOS (tm) C2900XL Software (C2900XL-H-M), Version 11.2(8)SA2, RELEASE SOFTWARE (f

c1)

Copyright (c) 1986-1998 by cisco Systems, Inc.

Compiled Fri 24-Apr-98 10:51 by rheaton

Image text-base: 0x00003000, data-base: 0x001A582C


ROM: Bootstrap program is C2900XL boot loader


publicswitch uptime is 7 weeks, 4 days, 12 hours, 52 minutes

System restarted by reload

Running default software



cisco WS-C2908-XL (PowerPC403GA) processor (revision 0x11) with 4096K/1024K byte

s of memory.

Processor board ID FAA0239U0A3, with hardware revision 0x03

Board ID 0x04

Last reset from warm-reset

8 Ethernet/IEEE 802.3 interface(s)


32K bytes of flash-simulated non-volatile configuration memory.

Base ethernet MAC Address: 00:90:AB:E7:79:40

Configuration register is 0xF

Correct Answer
pkhatri Wed, 03/01/2006 - 14:39
User Badges:
  • Purple, 4500 points or more

Ok, just did a quick search. With your release of software, you can only configure VLANs on the Enterprise edition of the software, which yours does not appear to be.


IOS 12.0(5)XU and later support both standard and enterprise edition features.


I suggest that you upgrade if you want to use VLANs.


Hope that helps - pls rate the post if it does.


Paresh

Actions

This Discussion