×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

CCM -> CME -> CUE call path troubles.

Answered Question
Mar 10th, 2006
User Badges:

I've successfully intergrated CME and CUE and can make calls both ways between CME and my CCM cluster. However, when I call from CCM to CME and expect voicemail to pick up, my call gets dropped. I can call directly from CCM to CUE, so I know its not a route pattern issue. My dial-peers and telephony-service entries must be correct or I wouldn't be able to access voicemail from my CME phones. I've even tried configuring all possible "voice service voip" allow-connections entries between h323 and sip just in case. Any ideas? Thank you!


CUE version = 2.2

CME version = 3.4

CCM version = 4.1

router = 2621XM "c2600-adventerprisek9-mz.124-4.T1.bin"

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.3 (4 ratings)
Loading.
thisisshanky Fri, 03/10/2006 - 12:11
User Badges:
  • Purple, 4500 points or more

Chris,


You are correct that the problem here is that there are two voip legs (one from CCM to CME) and another (from CME to CUE). One is a h323 leg, while other is a sip leg. To hairpin both legs, you need,


voice service voip

allow-connections h323 to sip

redirect ip2ip


HTH


Sankar

PS: please remember to rate posts!

chris.lombardo@... Fri, 03/10/2006 - 14:11
User Badges:

Thank you for your response. I already had the allow-connections h323 to sip in place (I actually had configured all 4 possible options just in case), but did not have the redirect ip2ip line. Unfortunately, this did not solve my problem. My call is still dropped at the point that it should be handed over to voicemail. This was working with my current config when I was running CME 3.3, but after upgrading to 3.4, my problems started.

thisisshanky Fri, 03/10/2006 - 14:45
User Badges:
  • Purple, 4500 points or more

Chris,


Can you paste ur CME configs ? (passwords, public ips if any masked)


Sankar.

chris.lombardo@... Sat, 03/11/2006 - 19:24
User Badges:

My config (some non-important things removed to get below 4000 chars)


memory-size iomem 10

clock timezone EST -5

clock summer-time EDT recurring

no network-clock-participate slot 1

no network-clock-participate wic 0

ip subnet-zero

ip cef

!

no ip domain lookup

ip multicast-routing

ip sla responder

ip sla low-memory 2000000

ip rcmd rcp-enable

ip rcmd rsh-enable

ip rcmd remote-host root 10.42.5.50 IWAM_RALDTESTX-XXX enable

!

ipv6 unicast-routing

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

redirect ip2ip

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g729r8

!

dial-control-mib retain-timer 30

dial-control-mib max-size 400

!

class-map match-all voip-rtp

match ip rtp 16384 16383

class-map match-all voice

match ip rtp 16384 16383

class-map match-all httpc

match protocol http

!

policy-map queue-voip

class voip-rtp

priority 32

class class-default

fair-queue

policy-map httpp

class httpc

priority 8

police cir 1000000

conform-action transmit

exceed-action drop

class voice

priority 32

!

interface FastEthernet0/0

ip address 10.42.5.1 255.255.255.0

ip broadcast-address 10.42.5.0

no ip redirects

ip pim dense-mode

duplex auto

speed 10

ipv6 address FEC0:A2A:500::/64 eui-64

ipv6 enable

ipv6 rip 42 enable

service-policy output queue-voip

!

interface FastEthernet0/1

ip address 10.42.6.254 255.255.255.0

ip broadcast-address 10.42.6.0

ip helper-address 10.43.1.29

no ip redirects

ip pim dense-mode

duplex auto

speed 10

ipv6 address FEC0:A2A:600::/64 eui-64

ipv6 enable

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.42.6.254

service-policy output queue-voip

!

interface Service-Engine1/0

ip unnumbered FastEthernet0/1

ip broadcast-address 10.42.6.0

service-module ip address 10.42.6.1 255.255.255.0

service-module ip default-gateway 10.42.6.254

!

router rip

redistribute connected

redistribute static

network 10.0.0.0

!

ip default-gateway 10.42.5.254

ip classless

ip route 0.0.0.0 0.0.0.0 10.42.5.254

ip route 10.42.6.1 255.255.255.255 Service-Engine1/0

!

ip http server

no ip http secure-server

ip http path flash

ip pim bidir-enable

!

access-list 110 permit tcp any any eq www

access-list 110 deny ip any any

dialer-list 1 protocol ip permit

snmp-server enable traps tty

snmp-server manager

ipv6 route ::/0 FEC0:A2A:500:0:208:E3FF:FE0B:F5C1

ipv6 router rip 42

redistribute connected

!

control-plane

!

dial-peer cor custom

!

dial-peer voice 2999 voip

destination-pattern 2[0-8]..

voice-class codec 1

session target ipv4:10.41.5.30

!

dial-peer voice 2000 voip

destination-pattern 297.

voice-class codec 1

session protocol sipv2

session target ipv4:10.42.6.1

dtmf-relay sip-notify

no vad

!

dial-peer voice 9999 voip

destination-pattern 9.T

voice-class codec 1

session target ipv4:10.42.4.254

!

dial-peer voice 7 voip

destination-pattern 7....

voice-class codec 1

session target ipv4:10.42.4.254

!

telephony-service

load 7910 P00403020214

load 7960-7940 P00307020200

load ATA ATA030100SCCP040211A

load 7905 CP7905060000SCCP050124A

load 7902 CP7902060000SCCP050124A

load 7971 TERM70.7-0-1-0s

load 7970 TERM70.7-0-1-0s

load 7936 cmterm_7936.3-3-5-0

load 7912 CP7912060000SCCP050124A

max-ephones 25

max-dn 192

ip source-address 10.42.6.254 port 2000

auto assign 1 to 192

time-zone 12

create cnf-files version-stamp 7960 Feb 21 2006 11:17:36

voicemail 2975

max-conferences 4 gain -6

moh music-on-hold.au

web admin system name test password

!

ephone-dn 1 dual-line

number 2950

name

call-forward busy 2975

call-forward noan 2975 timeout 10

!

ephone-dn 2

number 2951

name ATA1

call-forward busy 2975

call-forward noan 2975 timeout 18

!

ephone-dn 4

number 2978....

mwi on

!

ephone-dn 5

number 2979....

mwi off

anup.anand Fri, 03/10/2006 - 22:43
User Badges:
  • Silver, 250 points or more

This could be related to a codec issue as CUE supports only G711. If the call from Callmanager IP Phones use G729, then you would need transcoders.


You might want to check if you have transcoders available in the Callmanager to process these calls.


Regards,


Anup


chris.lombardo@... Tue, 03/14/2006 - 12:23
User Badges:

Thank you Anup. Unfortunately, I don't believe this is my problem because I can dial directly into CUE via my CCM phone. The only path which causes me issue is going from CCM->CME->CUE.

Actions

This Discussion