How works the distribute-list acl out in the eigrp routing?

Unanswered Question
Mar 17th, 2006

I have two WAN interfaces that one for dark fiber Giga and the other 100M LE. the Giga is single VLAN and the LE is trunk with two VLANs that Data and Voice.

In normal operation, send all traffic to Giga and LE will take over when outage the Giga but should forward separately the Data and Voice into the LE.

If I configure as follows, how works in normal(Giga and LE both running) and in Giga outage mode. and will it meet my goal?

!

router eigrp 100

network 10.0.0.0

distribute-list Data out vlan_data

distribute-list Voice out vlan_voice

!

Thanks in advance,

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
griffijo@elizab... Sun, 03/19/2006 - 14:35

distribute-lists control the routing updates that a router will either accept (in) or forward (out)

For instance, in the following example a router will only advertise or accept, via EIGRP, routes for 10.232.0.0

router eigrp 1

network 10.232.20.0 0.0.0.3

network 10.232.20.5 0.0.0.0

network 10.232.20.8 0.0.0.7

distribute-list 10 out

distribute-list 10 in

no auto-summary

no eigrp log-neighbor-changes

access-list 10 permit 10.232.0.0 0.0.255.255

access-list 10 deny any log

If I understand you correctly, you want to use the 100m link as a failover in case the 1g link goes down. This type of behavior is inherent to EIGRP. EIGRP only does equal cost load-balancing, unless you configure a variance, so it would see the 1g link as the better path and install that route in the routing table. If the 1g link goes down the 100m link would be a feasible successor and that route would then be installed in the routing table. You really shouldn't have to do anything.

cjrchoi11 Mon, 03/20/2006 - 10:22

Thanks the reply,

I may not explained correctly. my goal is 1G link as primary in normal operation and 100M as backup. while the 100M backup, I want to separate the Data and Voice into separate VLANs.

Let me say Data VLAN 10(10.10.0.0) and Voice 20(10.20.0.0).

!

router eigrp 100

network 10.0.0.0

distribute-list 10 out vlan10

distribute-list 20 out vlan20

!

access-list 10 permit ip 10.10.0.0 0.0.255.255

access-list 20 permti ip 10.20.0.0 0.0.255.255

!

If I don't have distribute-list, will work 1G as primary and 100M as backup but cannot separate the Data and Voice in the 100M link mode.

.

with distribute-list, I'm wonderting what's priority. 1G or distribute-list. if the Data and Voice take the distribute-list rule, will never take the 1G link and that's not my intension. please advise.

Actions

Login or Register to take actions

This Discussion

Posted March 17, 2006 at 3:13 PM
Stats:
Replies:2 Avg. Rating:
Views:160 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard