×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

IDLE URL and Authentication problem

Unanswered Question
Mar 25th, 2006
User Badges:
  • Purple, 4500 points or more

Test lab setup. Nothing in production. So any changes can be made as suggested.

------------


I was setting up IDLE URL for ip phones on Callmanager. I installed the SDK in the callmanager server itself (Even though its not recommended to install it in the callmanager server itself). The install completed smooth, with an additional component called Cisco URL Proxy installed along with the SDK. I converted an image to grayscale and resized the image to 125*60, and converted it to an xml file. Copied the XML file over to CCMCIP folder and specified the idle url as required, with a idle timeout of 5 seconds.


This is what I get on the phone, instead of the logo show up, I see an authentication screen with three fields,


a. Username

b. Pwd

c. Realm.


Why is this happening ? I am getting this same prompt when I hit the Services button or Corporate Directory ?


I tried uninstalling the SDK and Cisco URL Proxy, with no luck?


Sankar.


PS: please see attached picture.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (2 ratings)
Loading.
aaronw.ca Mon, 03/27/2006 - 07:43
User Badges:
  • Silver, 250 points or more

I am guessing that IIS is configured to not allow anonymous access to that virtual directory. So it's an IIS configuration issue and not an SDK issue. It should be easy to fix - you just have to enable anonymous access to the CCMCIP virtual directory in IIS using IIS Administrator.


Here are some steps you can use to check the setting. Sorry if they're overly verbose - you probably know how to do this anyway but I'm just including it for clarity (and in case others have this problem as well):


1. Open the IIS Administrator/IIS Manager (found in Control Panel - Administrative Tools). IIS Administrator/IIS Manager should open, showing you a tree view on the left side with the web server as the root node.


2. Expand the tree on the left side until you see a list of Web Sites defined in IIS, including the Default Web Site. There should be other virtual directories there, including CCMCIP.


3. Right-click on the CCMCIP virtual directory and click Properties. A dialog box should appear with around 8 tabs on it.


4. Switch to (click on) the Directory Security tab


5. Click the Edit button at the top of the dialog (in the Authentication and Access Control section). This will open another dialog listing the authentication methods used to access this virtual directory.


6. If the "Enable anonymous access" checkbox is unchecked, then that's your problem - Click on the checkbox to enable anonymous access and click the OK button to save the settings. Click the OK button on the CCMCIP properties to save these settings and that should return you to IIS Administrator/IIS Manager.


Try the app again, and see if it's fixed.

thisisshanky Mon, 03/27/2006 - 17:43
User Badges:
  • Purple, 4500 points or more

Aaron,


Anonymous access for CCMCIP folder was checked by default. So no worries there.


The anonymous user account was set to IUSR_Guest. I found a different entry in another working callmanager to be CCMUser for anonymous access. I changed the username from IUSR_Guest to CCMUser and restarted IIS service. Now if i hit the services button or idle url is set, it shows the html file as such in the ip phone screen..



aaronw.ca Tue, 03/28/2006 - 06:10
User Badges:
  • Silver, 250 points or more

Hmmm, I wonder how that happens. I've seen that before. So it looks like you fixed the access restrictions.


Are the services working now, or are they displaying the raw html text on the phone instead of xml? If it's displaying the text of the html/xml file, then either the content type is not set (in which case the phone treats it like text, and displays the contents instead of interpreting the XML elements), or there is a problem with the service and the service is returning HTML and not Cisco XML...

thisisshanky Tue, 03/28/2006 - 08:12
User Badges:
  • Purple, 4500 points or more

Aaron,


It is showing the contents of the HTML file as such.

What do you suggest next ? This is happening for all the asp/xml files hosted in the CCMCIP directory. (Services button and IDLE url show raw html, Corporate directory button is missing- gives a HTML 500 error). It looks like 500 is "Internal server error".


Sankar.

aaronw.ca Tue, 03/28/2006 - 08:30
User Badges:
  • Silver, 250 points or more

What happens if you try calling the service from a web browser? You should see a bunch of Cisco XML, such as CiscoIPPhoneText or CiscoIPPhoneMenu, etc.


So when you press the services button, you get some type of raw XML, such as:


...



Is that correct? What is the URL of your service URL? What is the URL for your IDLE URL?


If they are .xml files, then you probably have to add the .xml mime type to the CCMCIP virtual directory in IIS Manager, and map .xml to text/xml.

Actions

This Discussion